Aller au contenu

Rechercher dans la communauté

Affichage des résultats pour les étiquettes 'get'.



Plus d’options de recherche

  • Rechercher par étiquettes

    Saisir les étiquettes en les séparant par une virgule.
  • Rechercher par auteur

Type du contenu


Forums

  • Bienvenue
    • Nouveau ? Présentez-vous
    • Le bistrot
    • Mon installation domotique
    • Annonces et suggestions
  • La Home Center et ses périphériques
    • La Home Center pour les nuls
    • HC 2 & Lite
    • HC 3
    • Modules Fibaro
    • Modules Z-wave
    • Périphériques et matériels autres
    • Plugins
    • Quick App
    • Multimédia (audio, vidéo ...)
    • Chauffage et Energie
    • Actionneurs & Ouvrants (Portail, volets, piscines, ...)
    • Eclairage
    • Applications Smartphones et Tablettes
  • Autres solutions domotiques
    • Box / Logiciel
    • Modules Nice (433 & 866 MHz)
    • Modules Zigbee
    • GCE Electronics
    • Modules Bluetooth Low Energy
  • Objets connectés
    • Les Assistants Vocaux
    • Netatmo
    • Philips Hue
    • DIY (Do It Yoursel)
  • Sécurité
    • Alarmes
    • Caméras
    • Portiers
    • Serrures
  • Informatique / Réseau
    • Tutoriels
    • Matériels Réseaux
    • Matériels Informatique
    • NAS
    • Virtualisation
  • Les bonnes affaires
    • Sites internet
    • Petites annonces

Rechercher les résultats dans…

Rechercher les résultats qui…


Date de création

  • Début

    Fin


Dernière mise à jour

  • Début

    Fin


Filtrer par nombre de…

Inscription

  • Début

    Fin


Groupe


Jabber


Skype


Ville :


Intéret :


Version

2 résultats trouvés

  1. jojo

    Requêtes Http /get Sur Hcl

    Edit : regardez également ce post pour une info plus récente : http://www.domotique-fibaro.fr/index.php/topic/5935-requ%C3%AAtes-get-et-put-sur-hcl-synth%C3%A8se-de-celles-qui-fonctionnent/ Bonsoir, Je vois que beaucoup de monde se casse les dents sur les requêtes http sur HCL. Je précise que ce que je décris ici fonctionne avec la dernière version du firmware 3.593 1) créer un virtual device et préciser l'IP et le port (80) du HCL 2) dans la partie script de chaque bouton, entrez le string suivant qui contient la commande GET GET<space><command><space>HTTP/1.10x0D0x0AHost:<IP:port><space>0x0D0x0AAuthorization:<space>Basic<space><user:pwd inBase64><space>0x0D0x0A0x0D0x0A N.B. : remplacer <space> par un espace remplacer <command> par la commande GET à passer remplacer <user:pwd inBase64> en le calculant https://www.base64encode.org/. Pour user = admin; pwd = admin, le texte à encoder est admin:admin, ce qui donne YWRtaW46YWRtaW4= respecter SCRUPULEUSEMENT la syntaxe ci-dessus, y compris les espaces. Pour la liste de ce que vous pouvez passer comme requêtes, voir le post de moicphil http://www.domotique-fibaro.fr/index.php/topic/1321-ex%C3%A9cuter-et-stopper-une-sc%C3%A8ne-par-http/ Beaucoup de plaisir à toute la communauté
  2. Bonjour à tous, Après de très longues heures de recherches et d'essais infructueux, je m'en remets à vos connaissances pour ma problématique actuelle. Je cherche à automatiser l'envoi de SMS vers mon téléphone et également détecter la présence de mon iPhone sur le réseau local (en me basant grossièrement sur ce post). Tout est possible en utilisant les API disponibles sur mon réseau local. C'est-à-dire qu'une certaine adresse IP avec les bons paramètres enverra un SMS et l'IP de ma HC2 avec les bons paramètres appuiera sur le bouton d'un VD. Les URL d'accès à ces API fonctionnent en direct depuis mes navigateurs, ce qui prouve leur bon fonctionnement. Mais malheureusement, cela se gâte dès que ça n'est plus en direct ! Pour communiquer depuis la HC2 vers l'API SMS, je suis tombé sur ce type de code : HC2 = Net.FHttp(«http://192.168.2.10») response = HC2:GET(«?user=user&password=pass&to=0612345678&from=0123456789&text=Salut!») Malheureusement, impossible d'en faire quoi que ce soit, ça ne fonctionne pas, sans que je puisse l'expliquer. Je rencontre également des grosses difficultés pour communiquer de mon NAS (Docker) vers la HC2. Que je tente la ligne du script dont je m'inspire : curl -s -X PUT -d '{"value": "Present"}' http://$login:$password@$hc2ip/api/globalVariables/$nomvariable Ou en cherchant/essayant des solutions diverses et variées, après m'être renseigné sur les différentes utilisations des requêtes ici et là, parmi tant d'autres, ça ne donne rien non plus. Je précise que l'utilisateur en question a bien accès aux éléments nécessaires pour agir sur ceux-ci dans la HC2. De plus, j'ai effectué mes essais en désactivant l'ensemble des pare-feux présents sur mon réseau, mais rien n'y fait ! C'est un peu comme si ces requêtes étaient bloquées, mais je ne vois vraiment pas à quel niveau. Ou alors y'aurait-t-il simplement quelque chose d'énorme à côté duquel je serai passé ? Je vous remercie du temps passé à la lecture de ce message !
×