Aller au contenu
ADN182

Addon Xbmc Kodi By Adn182

Recommended Posts

1er post mis à jour avec les nouvelles fonctionnalité + Intégration GEA.

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

ça fait un moment que j'étais plus venu voir ce fil, impressionnant l'évolution :60: Je vais mettre à jour mon système ce week-end

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

I installed the latest version (1.4), with a Kodi scene and the Virtual device (Kodi v1.vfib)

 

But in the Debug log I get the following error:

 

Debug scene.PNG

 

Am I doing something wrong?

Modifié par bumperke

Partager ce message


Lien à poster
Partager sur d’autres sites

Hier @bumperke, that seam to be an authentification  problem. Have you an Access to Kodi interface with login and password via your webrowser ? 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, ADN182 a dit :

Yesterday @bumperke , that seam to be an authentication problem. Have you an Access to Kodi interface with username and password via your webrowser? 

 

@ADN182, Yes I can access the Kodi interface with a webbrowser (without a username and password)

Partager ce message


Lien à poster
Partager sur d’autres sites

@ADN182 I'm using Kodi v18. So I think that's the reason why it's not working. Will there be a new version of the HC2 Addon for Kodi v18 (in the future) ?

Partager ce message


Lien à poster
Partager sur d’autres sites

salut a tous

 

sur mon raspberry mon XBMC a disparu et impossible de le trouver pour l’installer de nouveau.

 

savez-vous si le plugin existe toujours ?

 

merci de votre aide 

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, 

 

Post mis à jour, scène mis à jour pour Kodi v18.

 

@bumperke, post updated with the new scene for kodi v18

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut ADN,

J'ai mis à jour ta dernière version qui a fortement évolué et je suis aussi passé sur Kodi 18.

ci dessous quelques anomalies constaté il me semble bien avoir suivi le post mais surement j'ai loupé quelque chose et après 2 jours ou je tourne en rond j'en viens à te demander un peu d'aide.

1- L'addon fonctionne mais je n'ai que le "video_started" qui n'est pas détecté malgré qu'il est activé ? les autres Ras.

Je crois que je ne suis pas le seul et pourtant il me semble avoir lu que tu avais fait une correction dans les dernières version, mais sans succès pour moi.

2- A partir du VD lorsque je lance une action (play, pause, avance...) l'action est bien visible dans le debug de la scène mais kodi ne répond pas, rien ne se passe ? 

Une piste ??

 

Merci d'avance, et encore félicitation pour l'évolutions de l'addon.

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello Fred, 

 

Alors j'ai testé ça fonctionne bien à la maison :), j'ai déjà eu ça comme problème, le play tu le fait pour un vidéos par pour une chaine TV ?


Je vais regarder sur le forum quelqu'un à déjà eu le problème, Tu sais poster le code de ta scène ? 

 

Pour point 2, au niveau de Kodi tout est ouvert ? Tu as mis un utilisateur et mot de passe ? "Difficile" de tester via navigateur désormais comme c'est de la méthode POST, à moin d'une module via Navigateur ou POSTMAN. 

 

 

Modifié par ADN182

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut

 

Alors le play est pour une vidéo.

 

Pour ma scène je l'ai mise en pièce jointe.

 

Pour le paramètrage kodi oui tout est ouvert, utilisateur et mot de passe ok, les autres fonction de la scène sont activent et ne me pose pas de soucis hormis le contrôle via le VD qui ne fonctionne pas.

 

Autres questions, par rapport à l'ancienne version il n'y a plus aucune variable sur ma HC2 ou doit on en conserver. Pour ma part j'ai retiré les variables, installer l'addon par dessus l'ancien, re créer les scènes sur HC2 et aussi le VD puis paramétrer le tout.

 

Merci

Scene-363-ID80-Scene_Kodi.xml

Partager ce message


Lien à poster
Partager sur d’autres sites

@Fred.domotique,

 

Dans la log de la scène lorsque que tu lance une vidéo, tu as un "Status : ..." qui apparait ? 

 

Sinon je pense à un ancien fichier de conf dans kodi.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Adn

J'était justement sur cette piste. En faite dans le log de la scène je n'est pas de status vidéo started. Je ne que vidéo Paused/Resumed.

J'ai fait une désinstallation complète de l'addon puis ré install mais le problème est le même.

Par contre quand je regarde dans le log kodi il me manque aussi le Log sur vidéo started. Donc le soucis est sur Kodi et non fibaro.

 

Après j'ai 4 ligne d'erreur pour accès à de la vidéo/ est ce possible que ses lignes perturbe et par contre je ne comprend pas l'erreur.

Ci dessous mon log

 

En vert les instances qui semble fonctionner, en rouge les erreurs qui sont peut être perturbante. 

Merci pour ton avis

 

16:30:56.673 T:6160  NOTICE: script.grab.fanart: Grab Fanart Service Started
16:30:57.649 T:6332  NOTICE: HC2 Addon : Recuperation de la liste des sections
16:30:57.830 T:6332  NOTICE: HC2 Addon : Recuperation de la liste des rooms
16:30:59.359 T:6332  NOTICE: HC2 Addon : Recuperation de la liste des devices?visible=true&enabled=true
16:30:59.737 T:6332  NOTICE: HC2 Addon : Recuperation de la liste des scenes
16:31:18.556 T:6332  NOTICE: HC2 Addon : On
16:31:33.923 T:8888   ERROR: XFILE::CDirectory::GetDirectory - Error getting
16:31:37.566 T:8888   ERROR: Previous line repeats 6 times.
16:31:37.566 T:8888   ERROR: NFS: Failed to stat(volume1/Media/Mes Films/The Equalizer/The Equalizer (2014)   1080p VFF EN x264 ac3 mHDgz-poster.jpg) stat call failed with "NFS: Lookup of /Mes Films/The Equalizer/The Equalizer (2014)   1080p VFF EN x264 ac3 mHDgz-poster.jpg failed with NFS3ERR_NOENT(-2)"
16:31:37.568 T:8888   ERROR: NFS: Failed to stat(volume1/Media/Mes Films/The Equalizer/The Equalizer (2014)   1080p VFF EN x264 ac3 mHDgz-thumb.jpg) stat call failed with "NFS: Lookup of /Mes Films/The Equalizer/The Equalizer (2014)   1080p VFF EN x264 ac3 mHDgz-thumb.jpg failed with NFS3ERR_NOENT(-2)"
16:31:38.644 T:8888   ERROR: CDVDDemuxFFmpeg::Open - Error, could not open file nfs://192.168.0.13/volume1/Media/Mes Films/L'opération corned Beef/L'operation Corned Beef 1990 1080p WEB-DL AC3 x264.mkv

16:31:39.185 T:14088  NOTICE: VideoPlayer::OpenFile: nfs://192.168.0.13/volume1/Media/Mes Films/Skyscraper/Skyscraper.2018.MULTi.1080p.WEB-DL.H264-NoTag.mkv
16:31:39.186 T:12184  NOTICE: Creating InputStream
16:31:39.205 T:12184  NOTICE: Creating Demuxer
16:31:39.299 T:12184  NOTICE: Opening stream: 0 source: 256
16:31:39.299 T:12184  NOTICE: Creating video codec with codec id: 27
16:31:39.299 T:12184  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
16:31:39.299 T:12184  NOTICE: Creating video thread
16:31:39.300 T:13904  NOTICE: running thread: video_thread
16:31:39.300 T:12184  NOTICE: Opening stream: 1 source: 256
16:31:39.300 T:12184  NOTICE: Finding audio codec for: 86018
16:31:39.301 T:12184  NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder aac
16:31:39.301 T:12184  NOTICE: Creating audio thread
16:31:39.301 T:12184  NOTICE: Opening stream: 3 source: 256
16:31:39.301 T:8012  NOTICE: running thread: CVideoPlayerAudio::Process()
16:31:39.302 T:13904  NOTICE: DXVA::CDXVAContext::CreateDecoder: hw may not support multiple decoders, releasing existing ones.
16:31:39.312 T:8012  NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 48000, no pass-through)
16:31:39.468 T:14088  NOTICE: DXVA::CProcessorHD::InitProcessor: supported deinterlace methods: blend:no, bob:yes, adaptive:yes, mocomp:yes.
16:31:39.469 T:14088 WARNING: CWinRenderer::UpdateVideoFilter: chosen scaling method 1 is not supported by renderer
16:31:39.847 T:13904  NOTICE: CDVDVideoCodecFFmpeg::CDropControl: calculated diff time: 41727
16:32:48.449 T:14088 WARNING: CGUIWindowManager - CGUIWindowManager::HandleAction - ignoring action 107, because topmost modal dialog closing animation is running
16:32:49.733 T:6332 WARNING: Previous line repeats 18 times.
16:32:49.733 T:6332  NOTICE: HC2 Addon : Video_Paused
16:32:50.235 T:13904 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
16:33:03.342 T:6332 WARNING: Previous line repeats 25 times.
16:33:03.342 T:6332  NOTICE: HC2 Addon : Video_Resumed
16:33:05.799 T:14088  NOTICE: CVideoPlayer::CloseFile()

Partager ce message


Lien à poster
Partager sur d’autres sites

Essaye de supprimer l'addon completement de ton répertoire une fois l'avoir supprimer depuis l'interface kodi

Dans ton UserData : image.png.4ff60ad41b715f85e2aae807ceba6cad.png

 

En fait c'est peut être du à une version de l'addon, si il voir que la version au niveau du fichier addon.xml n'a pas changé pour lui il utilise un ancien package et pas celui que tu upload. 

 

La ligne que tu as n'est pas à l'origine du problème. vérifie en même temps que dans ton fichier le video_started est bien à yes (dans addons/HC2_addon/)

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu fait un

cat addon_data/HC2.addon/settings.xml

Tu devrais avoir une ligne : 

    <setting id="video_started" value="Yes" />

 

Est-ce que tu peux augmenter "le temps de déclenchement après un changement de scène" et également "le temps d'attente afin de récupérer les infos video/audio"  ?
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut ADN,

 

Bon je tourne en rond.. 

J'ai bien tout ré installer, le paramètre est ok dans le fichier setting.xml =>      <setting id="video_started">Yes</setting>

J'ai joué sur les temps en allant jusqu'à 5000 mas rien à faire. 

Pour le temps d'attente afin de remonter les infos vidéo/audio je remarque que ces dernière ne remonte pas au travers du VD.

Pour le reste des commandes du VD elles fonctionnent, je t'avais mis dans mes premiers post que ce dernier envoie les infos à la scène mais sans déclenchement des actions. Cette erreur était lié à une erreur de port dans mon paramétrage des instances. 

 

En résumé tout fonctionne au niveau du VD sauf la remontée d'info.

Toutes les infos remontées à la scène et s'execute sauf le vidéo started.

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai finalement fait la mise à jour Kodi v18 Leia (le bug de lecture en HDR 4K sur la ShieldTV a enfin été résolu)

 

Du coup j'en ai profité pour installer la dernière version du plugin v1.4.1.

Merci @ADN182 :60:

 

Par contre j'ai 6 caméras, et le plugin est limité à 5 caméras.

 

=> Je me suis permis de créer une version 1.4.2 de l'add-on en pièce jointe.

J'ai modifié les fichiers suivants afin d'ajouter le support de 10 caméras maximum :

  • \HC2.addon\addon.xml

  • \HC2.addon\changelog.txt

  • \HC2.addon\script.py

  • \HC2.addon\service.py

  • \HC2.addon\resources\settings.xml
  • \HC2.addon\resources\language\English\strings.xml
  • \HC2.addon\resources\language\French\strings.xml

 

Si ça te semble correct, est-ce que tu veux bien la mettre en première page afin que cette version serve de base aux futurs développements ?

 

Merci :)

 

 

HC2.addon-1.4.2-Lazer.zip

  • Like 3

Partager ce message


Lien à poster
Partager sur d’autres sites

×