Aller au contenu

Recommended Posts

ok merci je vais tester :60:

Partager ce message


Lien à poster
Partager sur d’autres sites

 J'ai commencé simple avec une ligne comme celle-ci:

GEA.add(true, 30, "",{{"Time","13:56","13:57"},{"TurnOn", id["Leds_Terrasse"], 6*30}, {"Program", id["Leds_Terrasse"], 648}})

avec l'extinction au bout des trois minutes, et enfin j'ai testé en ajoutant au bout d'une ligne existante:

GEA.add({id["Com_Ecl_Portail"], {"Global", "Jour_Nuit", "Nuit"}}, -1, "", {{"turnOn", id["Eclairage_Portail"]}, {"TurnOn", id["Leds_Terrasse"], 15*60}, {"Program", id["Leds_Terrasse"], 648}}) -- Allumer automatiquement l'éclairage Portail & les Leds terrasse la nuit

Et miracle, ça marche (bien sur, j'avais remplacé nuit par jour dans ma condition de variable). :60:

Et si je voulais intégrer la condition de durée de l'éclairage portail (actuellement j'ai eu autre ligne qui l'éteint):

GEA.add(id["Eclairage_Portail"], 15*60, "", {{"turnOff"}}) -- Eteindre automatiquement l'éclairage Portail

, pourrais-je faire ceci?

GEA.add({id["Com_Ecl_Portail"], {"Global", "Jour_Nuit", "Nuit"}}, -1, "", {{"turnOn", id["Eclairage_Portail"], 15*60}, {"TurnOn", id["Leds_Terrasse"], 15*60}, {"Program", id["Leds_Terrasse"], 648}}) -- Allumer automatiquement l'éclairage Portail & les Leds terrasse la nuit

Et merci encore le staf GEA. :13:

Partager ce message


Lien à poster
Partager sur d’autres sites

@Did

 

GEA.add({id["Com_Ecl_Portail"], {"Global", "Jour_Nuit", "Nuit"}}, -1, "", { {"turnOn", {id["Eclairage_Portail"], id["Leds_Terrasse"]}, 15*60}, {"Program", id["Leds_Terrasse"], 648}}) -- Allumer automatiquement l'éclairage Portail & les Leds terrasse la nuit

Ca se tente ;-)

 

il y a 27 minutes, Did a dit :

staf GEA

lol, suis un plagieur ;-)

Partager ce message


Lien à poster
Partager sur d’autres sites

@pepite

GEA.add({{"Dates", "01/01", "31/08"}, {"Label", 217, "lblState", "#r#Vacances Terminées|Mode désactivé"} }, 1, "", {"Global", "Boiler", "Nuit"})

SUPER ça fonctionne à merveille

Encore merci  :18:

Partager ce message


Lien à poster
Partager sur d’autres sites

  @pepite,

Je n'ai pas compris, ni ma ligne, ni la tienne n'ont fonctionné à la fermeture du portail, et l'éclairage portail non plus ne s'est pas allumé.

Voici ce que j'avais dans le debugg:

661049977_debugggea.PNG.744fb3d198cfe9d0e5bdb2e95c2d975e.PNG

 

Partager ce message


Lien à poster
Partager sur d’autres sites

 Petite correction, j'ai retenté d'ouvrir le portail plus tard dans la soirée et c'est passé crème, je n'ai pas compris.

Tu vois un indice dans mon debugg?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

@Did

 Bizarre ;-) C'était quelle ligne exactement ? Ton portail a l'id 207 ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

J’ai un FGS-213, qui commande en (Sunset ON et Sunrise OFF) un spot extérieur muni d'un détecteur de mouvement.

Le but étant de récupérer la conso du spot sur déclenchement pour en allumer d'autres lampes.

j'ai essayé ceci mais j'ai un souci avec 1*5 ?

GEA.add({"Power+", id["SPOT_EXT_PARKLO"], 10}, 1*5, "", {"TurnOn", {id["ECL_HALL_BAS"], id["ECL_PRT_ENTREE"]}, 3*60})

:15:

 

Partager ce message


Lien à poster
Partager sur d’autres sites

salut

 

as-tu déclaré le spot SPOT_EXT_PARKLO dans l’entête ?

 

xx  Power

Partager ce message


Lien à poster
Partager sur d’autres sites

 C'est la ligne de @Steven avec le TurnOn:

GEA.add({id["Com_Ecl_Portail"], {"Global", "Jour_Nuit", "Nuit"}}, -1, "", {{"turnOn", id["Eclairage_Portail"]}, {"TurnOn", id["Leds_Terrasse"], 15*60}, {"Program", id["Leds_Terrasse"], 648}}) -- Allumer automatiquement l'éclairage Portail & les Leds terrasse la nuit

L'Id 207 est le contact d'un FGBS qui se colle dès que la motorisation se met en marche (ouverture ou fermeture).

Je n'ai finalement pas retiré ma ligne qui éteint l'éclairage du portail au bout d'un quart d'heure car je ne veux pas qu'il reste allumé plus longtemps.

Et du coup, ça à l'air de fonctionner les leds de la terrasse s'allument en même temps que l'ouverture du portail.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui j'ai essayé avec en mettant xx value

Partager ce message


Lien à poster
Partager sur d’autres sites

non  il faut par exemple : 41 power 

change le 41 par ID de ton spot 

Partager ce message


Lien à poster
Partager sur d’autres sites

Remplace le 1*5 par -1 et met l'ID de ton détecteur dans l'entête

Xxx power


Seul la combinaison du -1 avec en-tête peuvent fonctionner dans ton cas, sinon 5 secondes ne servent à rien sur un script qui tourne toutes les 30 secondes.

Envoyé de mon SM-G935F en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Il s'allume ~ après 45 secondes

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 22 minutes, Ghoosti a dit :

1*5

Bonjour,

Quelle est la durée que tu veux utiliser ? Ce serait 5 quoi ?

As tu modifié GEA.checkEvery ? Si ce n'est pas le cas, laisse un multiple de 30, donc pour 5 mins : 5*60

 

il y a 15 minutes, 971jmd a dit :

as-tu déclaré le spot SPOT_EXT_PARKLO dans l’entête ?

 

xx  Power

La déclaration de "id module propriété" n'est utile que si vous avez besoin de déclenchements instantanés, donc avec "-1" en durée. sinon ce n'est pas utile.

 

@Did bizarre tout de même, il n'y a rien de particulier sur cette ligne

le principal c'est que ca fonctionne ;-)

Partager ce message


Lien à poster
Partager sur d’autres sites

hop, grillé par @Steven ;-)

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour une fois que je répond

Envoyé de mon SM-G935F en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci à vous

ça fonctionne

GEA.add({"Power+", id["ECL_HOMECINEMA"], 30}, -1, "", {"TurnOn", {id["ECL_HALL_BAS"], id["ECL_PRT_ENTREE"]}})

merci :60:

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

pour  allumer parés 45s

 

GEA.add({"Power+", id["SPOT_EXT_PARKLO"], 10}, -1, "" , {{"Sleep", 45,  {"TurnOn", {id["ECL_HALL_BAS"], id["ECL_PRT_ENTREE"]}}}

Partager ce message


Lien à poster
Partager sur d’autres sites

Toujours un plaisir d'aider, sauf@pepite car il devient trop bon et donc ses questions de plus en plus pointues et tordues

Envoyé de mon SM-G935F en utilisant Tapatalk

  • Like 2

Partager ce message


Lien à poster
Partager sur d’autres sites
à l’instant, 971jmd a dit :

pour  allumer parés 45s

 

GEA.add({"Power+", id["SPOT_EXT_PARKLO"], 10}, -1, "" , {{"Sleep", 45,  {"TurnOn", {id["ECL_HALL_BAS"], id["ECL_PRT_ENTREE"]}}})

 

Partager ce message


Lien à poster
Partager sur d’autres sites

@Ghoosti exact, un peu tordu le type ;-)  Faut pas faire attention ;-) @Steven je sors

 lol

Juste pour info, du déclenchement instantané avec de la consommation, à chaque variation de consommation >= à 30, bingo, ca déclenche ta ligne ;-)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, j'essaye de passer de V5.42 en V6.11 et je voudrais passer des paramètres à mon scénario mais je n'y arrive pas, voici un exemple et le debug. @pepite me conseillais d'utilisé ceci

- Scenario : {"Scenario", <id>} - {"Scenario", <id>, {args}}

donc j'ai fait :

GEA.add({"Value-", 999,24}, 60, "Température  #value# inférieure à 24°C...On chauffe!", {{"Scenario", 998, {TxtSpeach="allume le chauffage"}}, {"Portable",997} })

et j'ai une erreur :

[DEBUG] 19:14:16:    [Démarrage] #19 [Value-, [999,24]] ][Scenario, [998,{"TxtSpeach":"allume le chauffage"}]][Portable, [997]]
[DEBUG] 19:14:17: Option : "TxtSpeach":"allume le chauffage" n'existe pas

 

Sinon avant en V5.42 j'utilisais la méthode Function mais elle me pose problème aussi en V6.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @Titof_44

Bizarre, le bug existait au début mais @Steven l'avait corrigé dans mes souvenirs. Je viens de tester, idem pour moi, même erreur. Peux tu essayer cela :

GEA.add({"Value-", 999,24}, 60, "Température  #value# inférieure à 24°C...On chauffe!", {{"Scenario", 998, {{TxtSpeach="allume le chauffage"}}}, {"Portable",997} })

En attendant, je ne sais pas combien tu as de ligne utilisant des arguments mais pour celle ci-dessous tu peux faire comme ceci : Dans config() tu mets

GEA.options.speach = {name = "Speach",
  action = function(txtspeach) local sceneparam = 998
    fibaro:startScene(sceneparam, {{TxtSpeach = GEA.getMessage(txtspeach)}}) end,
}

Puis dans setEvents() tu l'utilises comme ceci

GEA.add({"Value-", 999,24}, 60, "Température  #value# inférieure à 24°C...On chauffe!",{ {"Speach", "Allume le chauffage"}, {"Portable",997} })

 

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci @pepite, cela fonctionne, j'ai fait mes autres scénario sur la même base.

J' ai une autre question qui a du être déjà abordé mais dans toutes ces pages je ne trouve pas la réponse.

Y-a-t-il un moyen de remplacer le 18 par une variable globale : 

GEA.add({"Value-", id["TEMP"], 18}, 30*60, "Il fait froid au salon #value# à #time#")
  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

×