Aller au contenu
MAM78

Surveillance Station Manager

Recommended Posts

Me suis endormi dessus hier. 

Jai un soucis de parametrage. 

En espérant que ça soit ok pour le qnap

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, schwinny a dit :

Jai un soucis de parametrage. 

C'est quoi ton soucis ?

Partager ce message


Lien à poster
Partager sur d’autres sites

bonsoir à tous,

j'ai un QNAP aussi, je guette Schwinny et sa solution pour ne pas être obligé pour pouvoir profiter de ce VD, de basculer sous Syno :18:

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, MAM78 a dit :

C'est quoi ton soucis ?

d'avoir le temps pour une bonne semaine la car en déplacement et madame y touche pas :) 

 

sinon, il em trouve pas la scène mais je pense que cest le parametrage que j'ai foiré en y regardant a 2h du mat ... donc pas frais.

je regarde a mon retour

Partager ce message


Lien à poster
Partager sur d’autres sites

Comme indiqué dans le TUTO la scène doit être nommée « Surv Station Manager » sans point.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je n'ai pas encore eu le temps de regarder, mais comment cela pourrait il fonctionner sur Qnap sans SS...

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis pas certain de te suivre. L’objet de cette solution consiste à piloter l’API de SS. Je ne vois pas comment faire sans SS.

Concernant QNAP, j’ignore si SS Station est la même version que celle sur Synology. Donc j’ignore si ça vas fonctionner sur QNAP.

Modifié par MAM78

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est ce que je voulais dire : SS n'existe pas sous Qnap, c'est un produit 100% Synology qui ne fonctionne que sur DSM. Aucune chance de faire fonctionner cela sur un Qnap.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Nico a dit :

C'est ce que je voulais dire : SS n'existe pas sous Qnap, c'est un produit 100% Synology qui ne fonctionne que sur DSM. Aucune chance de faire fonctionner cela sur un Qnap.

Si, Surveillance station existe sous QNAP, je l'ai installé et configuré pour mon DoorBird.

 

C'est pour ça que ce VD me fait de l'oeil :18:

 

 

Capture.PNG

Partager ce message


Lien à poster
Partager sur d’autres sites

Sauf que Qnap n'a que repris le nom SS de celui de Synology, ce paquet n'a rien avoir avec le SS de Synology… Il est d'ailleurs loin d'être aussi abouti. Sorry, mais cela ne fonctionnera pas...

Partager ce message


Lien à poster
Partager sur d’autres sites

Zut alors, tu viens de me ruiner 2018 !!!!! :20:

Je vais devoir budgétiser un NAS Synology en 2019 ............

Partager ce message


Lien à poster
Partager sur d’autres sites

CQFD. Merci @Nico pour la précision que j'ignorais.

 

Si une API existe pour Surveillance Station sous QNAP, il faudra trouver quelqu'un pour adapter les VDs et la Scène ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Désolé les gars, c'était juste pour pas que vous perdiez du temps inutile dans des tests qui n'avaient aucune chances de fonctionner...

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @MAM78, je voulais tester ton VD mais j'ai clairement un petit problème ...

 

 

EDIT : problème résolé, je ne sais pas pourquoi mais les id de mes deux cams sont 7 et 8...  j'ai changé dans le VD global, et ca marche

 

 

Modifié par Cardane

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello @Cardane comment se passent tes tests ?

 

Modifié par MAM78

Partager ce message


Lien à poster
Partager sur d’autres sites

@MAM78 ben pour l'instant ca marche pas mal, j'ai plus de problème avec la configuration de la hikvision pour la détection de mouvement, mais c'est plus côté Surveillance Station. Pour le reste ca marche bien, je n'ai eu aucun problème

je n'ai pas fait beaucoup de tests encore, pour l'instant je suis englué dans mon code LUA pour faire le VD du KLF200, et je suis perdu avec la manipulation de chaînes de caractères :-)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, est-il possible d'envoyer les snapshoot par email ?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

tout dépend du mode de détection de mouvement que t'utilises :

  • Oui (via les notifications de Surveillance Station) pour la détection de mouvements par la caméra
  • Oui (via les notifications de Surveillance Station) pour la détection de mouvements par le logiciel Surveillance Station
  • Non apriori pour la détection par un événement externe (type détecteur de mouvements). Pour le moment (après quelques tests) :
    • J'arrive bien à enregistrer dans Surveillance Station les snapshot (via le bouton prévu à cet effet)
    • J'arrive bien à envoyer une notification textuelle par mail en utilisant les règles d'actions de SS.
    • Mais je n'ai pas réussi à joindre dans l'email de notification un snapshot.
    • Il est toutefois possible  (dans les règles d'actions) d'ajouter l'exécution d'une requête HTTP à destination de YAPUSS - Passerelle "Universelle" Surveillance Station de @sebcbien), mais je ne l'ai pas encore testé.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon je sais, l'actualité du jour ce n'est pas ici, mais est-ce que l'un de vous a fait des tests sur les fonctions PTZ ? et si oui pourriez-vous me faire un retour ?

 

Attention au retour de flames ? :22: en ce moment vous êtes à cran avec la nouveauté Fibaro du jour. 

 

Modifié par MAM78

Partager ce message


Lien à poster
Partager sur d’autres sites

Hi @MAM78,

 

I had initially some trouble to find the correct IDs for my three cams and hence the VD's did not work in the beginning. Having fixed this issue (Nos are 1, 2 and 3 :D), I was able to test the VD and it works great for me. As I intent to change the "Home Mode ON/OFF" status from other scenes I have added two more buttons in addition to the "Home Mode" toggle. So, I have a better control for scenarios like " if PresentState = "Away" then fibaro:call(SSM_ID, "pressButton", "2")". See image below.

 

There is one further issue, which might however be caused by my SSS setup. For one of the three cameras I can create snapshots without any problems. This camera is the only one that is directly connected to this server (1). The other two cameras are connected to a second Diskstation (2) and are just linked to the first Surveillance station (1) via Synology "Central Management System (CMS)". So, when I hit the button for the snapshot for the cams on server (2) I get an authentification failure (debug messages below). For myself this is not a serious issue as I will not need the snapshot funtion at all, or can use the normal Fibaro Plugin. but amybe there is a workaround to login into more than one diskstations in one script. Credentials and privileges in my case are be the same for both Diskstations but the SID is prbably different.

 

What else does not work:

- I cannot stop the recording. Or better the recording starts immediately after it was interrupted. Again likely an issue with my own SSS setup, as I am using continuous recording 24/7

- in The camera VDs I cannot toggle the source for movement detection. This always remains as it was initially setup in my SSS. However, as my cameras are have a PIR sensor I will always use this one and have no need to change the source.

 

I have not yet tested the scene buttons.

None of my cams has PTZ. So, no way to test this functionality

 

Altogether a fantastic tool and I am amazed what you guys here in the forum are able to implement. As an absolute LUA Rookie I do only barely understand how these VDs are working. But they do the job and that's what counts. Many thanks for sharing your knowledge.

 

Cheers

Alex

 

image.png.4ca6a82caafbd875ee8f1eda382ddd56.png

 

 

Camera on Server (1)
[DEBUG] 19:04:14: 10/01/2019 : Scene started manually
[DEBUG] 19:04:14: [{"VD_Text":"Prise d'une photo"},{"action":"TakeSnapshot"},{"value":"3"},{"VD_ID":610},{"VD_Button_ID":10},{"VD_Label":"lblMotionSource"}]
[DEBUG] 19:04:14: VD_Text : Prise d'une photo
[DEBUG] 19:04:14: action : TakeSnapshot
[DEBUG] 19:04:14: value : 3
[DEBUG] 19:04:14: VD_ID : 610
[DEBUG] 19:04:14: VD_Button_ID : 10
[DEBUG] 19:04:14: VD_Label : lblMotionSource
[DEBUG] 19:04:14: 10/01/2019 : Prise d'une photo 3
[DEBUG] 19:04:14: Gloabal Variable = SurvStationManager Contente : ({"pathAuth":"auth.cgi","pathCamera":"entry.cgi","SceneID":169,"HomeMode":false,"pathRecord":"entry.cgi","SID":"w5tGURcxDd.ic1830PCN718514","Cameras":{"1":{"Cam_VD_Id":608,"Cam_WithPTZ":false,"Cam_Recording":true,"CameraStatus":0,"Cam_PTZ_Position_name":"","Cam_PTZ_Position_id":"","Cam_Motion_Source":0,"Cam_Name":"Instar_Garten","Cam_Motion_Disabled":false,"Cam_Enabled":true},"3":{"Cam_VD_Id":610,"Cam_WithPTZ":false,"Cam_Recording":true,"CameraStatus":0,"Cam_PTZ_Position_name":"","Cam_PTZ_Position_id":"","Cam_Motion_Source":0,"Cam_Name":"Instar_Terrasse","Cam_Motion_Disabled":false,"Cam_Enabled":true},"2":{"Cam_VD_Id":609,"Cam_WithPTZ":false,"Cam_Recording":true,"CameraStatus":0,"Cam_PTZ_Position_name":"","Cam_PTZ_Position_id":"","Cam_Motion_Source":0,"Cam_Name":"Instar_Front","Cam_Motion_Disabled":false,"Cam_Enabled":true}},"CameraList":"3,1,2"}
[DEBUG] 19:04:14: pathAuth =auth.cgi Parameters found in "SurvStationManager" global variable
[DEBUG] 19:04:14: pathRecord =entry.cgi Parameters found in "SurvStationManager" global variable
[DEBUG] 19:04:14: pathCamera =entry.cgi Parameters found in "SurvStationManager" global variable
[DEBUG] 19:04:14: SID =w5tGURcxDd.ic1830PCN718514 Parameters found in "SurvStationManager" global variable
[DEBUG] 19:04:14: setTimeout(function() functions[TakeSnapshot]() end, 0)
[DEBUG] 19:04:14: Scene main loop finished
[DEBUG] 19:04:14: Call TakeSnapshot() function
[DEBUG] 19:04:14: getAPI() : http://192.168.178.72:5000/webapi/entry.cgi?api=SYNO.SurveillanceStation.SnapShot&version=1&method=TakeSnapshot&blSave=true&camId=3&_sid=w5tGURcxDd.ic1830PCN718514
[DEBUG] 19:04:14: getAPI() : response success
[DEBUG] 19:04:14: getAPI() : callback function TakeSnapshot
[DEBUG] 19:04:14: TakeSnapshot : Success
[DEBUG] 19:04:14: Prise d'une photo OK
[DEBUG] 19:04:14: label : lblStatus value : Prise d'une photo OK
[DEBUG] 19:04:14: Update VD_ID : 610 label : ui.lblStatus.value => Prise d'une photo OK

 

 

Camera on Server (2)
[DEBUG] 19:06:02: 10/01/2019 : Scene started manually
[DEBUG] 19:06:02: [{"VD_Text":"Prise d'une photo"},{"action":"TakeSnapshot"},{"value":"2"},{"VD_ID":609},{"VD_Button_ID":10},{"VD_Label":"lblMotionSource"}]
[DEBUG] 19:06:02: VD_Text : Prise d'une photo
[DEBUG] 19:06:02: action : TakeSnapshot
[DEBUG] 19:06:02: value : 2
[DEBUG] 19:06:02: VD_ID : 609
[DEBUG] 19:06:02: VD_Button_ID : 10
[DEBUG] 19:06:02: VD_Label : lblMotionSource
[DEBUG] 19:06:02: 10/01/2019 : Prise d'une photo 2
[DEBUG] 19:06:02: Gloabal Variable = SurvStationManager Contente : ({"pathAuth":"auth.cgi","pathCamera":"entry.cgi","SceneID":169,"HomeMode":false,"pathRecord":"entry.cgi","SID":"w5tGURcxDd.ic1830PCN718514","Cameras":{"1":{"Cam_VD_Id":608,"Cam_WithPTZ":false,"Cam_Recording":true,"CameraStatus":0,"Cam_PTZ_Position_name":"","Cam_PTZ_Position_id":"","Cam_Motion_Source":0,"Cam_Name":"Instar_Garten","Cam_Motion_Disabled":false,"Cam_Enabled":true},"3":{"Cam_VD_Id":610,"Cam_WithPTZ":false,"Cam_Recording":true,"CameraStatus":0,"Cam_PTZ_Position_name":"","Cam_PTZ_Position_id":"","Cam_Motion_Source":0,"Cam_Name":"Instar_Terrasse","Cam_Motion_Disabled":false,"Cam_Enabled":true},"2":{"Cam_VD_Id":609,"Cam_WithPTZ":false,"Cam_Recording":true,"CameraStatus":0,"Cam_PTZ_Position_name":"","Cam_PTZ_Position_id":"","Cam_Motion_Source":0,"Cam_Name":"Instar_Front","Cam_Motion_Disabled":false,"Cam_Enabled":true}},"CameraList":"3,1,2"}
[DEBUG] 19:06:02: pathAuth =auth.cgi Parameters found in "SurvStationManager" global variable
[DEBUG] 19:06:02: pathRecord =entry.cgi Parameters found in "SurvStationManager" global variable
[DEBUG] 19:06:02: pathCamera =entry.cgi Parameters found in "SurvStationManager" global variable
[DEBUG] 19:06:02: SID =w5tGURcxDd.ic1830PCN718514 Parameters found in "SurvStationManager" global variable
[DEBUG] 19:06:02: setTimeout(function() functions[TakeSnapshot]() end, 0)
[DEBUG] 19:06:02: Scene main loop finished
[DEBUG] 19:06:02: Call TakeSnapshot() function
[DEBUG] 19:06:02: getAPI() : http://192.168.178.72:5000/webapi/entry.cgi?api=SYNO.SurveillanceStation.SnapShot&version=1&method=TakeSnapshot&blSave=true&camId=2&_sid=w5tGURcxDd.ic1830PCN718514
[DEBUG] 19:06:03: getAPI() : response not success
[DEBUG] 19:06:03: getAPI() : callback function TakeSnapshot
[DEBUG] 19:06:03: Error : TakeSnapshot failed : API Authentication failure, Invalid login or password.
[DEBUG] 19:06:03: label : lblStatus value : Prise d'une photo Failed
[DEBUG] 19:06:03: Update VD_ID : 609 label : ui.lblStatus.value => Prise d'une photo Failed

Partager ce message


Lien à poster
Partager sur d’autres sites

Toujours pas eu le temps de tester, désolé @MAM78...

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 21 heures, lodi a dit :

I had initially some trouble to find the correct IDs for my three cams and hence the VD's did not work in the beginning. Having fixed this issue (Nos are 1, 2 and 3 :D), I was able to test the VD and it works great for me. As I intent to change the "Home Mode ON/OFF" status from other scenes I have added two more buttons in addition to the "Home Mode" toggle. So, I have a better control for scenarios like " if PresentState = "Away" then fibaro:call(SSM_ID, "pressButton", "2")". See image below.

Normally when you install the Global VD, you get the IDs of each camera in the camera list displayed in the global VG.

 

You have also been able to test the "HomeMode" data of the global variable "VG_SSM_Parameters" to know the current status of the presence and press the button according to the value. Like :

local Parameters = fibaro: getGlobalValue (VG_SSM_Parameters)
local status, Parameters = pcall (function () return json.decode (Parameters) end)
if  Parameters.HomeMode = false then
  ' press button .....
Il y a 21 heures, lodi a dit :

but amybe there is a workaround to login into more than one diskstations in one script.

You should be able to install a second Global VD and a second scene for your second Synology NAS. You will also need to think about changing the following variable by specifying the name of the second scene.

local Scene_Surv_Station_Manager = "Surv Station Manager"    -- Name of the Scene used to execute actions

And change the VG in all VD and scene for the second SSS :

    VG_SSM_Parameters        = "SurvStationManager",           -- Global Variable used to transmit Parameters between VD Main loop, Buttons and Scene
    VG_SSM_User_Data         = "SurvStationManager_User_Data", -- Global Variable used to transmit users datas between VD Main loop, Buttons and Scene
    VG_SSM_Status            = "SurvStationManager_Status",     -- Global Variable used to indicate the status off Surveillance Station

 

Il y a 21 heures, lodi a dit :

- I cannot stop the recording. Or better the recording starts immediately after it was interrupted. Again likely an issue with my own SSS setup, as I am using continuous recording 24/7

Indeed, it is related to your configuration. SSS takes precedence when you set up 24/7 recording.

One of the aims of my request is precisely not to record continuously to avoid the wear of hard drives and also for the protection of the privacy of the people living in the house.

 

Il y a 21 heures, lodi a dit :

- in The camera VDs I cannot toggle the source for movement detection. This always remains as it was initially setup in my SSS. However, as my cameras are have a PIR sensor I will always use this one and have no need to change the source.

Does the problem appear on CAMs attached to the primary or secondary NAS or both?
If it is on the second one, it may be related to the use of Synology "Central Management System (CMS)?

 

So, in summary, your problems are essentially related to your context of use and not bugs. I will see if it is possible to manage cameras when connected via Synology "Centralized Management System (CMS)"

 

Modifié par MAM78

Partager ce message


Lien à poster
Partager sur d’autres sites
3 hours ago, MAM78 said:

Normally when you install the Global VD, you get the IDs of each camera in the list displayed in the global VG.

@MAM78 Many Thanks' for your reply. Not sure for whatever reason the IDs did not show up but initially, but finally I have managed to get them. I remember I also had to adjust the privileges of the Synology user and maybe this explains why the IDs were not available in the first place.

3 hours ago, MAM78 said:

You have also been able to test the "HomeMode" data of the global variable "VG_SSM_Parameters" to know the current status of the presence and press the button according to the value. Like :


You should be able to install a second Global VD and a second scene for your second Synology NAS. You will also need to think about changing the following variables by specifying the name of the second scene.


And change the VG in all VD and scene for the second SSS :


 

Indeed, it is related to your configuration. SSS takes precedence when you set up 24/7 recording.

One of the aims of my request is precisely to be kept in mind.

 

Does the problem appear on CAMs attached to the primary or secondary NAS or both?
If it is on the second one, it can be related to the Synology "Central Management System (CMS)?

Yes, indeed to test the "Home Mode" status is certainly another -more elegant- option. I will consider to adjust my scenes accordingly.

 

I was also thinking about the installation of a second VD/SSM scene, but were not sure about the consequences and which globals would have to be adjusted. Thanks for your hints. Alternatively I will make the bigger step and buy myself another camera licence to move all three cams to one server.

 

I have currently only outdoor cams and basically want to record all around the clock. I keep all data for 30 days and have reserved the required diskspace. So, this works all fine for me. But I will try to record without a plan which would allow me to switch the recording on and off. As far as I can see this issue appears on both servers (which however have both the same 24/7 setup yet) 

3 hours ago, MAM78 said:

So, in summary, your problems are essentially related to your use and not bugs. Synology "Centralized Management System (CMS)"

 

Yes, I will try to change the recording from "permanent" to "on request" and will feedback my observations.

 

Anyway, I just had a look into the forums étiquette. There it is mentioned that French is mandatory. Hope my English comments are still OK. I am sure you do not want to read my comments when I try to write in French :18:.

 

Many Thanks'

Lodi

Partager ce message


Lien à poster
Partager sur d’autres sites

×