Aller au contenu
jjacques68

HC3 - Commande Shutdown

Recommended Posts

Ecoutes, moi j'ai plutôt le problème inverse en ce moment (cf. mon autre thread) :60:

 

Je continuais d'avoir des reboot à des heures rondes, et aléatoires. J'ai fini par retomber un backup en 5.040.37 il y a quelques heures. Pour le moment, le problème semble maîtrisé... Mais je préfère la laisser tourner encore quelques heures pour m'en assurer. 

 

Si je n'ai pas de reboot intempestif cet après-midi, et si personne ne t'as répondu d'ici-là, je ferai le test et je te dirai.

 

En tout cas la méthode fibaro.homeCenter.systemService.reboot est toujours spécifiée dans la documentation en ligne. 

Partager ce message


Lien à poster
Partager sur d’autres sites

fibaro.homeCenter.systemService.* c'est uniquement pour les scènes :(

 

Ce qui m'intéresse ce sont les QuickApps, dans lesquels ces méthodes n'ont jamais été disponibles.

C'est pour cela que je passe par l'API, comme expliqué par @Krikroff en page précédente

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

moi j'utilise ça

 

et en effet, le reboot c'est OK mais plus le shutdown... ????

 

function QuickApp:reboot()
    local http = net.HTTPClient({ timeout = 2000 })
    return http:request("http://localhost/api/service/reboot",{
    options={ 
        headers = {
            ["content-type"] = "application/json;charset=UTF-8",
            ["Authorization"] = "Basic xxxxxxx",              
            ["X-Fibaro-Version"] = "2"
        }, 
        method = "POST"
        }
    })
end


function QuickApp:shutdown()
    local http = net.HTTPClient({ timeout = 2000 })
    return http:request("http://localhost/api/service/shutdown",{
    options={ 
        headers = {
            ["content-type"] = "application/json;charset=UTF-8",
            ["Authorization"] = "Basic xxxxxxx",        
            ["X-Fibaro-Version"] = "2"
        }, 
        method = "POST"
        }
    })
end

 

Modifié par jjacques68

Partager ce message


Lien à poster
Partager sur d’autres sites

en fait la commande shutdown semble faire planter la box...

Si je la lance une deuxième fois, elle reboot ????

 

ça va poser problème pour l'extinction automatique si l'onduleur envoie l'info... :( 

 

EDIT : Lors du premier lancement du shutdown, il y a les led orange qui font K2000 ...

Modifié par jjacques68

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui pareil pour le shutdown chez moi, je pense qu'il faut l'oublier et utiliser le suspend à la place, même si je n'ai pas trop compris la différence...

 

Mais du coup tu utilises bien un header Authorization, c'est justement ce que je veux éviter, c'est juste aberrant quand le code tourne déjà sur la box elle-même....

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui pas le choix pour le reboot

curl -X POST "http://hc3-00000000/api/service/reboot" -H  "accept: */*" -H  "Content-Type: application/json" -H  "X-Fibaro-Version: 2" -H  "Accept-language: en" -H  "Authorization: Basic  YWRtaW46YWRtaW4=" -d "{\"recovery\":false}"

Mais il doit exister certainement un port qui permet de le faire sans auth

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Mouais... j'aurais pensé que via api.post(), donc en localhost sur 11111, ça serait passé sans auth, mais je constate une fois de plus que Fibaro modifie les API sans prévenir....

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Lazer a dit :

Oui pareil pour le shutdown chez moi, je pense qu'il faut l'oublier et utiliser le suspend à la place

mais on sait comment se comporte la box si on fait un "suspend" et que l'on coupe le courant ?

Redémarre-t-elle toute seule ? 

Perso j'ose pas trop oser... :) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ose, tu nous raconteras :D

 

  • Like 1
  • Sad 1

Partager ce message


Lien à poster
Partager sur d’autres sites

×