Aller au contenu

Recommended Posts

Salut Chacal,

 

J'ai testé en port 80 et 443 et c'est pareil !

 

Tu utilises bien les logins que tu utilises pour te connecter en web sur l'ip150 on est d'accord?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, MAidEN91 a dit :

Salut Chacal,

 

J'ai testé en port 80 et 443 et c'est pareil !

 

Tu utilises bien les logins que tu utilises pour te connecter en web sur l'ip150 on est d'accord?

Oui le password mis entre ' ' , mais pas le usercode mis brut

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon c'est le SSL qui pose problème, j'avais forcé mon IP150 en HTTPS et le script n'aime pas ! En le repassant en HTTP ca marche (enfin presque) ca va un peu plus loin :

 

* <INTERFACER> : Login to IP150...
* <INTERFACER> : Looking for someone connected...
* <INTERFACER> : SES Value found, encrypting credentials...
* <INTERFACER> : Sending auth request...
* <INTERFACER> : Not yet ready...
* <INTERFACER> : Seems ready.
* <INTERFACER> : Launching keep alive thread...
* <INTERFACER> : Retriving equipment...
Traceback (most recent call last):
  File "paradox.py", line 4, in <module>
    paradox_connector() # starting Paradox interfacer
  File "/home/pi/ip150/interfacer.py", line 33, in paradox_connector
    raise ValueError('Error while retriving equipment informations')
ValueError: Error while retriving equipment informations
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu n'es pas connecte avec l'interface web ?

Modifié par chacal621

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 15/3/2017 à 17:01, foxchip a dit :

Bonjour à tous,

 

voici avec beaucoup de retard une version stable compatible IP100, IP150

https://github.com/Guiiix/ip150_interfacer

bonjour , 

Dommage que vous n'apportiez pas plus de support a la mise en place de votre script , c'est pourtant un sujet fort intéressant et qui mériterai plus ...

Cordialement 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Le script est loin d'être en version stable pour le moment. Il s'agit seulement d'un bout de code réalisé rapidement afin de récupérer facilement les informations de l'IP150, prévu initialement pour une utilisation personnelle.

La mise en ligne du code (récente) est une simple action de partage afin de contribuer au développement de la domotique.

 

J'ai cependant rajouté une option de verbose afin de pouvoir faciliter vos debugs.

 

 

L'output devrait être beaucoup plus détaillé que dans la version précédente.

 

N'hésitez pas à poster un fichier de logs. Pour en créer un, tapez la commande python paradox.py -v > log.txt

Patientez une trentaine de secondes, puis stoppez le script si celui-ci tourne toujours (CTRL + C).

Si malgré ça, le script ne se stoppe pas, c'est que le serveur web est toujours en route, consultez la page internet http://IP_DE_VOTRE_MACHINE:12345/stop

Cela aura pour effet de le stopper.

Postez enfin le fichier log.txt

 

Bonne soirée à tous

 

 

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

 

Voila mon fichier de log ci joint, le script se connecte bien mais boucle en fait.

 

Avant la boucle j'ai ce message "<p>Framesets not supported. Please upgrade your browser so that you can use this setup tool</p>"

 

Egalement je vous confirme que quand l'ip150 est forcé en HTTPS le script ne fonctionne pas il retourne comme si quelqu'un etait déja connecté a l'interface :

 

* <INTERFACER> : VERBOSE mode activated
* <INTERFACER> : Login to IP150...
* <INTERFACER> : Making request to /login_page.html
<!DOCTYPE HTML PUBLIC '-//W3C//DTD HTML 4.01 Transitional//EN' 'http://www.w3.org/TR/html4/loose.dtd'>
<html>
<head>
        <meta http-equiv='content-type' content='text/html; charset=UTF-8' />
        <link rel='stylesheet' type='text/css' href='webstyles.css' />
        <title></title>
<script type='text/javascript'>function redirect(){var port="443";window.location = "https://" + window.location.hostname + ":" + port + window.location.pathname + window.location.search;} redirect();</script></head><body></body></html>
* <INTERFACER> : Looking for someone connected...
* <INTERFACER> : Unable to login, someone is probably already connected, waiting 15 seconds before retring...
* <INTERFACER> : Making request to /login_page.html

Merci pour votre aide !

log.txt

Partager ce message


Lien à poster
Partager sur d’autres sites

Au top!!!!! Fonctionne du feu de dieu!!!!

 

Bravo champion

Modifié par PafLaBounss

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

 

Effectivement, le protocole HTTPS n'est pas géré.

En revanche, vos logs montrent que tout fonctionne correctement.

 

Le but du script n'est pas simplement de se connecter et de retourner les infos à un instant t, mais reste bel et bien connecté tant qu'il n'est pas stoppé.

 

Les deux requêtes qui tournent en boucle sont :

  • le GET /status_live qui récupère les informations (chaque secondes, paramétrable dans le fichier const.py)
  • le GET /keep_alive permettant de maintenant la session de connexion à l'interface WEB de l'IP150

Une fois le script lancé, vous pouvez récupérer les informations de votre alarme en tapant dans votre navigateur :

  • http://IP:12345/description afin d'avoir un descriptif des capteurs détectés
  • http://IP:12345/status afin d'avoir le statut en temps réel de ces capteurs (à utiliser pour votre application domotique)
  • http://IP:12345/arm /desarm /partiel pour armer, désarmer ou mettre en mode partiel votre alarme.

Certains navigateurs peuvent vous afficher un message d'erreur car le script ne renvoi pas de réponses HTTP correctes pour le moment.

 

Bon courage et bonne soirée !

Modifié par Guiiix

Partager ce message


Lien à poster
Partager sur d’autres sites

super ça fonctionne , je peux armer /desarmer /partiel avec les requêtes http , mais description et status ne fonctionne pas 

merci pour le travail c'est top.$

J'ai ajouter le shebang #!/usr/bin/python à paradox.py pour un lancement ./paradox.py

Modifié par chacal621

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Ceci est le bug que j'ai décrit plus haut : le serveur ne renvoi pas de réponse HTTP correctement construites. 

Pour le contourner, vous pouvez réaliser un petit script PHP qui lui, comprendra les informations retournées, le temps que le bug soit résolu, si vous disposez d'un serveur web.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir , 

j'ai pas mal avancé sur l'intégration à domoticz ... par contre je n'arrive pas à exécuter le script en tache de fond . J'ai fais un lien du script ds /usr/Bin , j'ai cree un script ds /etc/init.d qd je lance le script , le server semble démarrer ... j'ai une réponse ok avec sudo service paradox status mais pas d'action sur mon Alarme .

Pour récupérer les informations de l'alarme tu dis de créer un petit script en php, tu pourrai m'aiguiller un petit peu sur ce que je dois faire ou demander au server. ,je ne suis pas trop calé en php . 

D'avance merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir Chacal,

 

As tu réussi a finalyser l'intégration a Domoticz? Pour ma part je souhaite simplement récupérer l'état général et des différentes zones. Si tu as réussi peux tu m'indiquer ta méthode?

 

Merci !

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 12/4/2017 à 22:55, MAidEN91 a dit :

Bonsoir Chacal,

 

As tu réussi a finalyser l'intégration a Domoticz? Pour ma part je souhaite simplement récupérer l'état général et des différentes zones. Si tu as réussi peux tu m'indiquer ta méthode?

 

Merci !

bonsoir maiden , 

non je n'ai pas réussi a récupérer les états , je ne m'y connais pas trop en php et je ne sais pas comment faire pour afficher les états ds le serveur , j'avais demande conseils mais pas de réponses 

 

j'arrive à armer/ désarmer en partiel ou total ave domoticz , voila mes avancées .

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Excusez mon pauvre français,

Est-il possible pour que Somone publie des instructions étape par étape sur la façon de configurer l'interface Paradox IP100 VD sur raspbery pi? 

Je suis tout à fait nouveau avec linux et j'essaie d'intégrer l'alarme paradoxe avec Fibaro HC2.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

 

Pour information, je suis en cours de test d'une version modifiée permettant d'envoyer les changements d'état alarme + zones vers Jeedom.

 

Je me suis inspiré d'un script OpenSprinkler-Push-Notifications que j'avais déjà modifié pour envoyer les changements d'état de mon système d'arrosage automatique vers Jeedom. Si ça peut intéresser quelqu'un, je déposerai le code sur GitHub.

 

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Voici: https://github.com/domorama/ip150_interfacer

 

J'ai fait le minimum pour que ça marche chez moi. Je n'ai pas modifié les docs. Les variables à modifier pour l'intégration Jeedom sont relativement simples. Voir aussi la page OpenSprinkler-Push-Notifications pour la mise en place du service Linux.

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@foxchip,

 

merci pour ce gros boulot... je ne suis pas du niveau de certains de cette discussion et j'essaie de comprendre les choses....

J'execute le script toutes les minutes sur un nas synology... je ne sais pas si il se lance...

 

Mon problème vient plutôt du coté de la hc2 ... lors du debug du module virtuel alarme (où j ai bien renseigné les id des différents modules et mis le bon nombre dans le script juste apres) , j'ai une erreur sur la ligne 5 :expected value but found invalid token at character 1  .....

 

Si tu pouvais m'en dire plus...

Merci d'avance...

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je suis tombé sur ce fil de discussion et qui répond à ma problématique..

J'ai une alarme paradox sp6000 avec  une interface IP150 et je souhaite bien sûr l'interfacer avec l'eedomus ou jeedom.

Pour l'instant, je gére ça avec un google script qui interagit avec la réception d'un mail lors d'un événement mais c'est un peu usine a gaz !

J'ai vu le github de @Guiiix qui correspond a ce que je veux faire. Je souhaiterai mettre le script sur un raspberry Pi zero.

j'ai installé numpy et pyjsparser et copié les scripts mais lorsque je lance python paradox.py -v > log.txt, j'ai une erreur sur la global verbose ! j'ai zappé d'installer un truc ?

xx@raspberrypi:~/ip150 $ python paradox.py -v > log.txt
Traceback (most recent call last):
  File "paradox.py", line 14, in <module>
    globals.verbose = True
AttributeError: 'builtin_function_or_method' object has no attribute 'verbose'

 

Autre question, quand vous parlez des identifiants, c'est le login de la page web ?

pour moi, elle se connecte via le port 50005 (d'après la page web, onglet "Configur. de l'IP150"), normal ?

par avance, merci d'avance, a celles et ceux qui m'aideront

Capture.JPG

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Pour l'erreur sur le script je ne sais pas trop t'aider, mais pour l'identifiant c'est bien celui de l'interface web sur laquelle tu peux accéder depuis ton pc (port 80 ou 443) qu'il faut renseigner.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, MAidEN91 a dit :

Bonjour,

 

Pour l'erreur sur le script je ne sais pas trop t'aider, mais pour l'identifiant c'est bien celui de l'interface web sur laquelle tu peux accéder depuis ton pc (port 80 ou 443) qu'il faut renseigner.

Merci nickel ... je me demande pourquoi je n'ai pas pensé au port 80 !

mais en faisant  python paradox.py et en changeant de port, ça fonctionne et en plus, visiblement, j'ai encore accès à l'appli android.

Partager ce message


Lien à poster
Partager sur d’autres sites

×