Aller au contenu

Arnaud78

Membres confirmés
  • Compteur de contenus

    31
  • Inscription

  • Dernière visite

Réputation sur la communauté

0 Neutral

À propos de Arnaud78

  • Rang
    Nouveau

Profile Information

  • Sexe :
    Homme
  • Ville :
    Meulan
  • Intéret :
    Domotique, Flipper, HC3
  • Box
    Autre
  • Version
    5.070.42
  1. Arnaud78

    Quick App - Sonos Zone Controller

    Oui, je le pense vraiment car je peux le lancer directement en allant le chercher via la selection par repertoire
  2. Arnaud78

    Quick App - Sonos Zone Controller

    Pas de modification visuelle (ni auditive)
  3. Arnaud78

    Quick App - Sonos Zone Controller

    Bonjour Krikroff et merci pour ta réponse rapide. Je mets ceci dans une scène sans condition (juste pour les tests). fibaro.call(716, "playStream", "smb://NAS/Qmultimedia/Musique/HC2/mimireveil.mp3", true, 50, 8000) et j'obtiens cela dans la ligne des DEBUG [10.05.2021] [09:38:01] [DEBUG] [QA-SONOS-716]: onAction: {"args":["smb:\/\/NAS\/Qmultimedia\/Musique\/HC2\/mimireveil.mp3",true,50,8000],"deviceId":716,"actionName":"playStream"} Sur l'application Sonos S1 controller du fabriquant (sous mac) je vois le nom s'afficher mais lors de la connection, il ne fait rien de plus, pas de lecture et si je force la lecture, il réessaye la connection sans succès. Est-ce que les doubles \/ soit Slash et AntiSlash sont logiques ou bien je fais quelque chose dans le mauvais sens ? Merci et bon lundi à vous. Edit : Je pense qu'il peut également s'agir des droits d'accès du NAS car dans le chemin créer sur l'app Sonos S1, je dois lui donner le login et mot de passe. Si quelqu'un a une idée sur la façon de rajouter le login+pass ?
  4. Arnaud78

    Quick App - Sonos Zone Controller

    Bonjour à vous tous et merci à nouveau à Krikroff pour ce superbe outil ! J'utilisais dans la version HC2, la possibilité de récupérer mes morceaux via SMB sur mon serveur. Est-ce toujours possible ? J'ai essayé les commandes :"Playfile" et "Playstream" mais sans succès car je n'arrive pas à mettre une ligne de chemin type : fibaro.call(716, "playStream", "smb://NAS._smb._tcp.local/Qmultimedia/Music/HC2/reveil.mp3", true, 50, 8000) Auriez-vous une idée ? Merci,
  5. Arnaud78

    Station météo Netatmo

    Bonjour, Je me réponds à moi-même au cas ou d'autres personnes seraient dans le même cas. Les différents scripts que l'on peut retrouver pour faire fonctionner le retour d'information de la Netatmo sur la HC2 ne fonctionne pas dans mon cas sans que je ne change les lignes d'accès à l'API par http au lieu de https. (cela dit dans la création de mon compte sur le site de Netatmo, les informations de connexion montraient 'http'). J'ai donc fait les changements, mais malgré cela, j'avais toujours un problème d'interprétation du Json via le module virtuel. Après différents essai, j'ai remarqué que malgré que fichier généré par l'appel de la page PHP était identique à un autre fichier fonctionnant (depuis le site de Pascal Stéphany) celui-ci n'était pas interpréter de la même façon. J'ai changé le code d'enregistrement de mon fichier script PHP en ISO-8859-1 au lieu de Utf-8 et maintenant cela fonctionne bien pour les différents devices et modules (5 au total). je vais enfin pouvoir dormir... Bonne journée.
  6. Arnaud78

    Station météo Netatmo

    Bonjour, Merci pour cette précision, mais il n'y a pas de rapport avec la capacité ou non de la HC2 à gérer les Https. Un script, dumoins plusieurs sont actuellement ici ou sur d'autres forums. Lorsque j'utilise le module virtuel de Krikroff avec le domaine de Pascal Stephany. cela fonctionne correctement. Je pense qu'il y a une petite chose à faire sur le serveur qui détient le script, mais je ne sais pas quoi exactement. Merci.
  7. Arnaud78

    Station météo Netatmo

    Bonjour, J'ai l'impression d'être le seul à ne pas savoir se connecter correctement sur la Netatmo à partir du HC2. Est-ce qu'une bonne âme charitable voudrait bien m'aider afin que je puisse dormir un jour à nouveau ? J'ai utilisé le script de Cédric Locqueneux concernant la mise en place d'un fichier script netatmo.php sur un serveur... (avec les différentes données, username, password, id, secret). Dans ce script, il est mentionné le fait que si on interroge l'adresse : http://www.xxxxx.xxx/script/netatmo.php?intext=int, on doit obtenir une suite d'information type : {"status":"ok","body":[{"beg_time":1399902868,"value":[[19.5,455,56]]}],"time_exec":0.011034965515137,"time_server":1399903486} ce qui semble être mon cas, uniquement lorsque je change le https par http dans ledit script. Dans le cas ou je garde à l'identique le script, j'obtiens une erreur du type : Warning: file_get_contents(https://api.netatmo.net/oauth2/token) [ function.file-get-contents]: failed to open stream: Invalid argument. Je précise une chose, si j'utilise le lien de Pascal Stephany de www.domotique-info.fr, cela semble fonctionner correctement (à part évidemment que j'ai ses valeurs au lieu des miennes). J'ai tenté d'utiliser le code de Krikroff dans un module virtuel en ayant préalablement créer les étiquettes qui vont bien et il semble que j'ai le même type d'erreur, c'est à dire : [DEBUG] 09:46:36: Récupération des données interieurs: false [DEBUG] 09:46:36: err: [string "while true do..."]:87: Expected value but found invalid token at character 1 [DEBUG] 09:46:36: Récupération des données extérieurs : false [DEBUG] 09:46:36: err: [string "while true do..."]:43: Expected value but found invalid token at character 1 Donc voici mes questions : 1) Doit-on utiliser https ou http ? 2) Dans le cas de https, à Part le fichier netatmo.php, doit-on copier d'autres fichiers sur le serveur, type SDK ? ​3) Y a t-il quelques choses à faire par rapport à "Scope" ? 4) Heu? Pourquoi cela ne fonctionne pas ? ​Merci pour votre aide. Bonne journée. Arnaud
  8. Arnaud78

    Régulation De L'humidité D'une Pièce

    Heu?! C'est moi, ou il y a un problème de nom de variable entre targetValue et humidyTargetValue ?
  9. Arnaud78

    Régulation De L'humidité D'une Pièce

    Je viens de le mettre en place, je vous ferais par de mon expérience d'ici quelques jours. Merci à tous les deux.
  10. Arnaud78

    Régulation De L'humidité D'une Pièce

    @Steven : Désolé j'étais en train de rédiger et n'ai pas vu ton message. Mais ouais c'est exactement ce que je recherche.
  11. Arnaud78

    Régulation De L'humidité D'une Pièce

    Pièce : Au sous sol (dont 1 partie légèrement enterrée). Déshumidificateur : EDS50 ( WOODS - Deshumidificateur professionnel Blanc - ED50 ). il a la particularité de vider directement dehors et d'avoir une sonde dite mécanique. En gros on ne perd jamais la valeur après coupure de courant. ​ Sonde : ST814, et oui je suis complètement d'accord avec toi, il faut obligatoirement les décaler car comparer à des Oregon il y a au moins 8 à 10% d'écart à environ 60% d'hygrométrie. J'ai fait un paquet de test, je dois avoir 4x ST814 et une dizaine d'Oregon. Il n'y a pas photo, je serais Oregon, je me mettrais au Z-Wave. En gros en ce moment, c'est une pièce d'écoute/ciné et le déshumidi se déclenche toutes les 30 minutes pendant 5 minutes car je n'ai pas la possibilité de lui changer sa différence d'intervention. Je pense que l'hysteresis me permettrait de lui dire de démarrer à + de 65% et de s'arrêter à 55% et non de démarrer à 61% et de s'arrêter à 59%. Je pense que tu as compris l'idée.
  12. Arnaud78

    Régulation De L'humidité D'une Pièce

    Bonjour Krikroff, As-tu modifié ton script avec l'intervention de l'hysteresis ? car j'aime bien l'idée du script, mais je pense que dans mon cas, le déshumidificateur va démarrer et s'arrêter toutes les 5 minutes. Merci.
  13. @Lazer: Est-ce qu'il serait envisageable d'utiliser ce module virtuel en faisant quelques modifications, avec un NAS Qnap et la surveillance station de Qnap ?! Bonne soirée.
  14. Arnaud78

    Modules Les Plus Consommateurs D'énergie

    H.S. @Krikroff : Le DSB05 faisait planter le script de Lazer, une fois exclu et réinstallé, tout est rentré dans l'ordre. Par contre, le ST814 en ID:36 faisait planter le toolkit. Lorsque je lançais la recherche des appareils, je scrollais la liste et juste avant de faire apparaître le ST814, il y avait un crash. J'ai simplement triple cliqué sur le bouton d'activation afin de lui faire reconnaître sa position et tout est ok maintenant. Je ne sais pas trop l'expliquer car je ne pense pas qu'il y ait de rapport mais bon. Cela faisait des semaines que je ne pouvais plus utiliser le toolkit... Donc maintenant c'est
  15. Arnaud78

    Modules Les Plus Consommateurs D'énergie

    @ Lazer : 340 modules en tout genre et cela fonctionne parfaitement après vérification d'un module AEON DSB05 qui faisait planter le code. @Frederic : Après vérification, le code fonctionne bien, mais il m'a fallu exclure et ré inclure 1 module (DSB05) et en réactiver 1 (ST814). Donc ok de mon coté. Ce qui est bien, c'est que je ne pouvais plus utiliser le toolkit de Krikroff à cause apparemment de ce DSB05 et que maintenant tout est rentré dans l'ordre.
×