Aller au contenu

Recommended Posts

Bonjour à tous, 

 

J'en ai marre d'avoir cette page qui me prévient "d'un problème de sécurité avec cette page".

J'ai essayé d'installer un certificat let's encrypt, ... à priori c'est bon, sauf que toujours le même problème.

J'utilise aussi bien internet explorer que Google Chrome.

Il y aurait-il une âme charitable pour me filer un coup de main, je trouve de tout et de rien sur le web, sans savoir vraiment quoi chercher.

 

D'avance merci pour votre aide.

 

Prenez soin de vous et , ..... restez chez vous !

Message - Google.png

Message - Internet explorer.png

Partager ce message


Lien à poster
Partager sur d’autres sites

@Rem's

 

Si tu as un syno , je te conseille de faire un certif let's encrypt type  wildcard ex: *.tondomaine.com  let's encrypt.

 

une fois celui-ci fait , tu fais un reverse proxy avec ton syno.( cela évitera d'ouvrir beaucoup de  ports ( NAT ) sur ton  routeur) en fait tu rediriges le 443 sur tes urls de ton lan.

 

pour le certificat je me suis servi d une  machine en docker  en suivant ce tuto :

 

https://www.blackvoid.club/lets-encrypt-docker-wild-card-certs/

 

pour le reverse proxy :

http://sarakha63-domotique.fr/reverse-proxy-sur-nas-synology-ssl/

 

j 'espérè que cela t'aidera ...

 

Minos

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

j’ai pas de solutions, mais je souhaite suivre la discution... ;) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Haproxy sur un debian c'est top
Il y a un tuto voir plusieurs sur le forum

Envoyé de mon BLA-L29 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci de votre réponse.

Je suis sur Synology, j'ai créé un certificat let's encrypted.

J'ai essayé de créer un proxy reverse, mais sur le port 5021 (connexion https).

Mais en fait, il ne se passe rien, aussi bien sur Chrome que IE.

 

Une idée ?? d'avance merci du coup de main.

Partager ce message


Lien à poster
Partager sur d’autres sites

pour ton probléme tu parles en local ou en accès distant

 

Sur le syno je crois que le port HTTPS et 5001

sous haproxy j'ai cela

frontend https-in
   bind :::443 ssl crt /etc/haproxy/certs/ no-sslv3
   reqadd X-Forwarded-Proto:\ https
   
   # Define hosts
   acl dsm hdr(host) dsm.toto.fr
   acl letsencrypt-acl path_beg /.well-known/acme-challenge
   
   use_backend backendDSM if dsm
  
   use_backend letsencrypt-backend if letsencrypt-acl
   default_backend www-backend 
#----------------------------------------------------------------------------------------------    
backend backendDSM
    mode http
    option httpchk
    option forwardfor except 127.0.0.1
    http-request add-header X-Forwarded-Proto https if { ssl_fc }
    server DSM_ESXI 192.170.47.11:5000

 

Partager ce message


Lien à poster
Partager sur d’autres sites

@Rem's

 

Mets un screen shot de ta conf en floutant ce qui est sensible ...;)

histoire de voir un peu le bouzin ..:2:

Partager ce message


Lien à poster
Partager sur d’autres sites

voila ma conf pour te donner une idée

 

Reverse-proxy.JPG.4e1c170359519779df1b2554c67a267e.JPG

Partager ce message


Lien à poster
Partager sur d’autres sites

Voila ce que j'ai comme paramétrage.

Je suis une quiche, mais il me semble que j'ai bien renseigné(sinon case rouge).

 

Si vous avez une idée ... d'avance merci du coup de main

Certificat.png

Reverse proxy.png

Partager ce message


Lien à poster
Partager sur d’autres sites

@Rem's

 

Ok sur la destination on ne le voit pas , mais tu rediriges sur une ip en https  ? c 'est bien ça .

 

il faut que ton 443 soit ouvert sur ta freebox (dans les gestions des ports )  à destination de ton syno sur le port  DSM https que tu as paramétré.

 

 

Je sais pas si c 'est très clair ..?:2:

 

 

 

 

 

 

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

×