Aller au contenu
Lazer

Quick App - Gestionnaire d'Événements Automatique - GEA pour HC3

Recommended Posts

Oui tout à fait avec la méthode updateProperty ça devrait fonctionner (cf l'URL que j'ai donné en page précédente).

 

J'ai regardé dans GEA, il appelle setProperty, ce qui semble être un reste de la HC2, et j'ai l'impression que cette méthode n'est plus implémentée dans les QuickApps.

@Dragoniacs ou les autres adeptes des belles icones, vous avez testé de mettre à jour les icones des autres modules via GEA ?

Parce que tel que c'est là, ça ne doit jamais fonctionner.

Sinon je remplacerai par updateProperty

Partager ce message


Lien à poster
Partager sur d’autres sites

@Lazer @Dragoniacs J'ai mis en place le la ligne GEA dans le setEvents() de config et ça fonctionne bien pour moi. je n'ai rien modifié dans le main.

Voici la ligne GEA:

GEA.add(true, 0, "", {"CurrentIcon", 29, 1053})

et le debug

[17.01.2021] [19:41:48] [TRACE] [QA_GEA_29]: Ajout auto : #1 Démarrage GEA
[17.01.2021] [19:41:48] [TRACE] [QA_GEA_29]: Ajout auto : #2 [true][CurrentIcon, [29,1053]]

J'ai testé en changent plusieurs d'icônes et ça fonctionne parfaitement.

Partager ce message


Lien à poster
Partager sur d’autres sites

Fonctionne parfaitement bien pour moi aussi avec le G.E.A dans le fichier config

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je vois une seule différence entre ta ligne et la mienne : pas de guillemets autour du numéro de l'icône...
J'essaie ça demain.

Envoyé de mon RMX1993 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon ben même en corrigeant la ligne cela ne fonctionne pas.

Je suis bien en V7.11, mais je n'ai pas installé la dernière BETA de la box.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Il faut donc installer la dernière beta de la box pour pouvoir changer les icônes avec un GEA.add

Envoyé de mon RMX1993 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

@Dragoniacs Oui je suis avec la dernière version beta de la HC3 et avec GEA 7.11

Partager ce message


Lien à poster
Partager sur d’autres sites

Le problème vient tout juste de se réalisér. 

 ci-dessous le debug

 

[25.01.2021] [09:42:54] [DEBUG] [QA_GEA_252]:         [action] [OnOff, [91]]
[25.01.2021] [09:42:55] [DEBUG] [QA_GEA_252]: @0s [Validation] #5 [SceneActivation, [264,2]][OnOff, [89]]
[25.01.2021] [09:42:55] [DEBUG] [QA_GEA_252]: @0s [Validation] #6 [SceneActivation, [264,3]][Open, [250,100]][Global, ["sceneactiva","on"]]
[25.01.2021] [09:42:55] [DEBUG] [QA_GEA_252]: @0s [Validation] #8 [SceneActivation, [264,3]][Global, ["VL","ok"]][Open, [95,100]][Global, ["VL","0"]]
[25.01.2021] [09:42:55] [DEBUG] [QA_GEA_252]: @0s [Validation] #9 [SceneActivation, [264,4]][Close, [[250,95],100]][Global, ["VL","0"]]
[25.01.2021] [09:42:55] [DEBUG] [QA_GEA_252]: @0s [Validation] #10 [SceneActivation, [264,5]]
[25.01.2021] [09:42:55] [DEBUG] [QA_GEA_252]: @0s [Validation] #11 [SceneActivation, [264,6]]
[25.01.2021] [09:42:55] [DEBUG] [QA_GEA_252]: @0s [Validation] #12 [SceneActivation, [264,7]][QuickApp, [238,"p4"]]
[25.01.2021] [09:42:55] [DEBUG] [QA_GEA_252]: @0s [Validation] #13 [SceneActivation, [264,8]][Stop, [95]]
[25.01.2021] [09:42:55] [DEBUG] [QA_GEA_252]: @0s [Validation] #14 [SceneActivation, [264,8]][Stop, [250]]

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah merci :)

 

Mais tu pourrais me fournir aussi le début du log, à partir du moment où il affiche un message du genre ("déclenchement de GEA par événement...") ?

 

Et pendant que j'y pense, pour essayer d'avancer pendant ce temps là (et simplifier le prise de logs, car je me doute que ce n'est pas évident de tomber dessus...), tu pourrais créer une autre instance de GEA, avec uniquement ta ligne censée déclencher le (ou les) SceneActivation qui pose problèmes. Évidemment dans ton GEA principal, tu enlèves ces lignes là, sinon ils vont se déclencher en double.

 

Autre chose, dans le GEA dédié aux SceneActivation, en plus du GEA.debug=true, tu peux activer une autre option, qui est GEA.lldebug=true et donnera encore plus d'infos.

Je ne sais pas si ça suffira à comprendre ce qui se passe, mais ça me donnera encore plus d'infos.

Merci.

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, c'est le principe de l'option cachée et non documentée :P

Bref, tu l'ajoutes comme je t'ai dit, c'est tout, dans ta function config(GEA) avec les autres options personnalisées.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

ici 

    -- ===================================================
    -- Configuration générale
    -- ===================================================
    GEA.debug = true
    GEA.lldebug= true
    GEA.checkEvery = 30
    GEA.portables = {216,219}
    GEA.globalvariables = "GEA_Tasks_GEA3"
    GEA.language = "fr"
end

Partager ce message


Lien à poster
Partager sur d’autres sites

oui voilà exactement, c'est donc bien dans la function config(GEA) comme je disais plus haut ;)

 

Partager ce message


Lien à poster
Partager sur d’autres sites

voila le bug est peut-être dedans

 

[25.01.2021] [17:00:29] [TRACE] [QA_GEA_265]: --------------------------------------------------------------------------------
[25.01.2021] [17:00:29] [TRACE] [QA_GEA_265]: Démarrage par événement de GEA 7.11 (mode device [264])
[25.01.2021] [17:00:29] [TRACE] [QA_GEA_265]: --------------------------------------------------------------------------------
[25.01.2021] [17:00:29] [DEBUG] [QA_GEA_265]: copy.check() copy.name=SceneActivation id=264 property=1 value=1 value2=1 value3=1 value4=1
[25.01.2021] [17:00:29] [WARNING] [QA_GEA_265]: copy.getValue() 2 return copy.lastvalue, copy.lastDisplayValue : (boolean) true, (boolean) true
[25.01.2021] [17:00:29] [DEBUG] [QA_GEA_265]: copy.check() result = (boolean) true
[25.01.2021] [17:00:29] [WARNING] [QA_GEA_265]: GEA:check() result = true, true
[25.01.2021] [17:00:29] [DEBUG] [QA_GEA_265]: @0s [Validation*] #2 [SceneActivation, [264,1]][OnOff, [91]]
[25.01.2021] [17:00:29] [TRACE] [QA_GEA_265]:    [Démarrage] #2 [SceneActivation, [264,1]][OnOff, [91]]
[25.01.2021] [17:00:29] [DEBUG] [QA_GEA_265]:         [action] [OnOff, [91]]
[25.01.2021] [17:00:30] [DEBUG] [QA_GEA_265]: Event : {"type":"DevicePropertyUpdatedEvent","data":{"id":264,"property":"sceneActivation"}}
[25.01.2021] [17:00:30] [TRACE] [QA_GEA_265]:
[25.01.2021] [17:00:30] [TRACE] [QA_GEA_265]: --------------------------------------------------------------------------------
[25.01.2021] [17:00:30] [TRACE] [QA_GEA_265]: Démarrage par événement de GEA 7.11 (mode device [264])
[25.01.2021] [17:00:30] [TRACE] [QA_GEA_265]: --------------------------------------------------------------------------------
[25.01.2021] [17:00:30] [DEBUG] [QA_GEA_265]: copy.check() copy.name=SceneActivation id=264 property=1 value=1 value2=1 value3=1 value4=1
[25.01.2021] [17:00:30] [WARNING] [QA_GEA_265]: copy.getValue() 2 return copy.lastvalue, copy.lastDisplayValue : (boolean) true, (boolean) true
[25.01.2021] [17:00:30] [DEBUG] [QA_GEA_265]: copy.check() result = (boolean) true
[25.01.2021] [17:00:30] [WARNING] [QA_GEA_265]: GEA:check() result = true, true
[25.01.2021] [17:00:30] [DEBUG] [QA_GEA_265]: @0s [Validation*] #2 [SceneActivation, [264,1]][OnOff, [91]]
[25.01.2021] [17:00:30] [TRACE] [QA_GEA_265]:    [Démarrage] #2 [SceneActivation, [264,1]][OnOff, [91]]
[25.01.2021] [17:00:30] [DEBUG] [QA_GEA_265]:         [action] [OnOff, [91]]
[25.01.2021] [17:00:31] [DEBUG] [QA_GEA_265]: Event : {"type":"DevicePropertyUpdatedEvent","data":{"id":264,"property":"sceneActivation"}}
[25.01.2021] [17:00:31] [TRACE] [QA_GEA_265]:
[25.01.2021] [17:00:31] [TRACE] [QA_GEA_265]: --------------------------------------------------------------------------------
[25.01.2021] [17:00:31] [TRACE] [QA_GEA_265]: Démarrage par événement de GEA 7.11 (mode device [264])
[25.01.2021] [17:00:31] [TRACE] [QA_GEA_265]: --------------------------------------------------------------------------------
[25.01.2021] [17:00:31] [DEBUG] [QA_GEA_265]: copy.check() copy.name=SceneActivation id=264 property=1 value=1 value2=1 value3=1 value4=1
[25.01.2021] [17:00:31] [WARNING] [QA_GEA_265]: copy.getValue() 2 return copy.lastvalue, copy.lastDisplayValue : (boolean) true, (boolean) true
[25.01.2021] [17:00:31] [DEBUG] [QA_GEA_265]: copy.check() result = (boolean) true
[25.01.2021] [17:00:31] [WARNING] [QA_GEA_265]: GEA:check() result = true, true
[25.01.2021] [17:00:31] [DEBUG] [QA_GEA_265]: @0s [Validation*] #2 [SceneActivation, [264,1]][OnOff, [91]]
[25.01.2021] [17:00:31] [TRACE] [QA_GEA_265]:    [Démarrage] #2 [SceneActivation, [264,1]][OnOff, [91]]
[25.01.2021] [17:00:31] [DEBUG] [QA_GEA_265]:         [action] [OnOff, [91]]
[25.01.2021] [17:00:33] [DEBUG] [QA_GEA_265]: Event : {"type":"DevicePropertyUpdatedEvent","data":{"id":264,"property":"sceneActivation"}}
[25.01.2021] [17:00:33] [TRACE] [QA_GEA_265]:
[25.01.2021] [17:00:33] [TRACE] [QA_GEA_265]: --------------------------------------------------------------------------------
[25.01.2021] [17:00:33] [TRACE] [QA_GEA_265]: Démarrage par événement de GEA 7.11 (mode device [264])
[25.01.2021] [17:00:33] [TRACE] [QA_GEA_265]: --------------------------------------------------------------------------------
[25.01.2021] [17:00:33] [DEBUG] [QA_GEA_265]: copy.check() copy.name=SceneActivation id=264 property=1 value=1 value2=1 value3=1 value4=1
[25.01.2021] [17:00:33] [WARNING] [QA_GEA_265]: copy.getValue() 2 return copy.lastvalue, copy.lastDisplayValue : (boolean) true, (boolean) true
[25.01.2021] [17:00:33] [DEBUG] [QA_GEA_265]: copy.check() result = (boolean) true
[25.01.2021] [17:00:33] [WARNING] [QA_GEA_265]: GEA:check() result = true, true
[25.01.2021] [17:00:33] [DEBUG] [QA_GEA_265]: @0s [Validation*] #2 [SceneActivation, [264,1]][OnOff, [91]]
[25.01.2021] [17:00:33] [TRACE] [QA_GEA_265]:    [Démarrage] #2 [SceneActivation, [264,1]][OnOff, [91]]
[25.01.2021] [17:00:33] [DEBUG] [QA_GEA_265]:         [action] [OnOff, [91]]
[25.01.2021] [17:00:35] [DEBUG] [QA_GEA_265]: ... vérification en cours #168 @5040s...
[25.01.2021] [17:00:35] [DEBUG] [QA_GEA_265]: copy.check() copy.name=true id=true property=true value=true value2=true value3=true value4=true
[25.01.2021] [17:00:35] [WARNING] [QA_GEA_265]: copy.getValue() 2 return copy.lastvalue, copy.lastDisplayValue : (boolean) true, (boolean) true
[25.01.2021] [17:00:35] [DEBUG] [QA_GEA_265]: copy.check() result = (boolean) true
[25.01.2021] [17:00:35] [WARNING] [QA_GEA_265]: GEA:check() result = true, true

 

Modifié par 971jmd

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah super

Bon par contre il y a plein de scenesactivation, donc tu peux me rappeler celui qui pose problème ?

 

J'ai pas du tout suivi ta config, donc penses à remettre ici tes règles GEA.add() en précisant quel sceneactivation correspond à quoi (le double clic qui pose problème, ou pas, etc)

Désolé mais je n'ai guère le temps, ni l'envie, de me plonger dans les docs des modules Fibaro....

Partager ce message


Lien à poster
Partager sur d’autres sites
	local id = {
----CUISINE
MINITELECOM = 264,  SUSPENSION_CUISINE = 91
	}


GEA.add(true, 0, "Démarrage de GEA N3 le #date# à #time#. GEA3", nil, "Démarrage GEA3")


GEA.add({"SceneActivation", id["MINITELECOM"] ,  1}, -1,"SUS CUISINE GEA3" , {{"OnOff", id["SUSPENSION_CUISINE"]}}) 



end

 

j'ai isolée fautif dans une seul instance et quand j'ai cliqué ça générer ce que je t'ai envoyé

 

Ça fait on et off 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

OK je vais regarder ça..... demain :)

 

Partager ce message


Lien à poster
Partager sur d’autres sites

@971jmd  je ne comprends toujours pas, mais je te propose de faire 2 tests.
On va modifier le code source de GEA, ça ira plus vite que de te d'envoyer une nouvelle version à chaque fois.

 

Dans le fichier main, à la ligne 591, tu remplaces cette lignes complète :

trigger   = function(id) return {event = {type = "device", id = self:findDeviceId(id), property = "sceneActivation"}, filter = {type = "DevicePropertyUpdatedEvent", data = {id = self:findDeviceId(id), property = "sceneActivation"}}} end,

Par cette nouvelle ligne :

trigger   = function(id, value) return {event = {type = "device", id = self:findDeviceId(id), property = "sceneActivation"}, filter = {type = "DevicePropertyUpdatedEvent", data = {id = self:findDeviceId(id), property = "sceneActivation", newValue = value}}} end,

 

Et tu refais tes tests sur plusieurs jours.

 

Ensuite, voici une autre suggestion de ligne, toujours pour remplacer cette même ligne :

trigger   = function(id, value) return {event = {type = "device", id = self:findDeviceId(id), property = "sceneActivation"}, filter = {type = "SceneActivationEvent", data = {deviceId = self:findDeviceId(id), sceneId = value}}} end,

Et tu me diras si ça change quelque chose.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

salut @Lazer

 

je pense avoir trouver le problème.

 

j'ai tester avec les lignes de code que tu ma envoyer et toujours  pareille 

 

Et je me suis dit que je vais essayer à nouveau de recréer une scène bloc toute simple juste pour voir si ça fonctionne, et ben tu sais quoi c'est la même chose la lampe On puis Off ou le contraire. 

 

Ce qui m'énerve c'est que j'avais déjà essayé avec une scène bloc il y a déjà un moment de ça et ça va être stable, donc c'est vraiment un problème FIBARO avec les SceneActivation

 

mai visiblement pas de problème avec les CentralSceneEvent

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah bon OK, merci de ton retour.

Quelque part ça me rassure pour le code LUA de GEA, car là je ne comprenais pas !!

 

Mais si le problème se situe dans la HC3, c'est finalement tout aussi gênant.

 

Une autre théorie serait que le problème proviennent du module lui-même (et envoie de mauvaises trames sceneActivation), mais tu avais dit que ça fonctionnait bien sur HC2.

Mais était-ce exactement le même module ? Parce que ça peut être un problème de firmware, ou même tout autre chose : par exemple un contact qui fait "rebond" électrique, donc au lieu de détecter un simple clic, il détecte un double clic, ou autre chose du même genre.

Partager ce message


Lien à poster
Partager sur d’autres sites

Le problème vient avec tous les modules qui fonctionne sur le principe de SceneActivation

 

Et tous ses modules fonctionnait très bien sur la HC2

Partager ce message


Lien à poster
Partager sur d’autres sites

OK, donc ça serait bien un problème lié à la HC3 ?

Il faut remonter le souci à Fibaro, c'est peut-être déjà fait, il faut fouiller sur le forum officiel.

Partager ce message


Lien à poster
Partager sur d’autres sites

×