Aller au contenu
Arnaud78

Modules Les Plus Consommateurs D'énergie

Recommended Posts

@shyrka973: oups! j'avais oublier de mettre mais prises de lumières on off et dimmer a ON....

 

j'ai maintenant des lectures! mais pas avec mes DSC24, je ne suis pas capable d'entrer le watt par prise....

 

Merci Bien,

 

Patrick

Partager ce message


Lien à poster
Partager sur d’autres sites

bizarrement j'ai aucune remontée moi, je suis encore en 4.040

J'ai mis 5mn de tempo, mais aucune info - il ne voit aucun de mes WP par exemple

 

faut que je regarde si un module pose problème pour l'exclure.

je vois ça ou ?

 

ok trouvé, c'est tout bon

 

par contre il faut que les WP, pas les FGRM222 par exemple ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour modifier rapidement la période de vérification sans modifier le code, on utilise la propriété "Port" du VD.

Donc darklite44, le 80mn correspond au 80 qui se trouve dans la propriété "Port". Même chose pour cybersquat pour le 0mn.

 

Mettez donc une valeur plus adéquat (5 ou 10 par exemple pour 5mn ou 10mn).

une des modifs suplémentaires que j'ai faites, est que si vous mettez 0 dans TCP port, il considère que c'est 1 sec

Partager ce message


Lien à poster
Partager sur d’autres sites

en fait j'ai la meme erreur sur la ligne 52

    local id    = variables[i][1]

il trouve bien mes 3 WP, mais bloque ici?

Partager ce message


Lien à poster
Partager sur d’autres sites

comme il semble que tout va bien en 4.042, voici la version finale qui est compatible v3.x et v 4.x.

J'ai également incorporé l'excellente idée de Shyrka973 d'avoir une liste de devices à  exclure, pour la v3.x.

Merci encore à  Shyrka973 pour le travail de compatibilité avec la v4.x.

Je propose que tout le monde parte de cette version, qu'on corrigera / améliorera pour tous avec vos remarques.

==> SVP apportez des propositions d'améliorations.

Top_10_Power_v3.0.vfib

 

  • Upvote 2

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour messieurs, du beau boulot,, ca marche super ;-)

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à  tous,

 

moi j'ai un petit soucis:

 

post-135-0-10583800-1429857595_thumb.jpg

 

 

l heure du last check change continuellement, en revenant même parfois dans le passé lol.

 

J'ai mis 5 minutes sur le port TCP  :rolleyes:

Partager ce message


Lien à poster
Partager sur d’autres sites

je viens de re tester, et tout ok en v3.600

cela doit donc venir de la v4.x.

Est-ce que la date du Last Checked change également de manière alléatoire dans la vue du VD ?

Sinon, le code pour afficher la ligne verte, se trouve àla fin du bouton

-- affichage du message en bas de l'icône en continu,
-- durant la période entre chaque test
statut = 'Last Check: ' ..os.date("%d/%m/%y %H:%M:%S").. ' - vérification toutes les ' ..Verification.. ' minutes'
i=0
while i < (Verification*60 + 1) do
	fibaro:log(statut)
	fibaro:sleep(9*1000)
	i = i + 9
end

essayez en mettant tout en commentaires, sauf

fibaro:log(statut)

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai aussi constaté ce problème mais uniquement au moment où j'enregistre le VD. Si on modifie la fréquence par exemple, on voit cette ligne afficher l'ancienne fréquence et la nouvelle. Mais après un moment, ça se stabilise.

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai le probleme aussi, l'heure n'est pas la bonne, on va attendre un peu alors ;-)

Partager ce message


Lien à poster
Partager sur d’autres sites

Voilà  ce que donne la capture pour bien se rendre compte.  J'ai utilisé Screentogif qui permet de réaliser des GIF animés de ce qui se passe sur votre écran.

gallery_178_65_88073.gif

Partager ce message


Lien à poster
Partager sur d’autres sites

le check toutes les 80 min me semble beaucoup. As-tu le même résultat avec un intervalle de 1 min ?

Autre piste : le HC2 perd peut-être les pédales car il ne trouve pas les icônes => essaye en lui donnant des références d'icônes qui existent (cela peut être 5 fois la même icône)

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne vois pas trop comment faire pour changer l'intervalle mais je vois un bug :

-- fréquence de vérification [min]
local Verif = fibaro:get(SelfId,"TCPPort")

On récupère le port du VD comme intervalle 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ce n'est pas un bug. Le port du VD est effectivement uniquement utilisé pour déterminer la fréquence de rafraichissement.

Dans le même ordre d'idée tu dois laisser le champ) IP Adress vide.

Mais également, je constate que tu n'utilises pas la dernière version du code que j'ai postée, dans la dernière verrsion le champ est Verification et pas Verif

Partager ce message


Lien à poster
Partager sur d’autres sites

donc ton cham IPAdress est bien vide ?

 

tu as également mis des n° d'icônes qui existaient ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Il est préférable d'utiliser le VD de jojo qui se trouve ici.

 

@jojo, peut être pourrais tu voir avec un admin pour insérer un post au debut de ce fil, qui contiendrai un ton VD avec quelques explications (et celui de Lazer aussi).

Partager ce message


Lien à poster
Partager sur d’autres sites

essaye également un debug en appuyant sur le bouton

Partager ce message


Lien à poster
Partager sur d’autres sites

Ce n'est pas mon virtual device, cest celui de Lazer.

Je n'ai fait que des petites modifs cosmétiques et toi tu l'as rendu compatible avec v4.x

 

@Lazer, ne ferait-on pas comme pour le device MyBatteries, un nouveau sujet "Top 10 Power", et tu modifierais le lien dans ta signature vers ce nouveau topic. Comme ça je pourrais éditer la 1° page ?

Partager ce message


Lien à poster
Partager sur d’autres sites

donc ton cham IPAdress est bien vide ?

 

tu as également mis des n° d'icônes qui existaient ?

Oui IPAdress est vide. J'ai n'ai pas trouvé comment les ID des icônes que j'ai importées.

 

Il est préférable d'utiliser le VD de jojo qui se trouve ici.

 

@jojo, peut être pourrais tu voir avec un admin pour insérer un post au debut de ce fil, qui contiendrai un ton VD avec quelques explications (et celui de Lazer aussi).

 

C'est ce que j'ai fait, j'ai bien importé Top_10_Power_v3.0.vfibLe debug me donne ça :

[DEBUG] 16:48:10: Pause 5 min
[DEBUG] 16:53:13: Pause 5 min
[DEBUG] 16:58:16: Pause 5 min
[DEBUG] 17:03:19: Pause 5 min
[DEBUG] 17:08:22: Pause 5 min
[DEBUG] 17:13:25: Pause 5 min
[DEBUG] 17:18:28: Pause 5 min
[DEBUG] 17:23:31: Pause 5 min
[DEBUG] 17:28:34: Pause 5 min
[DEBUG] 17:33:37: Pause 5 min

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×