Welcome to Domotique-fibaro

 

Inscrivez-vous maintenant pour accéder à toutes nos fonctionnalités. Une fois inscrit et connecté, vous serez en mesure de contribuer à ce site en soumettant votre propre contenu ou en répondant au contenu existant. Vous serez en mesure de personnaliser votre profil, de recevoir des points de réputation comme une récompense pour la soumission de contenu, tout en communiquant avec d'autres membres via votre boîte de réception privée, et bien plus encore! Ce message sera supprimé une fois que vous vous êtes connecté.

 

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Nissan_GT-R

Besoin de votre aide pour Living Connect

45 messages dans ce sujet

Bonjour tout l'monde ;) et merci pour vos réponses :13:

 

j'ai testé le code de pepite et malheureusement ça ne fonctionne pas :(

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir, 

 

Ah zut ;-) 

 

poste le code que tu as utilisé stp ? et comment ? tu as modifié le SRT ou la LC13 ? 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour tout le monde ;)

 

Pepite j'ai créée une scène LUA et j'ai mis ça :

 

--[[
%% properties
90 value
146 value
%% events
%% globals
--]]


local lc13 = {
    CANAP = 90, 
    SDB = 95
    }
local SRT = {146}
-- ========================
local source = fibaro:getSourceTrigger()
if source["type"] == "property" then -- si scene est declenchée par le changement d'une propriété d'un module
    local ModuleDeclencheur = source["deviceID"]
    fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur)
    if ModuleDeclencheur == lc13["CANAP"] then -- si le module declencheur est une LC13
        local temperatureLC13 = fibaro:getValue(ModuleDeclencheur, "value")
        -- envoi tempérture au SRT
        fibaro:call(SRT, "setTargetLevel", temperatureLC13)
    else -- si Module declencheur est le SRT
        local temperatureSRT = fibaro:getValue(SRT, "value")
        -- envoi temperature aux lc13
        for i = 1, #lc13 do
            fibaro:call(lc13, "setTargetLevel", temperatureSRT)
        end
    end
end
 

Mais bête comme je suis, je suis sûr que j'ai tout fait de travers !!!

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e) (modifié)

Bonjour
@Nissan_GT-R

heuu, oui erreur de copier coller, il y en manque un peu ;-). Je l'ai refaite, à tester bien sûr ;-)


 

 --[[
%% properties
90 value
146 value
%% events
%% globals
--]]


local lc13 = {
    CANAP = 90, 
    SDB = 95
    }
    
local SRT = 146
-- ========================
local source = fibaro:getSourceTrigger()

if source["type"] == "property" then -- si scene est declenchée par le changement d'une propriété d'un module
    local ModuleDeclencheur = tonumber(source["deviceID"])
    fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur)
    
    if ModuleDeclencheur == lc13["CANAP"] then -- si le module declencheur est une LC13
    
        local temperatureLC13 = fibaro:getValue(ModuleDeclencheur, "value")     
        -- envoi tempérture au SRT
			fibaro:call(SRT, "setTargetLevel", temperatureLC13)
		
    else -- si Module declencheur est le SRT
    
        local temperatureSRT = fibaro:getValue(SRT, "value")
        -- envoi temperature aux lc13
        for i = 1, #lc13 do
            fibaro:call(lc13[i], "setTargetLevel", temperatureSRT)
        end
    end
end

 

Modifié par pepite
0

Partager ce message


Lien à poster
Partager sur d’autres sites

Coucou pepite ;)

 

J'ai refais un copier/coller mais ça ne fonctionne toujours pas :(

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu as quoi dans le debug ? Comment testes tu ? 

 

Tu commences du SRT ou du LC13 du canap ? 

N'oublie pas ce n'est pas instantané. ce sont des modules à pile. 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu peux poster le json de ton SRT ? 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Voilà pour le json du SRT :

 

{"id":146,"name":"Thermostat salon","roomID":4,"type":"com.fibaro.thermostatHorstmann","baseType":"com.fibaro.thermostatDanfoss","enabled":true,"visible":true,"isPlugin":false,"parentId":145,"remoteGatewayId":0,"interfaces":["battery","zwave","zwaveConfiguration","zwaveWakeup"],"properties":{"batteryLevel":91,"parameters":[{"id":1,"lastReportedValue":129,"lastSetValue":129,"size":1,"value":129},{"id":2,"lastReportedValue":0,"lastSetValue":0,"size":1,"value":0},{"id":3,"lastReportedValue":10,"lastSetValue":10,"size":1,"value":10}],"pollingTimeSec":0,"wakeUpTime":900,"zwaveCompany":"Horstmann Controls Limited","zwaveInfo":"2,2,78","zwaveVersion":"6.0","batteryLowNotification":"true","configured":"true","dead":"false","defInterval":"0","deviceControlType":"0","deviceIcon":"39","emailNotificationID":"0","emailNotificationType":"0","endPointId":"0","liliOffCommand":"","liliOnCommand":"","log":"En attente du réveil","logTemp":"TxtGreen","manufacturer":"","markAsDead":"false","maxInterval":"0","minInterval":"0","model":"","nodeId":"34","parametersTemplate":"43","productInfo":"0,89,0,1,0,3,6,0","pushNotificationID":"0","pushNotificationType":"0","remoteGatewayId":"0","saveLogs":"true","serialNumber":"","smsNotificationID":"0","smsNotificationType":"0","stepInterval":"0","targetLevel":"21.00","timestamp":"1494081065","unit":"C","useTemplate":"true","userDescription":"","value":"21.00"},"actions":{"getParameter":1,"reconfigure":0,"setInterval":1,"setParameter":2,"setTargetLevel":1,"setTime":1},"created":1493627086,"modified":1493627086,"sortOrder":38}

Et voilà le debug :

 

[DEBUG] 20:13:50: Module déclencheur : 90

[DEBUG] 20:20:31: Module déclencheur : 146

[DEBUG] 20:20:31: Module déclencheur : 146

 

Quand j'ai changé la température sur la tête du salon, ça n'a rien changé sur le SRT...

 

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bizarre, bizarre, tu reveilles bien les modules après ? ou tu attends leur réveil ? Tu mets bine une temperature de consigne differente ? car sur ton json le SRT est à 21 et la LC13  à 21 aussi ;-)

 

Pourtant dans le json de la tete LC13 et du SRT, on a bien le TargetLevel (temperature de consigne) et value (la temperature)

 

J'ai rajouté des debug pour voir où ca passe, sinon après in fera en mode api.get et api.put ;-)


 

--[[
%% properties
90 value
146 value
%% events
%% globals
--]]


local lc13 = {90, 95}
local SRT = 146
-- ========================
local source = fibaro:getSourceTrigger()

if source["type"] == "property" then -- si scene est declenchée par le changement d'une propriété d'un module
    local ModuleDeclencheur = tonumber(source["deviceID"])
    fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur)
   
   for i = 1, #lc13 do
        if ModuleDeclencheur == lc13[i] then -- si le module declencheur est une LC13
            fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur.. " == LC13")
    
            local temperatureLC13 = tonumber(fibaro:getValue(ModuleDeclencheur, "value"))
            local timestampLC13 = tonumber(fibaro:getValue(ModuleDeclencheur, "timestamp"))
            fibaro:debug("Temperature LC13 CANAP : " ..temperatureLC13.. " - TimeStap LC13 : " ..timestampLC13)  

            -- envoi température et timestamp au SRT
            fibaro:call(SRT, "setTargetLevel", temperatureLC13)
            fibaro:call(SRT, "setTime", timestampLC13)
            fibaro:debug("Envoi Température et TimeStamp au : " ..SRT)
        
        else -- si Module declencheur est le SRT
        
            local temperatureSRT = tonumber(fibaro:getValue(SRT, "value"))
            local timestampSRT = tonumber(fibaro:getValue(SRT, "timestamp"))
            fibaro:debug("Temperature SRT : " ..temperatureSRT.. " - Timestamp : "..timestampSRT)  
        
            -- envoi temperature et timestamp aux lc13
            for i = 1, #lc13 do
                fibaro:call(lc13[i], "setTargetLevel", temperatureSRT)
                fibaro:call(lc13[i], "setTime", temperatureSRT)
            end
            fibaro:debug("Envoi temperature aux LC13")
        end
    end
end

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Désolé pour le temps de réponse, je fais trop d'heures en ce moment :(

 

J'attends bien le réveil des modules...

 

Tout de suite la température était de 20° affichée sur le SRT et la LC13 du salon...

 

Je suis monté à 21° sur la tête du salon et voilà ce que ça dit :

 

 

[DEBUG] 17:28:25: Module Déclencheur : 90
[DEBUG] 17:28:25: Module Déclencheur : 90 == LC13
[DEBUG] 17:28:25: Temperature LC13 CANAP : 21 - TimeStap LC13 : 1494610022
[DEBUG] 17:28:25: Envoi Température et TimeStamp au : 146
[DEBUG] 17:28:25: Temperature SRT : 20 - Timestamp : 1494081065
[DEBUG] 17:28:25: Envoi temperature aux LC13
[DEBUG] 17:28:26: Module Déclencheur : 90
[DEBUG] 17:28:26: Module Déclencheur : 90 == LC13
[DEBUG] 17:28:26: Temperature LC13 CANAP : 20 - TimeStap LC13 : 20
[DEBUG] 17:28:26: Envoi Température et TimeStamp au : 146
[DEBUG] 17:28:26: Temperature SRT : 20 - Timestamp : 1494610022
[DEBUG] 17:28:26: Envoi temperature aux LC13

 

Encore merci pour ton aide et désolé de te déranger ;)

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,
Ah oui ca boucle :-) ca buggue :-)

Envoyé de mon Nexus 5X en utilisant Tapatalk

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e) (modifié)

Bonjour,

 

Désolé pour le retard
@Nissan_GT-R

On va essayer simple avec la tete du canap dont l'id est 90

 

--[[
%% properties
90 value
146 value
%% events
%% globals
--]]


local lc13 = 90
local SRT = 146
-- ========================
local source = fibaro:getSourceTrigger()

if source["type"] == "property" then -- si scene est declenchée par le changement d'une propriété d'un module
    local ModuleDeclencheur = tonumber(source["deviceID"])
    fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur)
   
 
        if ModuleDeclencheur == lc13 then -- si le module declencheur est la LC13 90
            fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur.. " == LC13 num"..lc13)
    
            local temperatureLC13 = tonumber(fibaro:getValue(ModuleDeclencheur, "value"))
            local timestampLC13 = tonumber(fibaro:getValue(ModuleDeclencheur, "timestamp"))
            fibaro:debug("Temperature LC13 CANAP : " ..temperatureLC13.. " - TimeStamp LC13 CANAP : " ..timestampLC13)  

            -- envoi température et timestamp au SRT
            fibaro:call(SRT, "setTargetLevel", temperatureLC13)
            fibaro:call(SRT, "setTime", timestampLC13)
            fibaro:debug("Envoi Température : " ..temperatureLC13.." et TimeStamp de "..timestampLC13.. "au : " ..SRT)
        end
end

 

Modifié par pepite
0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour pepite et encore merci pour ton aide ;)

Tu n'as pas à t'excuser, c'est déjàsuper sympa de ta part de m'aider ;)

J'ai essayé ton dernier post et pour l'instant ça a l'air de bien fonctionner...

Je vais faire d'autres tests et je tiens au courant... le problème c'est que je fais beaucoup beaucoup d'heures, ce boulot est en train de me rendre complètement cinglé !!!

Mais je continue les tests...

Encore merci pour ton aide ;)

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Par contre, la consigne est bien envoyée de la LC13 au SRT... mais du SRT à la LC13 ça ne fonctionne pas :(

0

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, Nissan_GT-R a dit :

SRT à la LC13 ça ne fonctionne pas

 :-) Je dirais normal, dans le dernier post que tu testes, seul est écrit de la LC13 au SRT ;-)

 

je te fais ca dans le sens SRT --> LC13

0

Partager ce message


Lien à poster
Partager sur d’autres sites

A tester, uniquement dans le sens SRT --> LC13, si c'est OK, on ne fera qu'un seul code. C'est pour dissocier, plus facile à debuguer si erreur ;-)


 

--[[
%% properties
90 value
146 value
%% events
%% globals
--]]


local lc13 = 90
local SRT = 146
-- ========================
local source = fibaro:getSourceTrigger()

if source["type"] == "property" then -- si scene est declenchée par le changement d'une propriété d'un module
    local ModuleDeclencheur = tonumber(source["deviceID"])
    fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur)

    if ModuleDeclencheur == SRT then -- si le module declencheur est le SRT
         fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur.. " == SRT num"..SRT)
     
         local temperatureSRT = tonumber(fibaro:getValue(ModuleDeclencheur, "value"))
        local timestampSRT = tonumber(fibaro:getValue(ModuleDeclencheur, "timestamp"))
         fibaro:debug("Temperature SRT : " ..temperatureSRT.. " - TimeStamp SRT : " ..timestampSRT)  
      
        -- envoi temperature et timestamp aux LC13
        fibaro:call(lc13, "setTargetLevel", temperatureSRT)
        fibaro:call(lc13, "setTime", timestampSRT)
        fibaro:debug("Envoi Température : " ..temperatureSRT.." et TimeStamp de "..timestampSRT.. "au : " ..lc13)
    end

end

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir pepite ;)

 

En effet ça fonctionne ;)

 

Et maintenant comment faire pour "assembler" les deux ?

 

Bonne soirée du sud et encore merci :)

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir @Nissan_GT-R,

 

A tester bien sur


 

--[[
%% properties
90 value
146 value
%% events
%% globals
--]]


local lc13 = 90
local SRT = 146

-- ========================
local source = fibaro:getSourceTrigger()

if source["type"] == "property" then -- si scene est declenchée par le changement d'une propriété d'un module
    local ModuleDeclencheur = tonumber(source["deviceID"])
    fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur)

    if ModuleDeclencheur == lc13 then -- si le module declencheur est la LC13 90
            fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur.. " == LC13 num"..lc13)
    
            local temperatureLC13 = tonumber(fibaro:getValue(ModuleDeclencheur, "value"))
            local timestampLC13 = tonumber(fibaro:getValue(ModuleDeclencheur, "timestamp"))
            fibaro:debug("Temperature LC13 CANAP : " ..temperatureLC13.. " - TimeStamp LC13 CANAP : " ..timestampLC13)  

            -- envoi température et timestamp au SRT
            fibaro:call(SRT, "setTargetLevel", temperatureLC13)
            fibaro:call(SRT, "setTime", timestampLC13)
            fibaro:debug("Envoi Température : " ..temperatureLC13.." et TimeStamp de "..timestampLC13.. "au : " ..SRT)

    elseif ModuleDeclencheur == SRT then -- si le module declencheur est le SRT
            fibaro:debug("Module Déclencheur : " ..ModuleDeclencheur.. " == SRT num"..SRT)
     
            local temperatureSRT = tonumber(fibaro:getValue(ModuleDeclencheur, "value"))
            local timestampSRT = tonumber(fibaro:getValue(ModuleDeclencheur, "timestamp"))
            fibaro:debug("Temperature SRT : " ..temperatureSRT.. " - TimeStamp SRT : " ..timestampSRT)  
      
            -- envoi temperature et timestamp aux LC13
            fibaro:call(lc13, "setTargetLevel", temperatureSRT)
            fibaro:call(lc13, "setTime", timestampSRT)
            fibaro:debug("Envoi Température : " ..temperatureSRT.." et TimeStamp de "..timestampSRT.. "au : " ..lc13)
    end

end

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour pepite ;)

 

Je suis dans le sud mais j'ai fait quelques petits tests et voilà ce que ça donne : 

 

- à partir du SRT :

 

 

[DEBUG] 11:59:26: Module Déclencheur : 146
[DEBUG] 11:59:26: Module Déclencheur : 146 == SRT num146
[DEBUG] 11:59:26: Temperature SRT : 17 - TimeStamp SRT : 1495626631
[DEBUG] 11:59:26: Envoi Température : 17 et TimeStamp de 1495626631au : 90
[DEBUG] 12:02:13: Module Déclencheur : 90
[DEBUG] 12:02:13: Module Déclencheur : 90 == LC13 num90
[DEBUG] 12:02:13: Temperature LC13 CANAP : 17 - TimeStamp LC13 CANAP : 1495626631
[DEBUG] 12:02:13: Envoi Température : 17 et TimeStamp de 1495626631au : 146

 

- à partir de la LC13 :


[DEBUG] 12:12:04: Module Déclencheur : 90
[DEBUG] 12:12:04: Module Déclencheur : 90 == LC13 num90
[DEBUG] 12:12:04: Temperature LC13 CANAP : 19 - TimeStamp LC13 CANAP : 1495626631
[DEBUG] 12:12:04: Envoi Température : 19 et TimeStamp de 1495626631au : 146
[DEBUG] 12:14:26: Module Déclencheur : 146
[DEBUG] 12:14:26: Module Déclencheur : 146 == SRT num146
[DEBUG] 12:14:26: Temperature SRT : 19 - TimeStamp SRT : 1495626631
[DEBUG] 12:14:26: Envoi Température : 19 et TimeStamp de 1495626631au : 90

 

Donc tout à l'air de fonctionner... merci mille fois pepite !!!

 

Je fais d'autres tests et si ça ne va pas je te tiens au jus...

 

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

@Nissan_GT-R Tu pourras STP partager (notamment dans tu premier post du sujet) tes VD et Scènes en expliquant leur fonctionnement ?

0

Partager ce message


Lien à poster
Partager sur d’autres sites