Aller au contenu
Domodial

Notifications problématique

Recommended Posts

Bonjour,

 

J'ouvre un sujet sur les notifications, parce que ça fait bien 1 an que rien n'est stable de mon coté, et je ne trouve pas pourquoi après avoir tout essayé avec plusieurs conseils.

Suis-je le seuls 

 

Pour info je recevais les notifications sur mon smarphone pro (Samsung S3), et sur mon Huawei perso sans probleme.

Et puis ma femme sur le même Huawei n'a jamais rien reçue.

Depuis 7 jours je ne reçois plus rien sur mon huawei.

 

Coté applications Fibaro

Je me suis assuré tout d'abord d'activer le Keep awake pour prevenir le sleep mode.

Ensuite du coté du terminal j'ai indiqué à android de ne jamais fermé l'appli Fibaro, ok ça mange de la batterie mais tant pis.

 

Un tour sur la méthode d'envoi

Toutes les notifications sont envoyés par GEA.

La seule que je reçois à ce jour c'est la notification de Backup de la box, mais cette notif est envoyé par le script.

Toutes les autres ne fonctionnent plus par GEA alors qu'elles fonctionnait (sauf pour ma femme).

 

Si j'essaye un test de notif sur les 3 smartphones à partir d'un script LUA avec une pause de 10 secondes entre chaque envoi, ça fonctionne et même sur celui de ma femme !!

 

GEA

Les mobiles sont renseignés comme ceci :

  local MobileId = {
  PHONE_NATHALIE = 558, -- (NATHALIE)
  PHONE_BERNARD = 557,  -- (BERNARD)
  PHONE_BERNARD_PRO = 531,  -- samsung GT-I9505 (PRO)
  }

 

Et la tronche d'une ligne de notification est comme ceci :

GEA.add({{"Global","EtatPortail","open"},{"Global","Maison","Absent"}}, -1, "Portail ouvert à #time# le #date#", {{"Portable", MobileId["PHONE_BERNARD"]}, {"Portable", MobileId["PHONE_BERNARD_PRO"]}, {"Portable", MobileId["PHONE_NATHALIE"]}})

ou

GEA.add(id["BASCULE_GARAGE"], -1, "Mouvement sur porte garage #time# le #date#", {{"Portable", MobileId["PHONE_BERNARD"]}, {"Portable", MobileId["PHONE_BERNARD_PRO"]}})

ou encore 

GEA.add({"Value-", id["NetAtmo_temp_ext"],0.10}, 10*30, "Température extérieure à #value#°C, risque de gel", {{"Time","05:00", "08:00"},{"Portable", MobileId["PHONE_BERNARD"]}, {"Portable", MobileId["PHONE_NATHALIE"]}})

  local estPresent = {"Global","Maison","Present"}
  local estAbsent = {"Global","Maison","Absent"}

GEA.add({{"Global","EtatPortail","open"},{"Global","Maison","Absent"}}, -1, "Portail ouvert à #time# le #date#", {{"Portable", MobileId["PHONE_BERNARD"]}, {"Portable", MobileId["PHONE_BERNARD_PRO"]}, {"Portable", MobileId["PHONE_NATHALIE"]}})
   GEA.add({{"Global","EtatPortail","close"},{"Global","Maison","Absent"}}, -1, "Portail fermé à #time# le #date#", {{"Portable", MobileId["PHONE_BERNARD"]}, {"Portable", MobileId["PHONE_BERNARD_PRO"]}, {"Portable", MobileId["PHONE_NATHALIE"]}})

 

Comme tous, j'ai une tonne de notifs donc je ne met que quelques une.

 

Merci à qui peut me sortir de cette mouise, parce du coup la domotique ne m'aide pas pour me prévenir à distance  ^^

 


   

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @Domodial,

 

Toujours pas résolu tes pushs ;-(

 

Tu ne recois plus rien sur aucun smartphone, ou tu recois sur ton Téléphone PRO encore, et plus rien sur les HUAWEI ?

 

En LUA depuis une scène avec des sleep c'est OK. Et si tu ne mets pas de Sleep, recois tu les notifications ?

Si oui, cela voudrait dire que cela viendrait de GEA ?

 

De mon côté, je recois toutes les notifs GEA mais ce n'est pas le sujet.

 

Je suis d'accord avec toi, sans notifs heuuu..

 

Workaround  : as tu une passerelle SMS ou tu es chez FreeMobile ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello @pepite

 

- Si je ne met pas les sleep en LUA j'en reçois que 1 sur 3 lors de mes tests c'est pour ça que j'ai mis des slips :D

- Non pas de passerelle SMS, je ne suis plus chez Free :P 

 

Autrement je viens de mettre cette ligne pour test et je reçois ! (mais ma femme j'en sais rien pour le moment) mais elle n'a jamais rien reçue punaise :(

 

   -- TEST TEST TEST TEST Notification Informations Luminosité Séjour et Température envoyées toutes les 60 minutes
   GEA.add({{"Value+", id["LUX1_SEJOUR"],0},{"Value+", id["NetAtmo_temp_int"],0}}, 120*30, "Information - Séjour: #value[1]# Lux et #value[2]# °C", {{"Portable", MobileId["PHONE_NATHALIE"]},{"Portable", MobileId["PHONE_BERNARD"]},{"Repeat"}})
 

C'est vrais que ça me rends dingue, dans les débuts tout allait bien et un jour tout s'est mis à être instable à ce niveau.

Autrement la domotique fonctionne bien ... 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Par exemple cette ligne ne m'envois rien si je passe la variable à "Absent"

 

--- Test
   GEA.add({"Global","PhoneBernie","Absent"}, -1, "Bernard est absent !", {{"Portable", MobileId["PHONE_BERNARD"]}})

Et tous le reste doit être pareil je pense hors mis quelques ligne qui fonctionnent...

 

"PhoneBernie" est déclaré dans l'entête.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Si je ne met pas les sleep en LUA j'en reçois que 1 sur 3 lors de mes tests c'est pour ça que j'ai mis des slips

Ca vient peut etre de ca non ??? Si meme en lua fibaro sans slips :-) tu ne recois pas, gea ne fait qu utiliser le lua fibaro avec une syntaxe propre a GEA, enfin Steven.

Faudrait essayer de te faire un code push propre a toi avec un setTimeout avant ou apres le push pour tester.

Envoyé de mon Nexus 5X en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Pendant longtemps, je n'avais quasiment aucune notification Fibaro qui passait. Suite à d'autre soucis, Fibaro est passé sur ma box et on corrigé pas mal de petit truc. Depuis, plus aucun soucis de notification. Par contre, je ne sais pas ce qu'ils ont fait. Cela peux valoir la peine de soulever ton soucis au support de Fibaro ?

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

ok @Steven merci pour l'info !

Car c'est vraiment très insupportable et le comportement est vraiment douteux.

 

Je vais les contacter, il faut juste se rendre disponible et ça c'est super pénible aussi.

Je ne sais pas s'ils ont une procédure pour se débrouiller tout seul.

Je pense que je vais leur préparer un accès et ouvrir le port ssh et qu'ils essayent de me faire ça.

 

yes !

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est exactement ce que j'avais fait. Courage ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 22 minutes, Domodial a dit :

Je ne sais pas s'ils ont une procédure pour se débrouiller tout seul.

en 4.160 regarde dans configuration, on peut donner un acces maintenant. Jamais testé

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

 

Je viens de leur envoyer un email ainsi qu'un accès 7 jours sur la box, j'ai ouvert le port 22 je ne sais pas si c'est toujours nécessaire.

 

 

  • Like 2

Partager ce message


Lien à poster
Partager sur d’autres sites

×