Aller au contenu

Recommended Posts

n'oublie pas de mettre fibaro:debug(fibaro:getValue(404, "value"));

Partager ce message


Lien à poster
Partager sur d’autres sites

argh !

J'ai ce résultat : [DEBUG] 15:59:34: nil

Ce module doit travailler autrement pour remonter la conso....

Partager ce message


Lien à poster
Partager sur d’autres sites

effectivement, faut que j'investisse dans ce type de module pour y voir clair :) 

Partager ce message


Lien à poster
Partager sur d’autres sites

@domodial, va voir le json de ton 404 stp ;-)

 

http://ipboxhc2/api/devices/404

 

Petit HS : quelqu'un a fait une icone pour le replicator ? Merciiii

Modifié par pepite

Partager ce message


Lien à poster
Partager sur d’autres sites

merci pour ce VD es que quelqu'un aurait des icônes à  partager pour ce super VD  :D

Partager ce message


Lien à poster
Partager sur d’autres sites

ouais j'avais deja été voir, mais je comprends rien à  ce qui s'affiche lol

 

 

@domodial, va voir le json de ton 404 stp ;-)

 

http://ipboxhc2/api/devices/404

 

Petit HS : quelqu'un a fait une icone pour le replicator ? Merciiii

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai fait des retours àla ligne sinon ça tenait tout sur une seule ligne.

Si ça te cause ? car moi pas :D

{"id":404,"name":"LED TV","roomID":1,"type":"com.fibaro.zwaveDevice","baseType":"com.fibaro.device","enabled":false,"visible":false,"isPlugin":false,"parentId":1,"remoteGatewayId":0,"interfaces":
["light","polling","zwave","zwaveAssociation","zwaveConfiguration","zwaveSlaveRouting"],"properties":{"associations":"
[{\"endPointId\":0,\"groups\":[{\"groupInfo\":{\"commands\":[],\"name\":\"\",\"profile\":\"\"},\"id\":1,\"singleChannel\":{\"max\":5,\"set\":[1],\"view\":[1]}},
{\"groupInfo\":{\"commands\":[],\"name\":\"\",\"profile\":\"\"},\"id\":2,\"singleChannel\":{\"max\":5,\"set\":[1],\"view\":[1]}},{\"groupInfo\":{\"commands\":[
],\"name\":\"\",\"profile\":\"\"},\"id\":3,\"singleChannel\":{\"max\":5,\"set\":[1],\"view\":[1]}},{\"groupInfo\":
{\"commands\":[],\"name\":\"\",\"profile\":\"\"},\"id\":4,\"singleChannel\":{\"max\":5,\"set\":[1],\"view\":[1]}},
{\"groupInfo\":{\"commands\":[],\"name\":\"\",\"profile\":\"\"},\"id\":5,\"singleChannel\":{\"max\":1,\"set\":[1],\"view\":
[1]}}]}]","configured":"true","dead":"false","deviceControlType":"51","deviceIcon":"28","deviceSpecificData":"","deviceSpecificIdType":"","emailNotificationID":"0",
"emailNotificationType":"0","endPointId":"0","isLight":"true","liliOffCommand":"","liliOnCommand":"","log":"","logTemp":"","manufacturer":"","markAsDead":"true","model":"",
"nodeId":"119","parameters":[{"id":1,"size":1,"value":255},{"id":6,"size":1,"value":2},{"id":8,"size":1,"value":0},{"id":9,"size":1,"value":1},{"id":10,"size":2,"value":10},
{"id":11,"size":1,"value":67},{"id":12,"size":1,"value":255},{"id":13,"size":1,"value":2},{"id":14,"size":2,"value":17472},{"id":15,"size":1,"value":1},{"id":16,"size":1,"value":1},
{"id":30,"size":1,"value":0},{"id":38,"size":1,"value":10},{"id":39,"size":2,"value":600},{"id":42,"size":1,"value":2},{"id":44,"size":2,"value":30},{"id":45,"size":1,"value":10},
{"id":71,"size":1,"value":1},{"id":73,"size":1,"value":0}],"parametersTemplate":"231","pollingInterval":"0","pollingTimeSec":0,"productInfo":"1,15,9,0,16,0,22,22","pushNotificationID":"0",
"pushNotificationType":"0","remoteGatewayId":"0","saveLogs":"true","smsNotificationID":"0","smsNotificationType":"0","useTemplate":"true","userDescription":"","zwaveCompany":"Fibargroup",
"zwaveInfo":"3,3,52","zwaveVersion":"22,22"},"actions":{"getParameter":1,"poll":0,"reconfigure":0,"setParameter":2},"created":1459245399,"modified":1459245399,"sortOrder":106}

Partager ce message


Lien à poster
Partager sur d’autres sites

ah oui, @domodial, c'est en ligne quand tu n'as pas d'addon sur ton navigateur pour lire le json ;-)

 

C'est encore pas tres lisible hihi

 

Mets un addon, par exemple sur firefox, il s'appelle jsonview

 

Le json te permet de voir les proprietes et les differentes valeurs. Je n'ai pas de RGB, je me demandais comment apparaissait la consommation dans le json.

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Genial !! Merci pepite !

 

(y en a 3 tonnes lol) je peux pas poster ici, en plus le formatage pas terrible.

dans tout ce que je lis dans le Json, il semble qu'il n'y a rien qui fait référence à  de la conso :(

Partager ce message


Lien à poster
Partager sur d’autres sites

c'est peut-etre value ? apres pour reperer, faut jouer avec ton RGB et regarder quelles valeurs changent.

La couleur le prog...

Partager ce message


Lien à poster
Partager sur d’autres sites

Ce que vous cherchez se trouve dans: properties.power
 
Mais le type devrait être com.fibaro.FGRGBW441M pour un RGB et on a ici com.fibaro.zwaveDevice.

Peut être qu'il faudrait lancer un "Soft reconfigure" sur ce device.

Partager ce message


Lien à poster
Partager sur d’autres sites

@Shyrka973

 

Tout d'abord merci pour l'info !

Je viens de regarder, le 404 est la boite en carton caché qui est donc en com.fibaro.zwaveDevice

Si je prends le module 405 (qui est le RGBW par lui même) il est bien en com.fibaro.FGRGBW441M

 

C'est toujours étrange ou pas ?

PS : j'ai fait une configuration douce mais rien ne change.

 

Peut être que le script replicator peut ignorer les boites en carton caché ?

Car au final ce n'est pas réellement le module en lui même ce truc en carton pâte :D

Partager ce message


Lien à poster
Partager sur d’autres sites

ah, j'avais pas compris que le 404 etait ton ID maitre ;-) hihihi

 

mets nous le json du 405 stp ;-) c'est pour ma culture perso lol

 

Exact ton 404 ne doit pas remonter la conso, tu n'as rien derriere le properties.power ?

 

Merci shyrka...faut vraiment que j'n=investisse dans un bandeau

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello l'équipe, 

 

Suis intéressé par ce réplicateur ! ça a l'air génial :60:

 

Question : 

 

Est-ce qu'il est toujours d'actualité ? suis en version 4.56

 

 et est-ce bien la dernière version ?  Presence_Replicator v2.vfib

 

Je demande car je vois que les messages datent de 2016....

 

Merci d'avance

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

×