Aller au contenu

jucom

Membres confirmés
  • Compteur de contenus

    45
  • Inscription

  • Dernière visite

Tout ce qui a été posté par jucom

  1. jucom

    Help - requete HTTPS vers synology

    Bonjour, je cherche de l'aide car je bloque sur quelque chose qui doit être facile mais qui pour moi est très compliqué. J'aimerai envoyer une requete HTTPS depuis la HC3 pour déclencher une action préconfigurée dans surveillance station (synology). En clair la HC3 remonte un mouvement PIR et pousse la requête HTTPS qui déclenche l'action préconfigurée dans surveillance station. le requête est la suivante : https://ADRESSEipSYNOLOGY/webapi/entry.cgi?api=SYNO.SurveillanceStation.ExternalEvent&method="Trigger"&version=1&eventId=1&eventName="This is external event1"&account="{account}"&password="{password}" Dans Firefox, j'ai le bon retour "success" et l'action préconfigurée fonctionne. Comme j'ai vu que l'on pouvait faire ce genre de chose avec net.HTTPClient(), je me suis lancé mais évidement ce n'est pas si simple, du moins pour moi... J'ai créé une scene lua et en déclaration j'ai ; { conditions = { { id = 216, isTrigger = true, operator = "==", property = "value", type = "device", value = true } }, operator = "all" } en action j'ai ; local http = net.HTTPClient() http:request("https://ADRESSEipSYNOLOGY/webapi/entry.cgi?api=SYNO.SurveillanceStation.ExternalEvent&method="Trigger"&version=1&eventId=1&eventName="This is external event1"&account="MONLOGIN"&password="MONPASSWORD"", { success = function(response) if response.status == 200 then fibaro:debug('OK, réponse : '.. response.data) else fibaro:debug("Erreur : status=" .. tostring(response.status)) end end, error = function(err) fibaro:debug("Erreur : " .. err) end, options = { method = 'GET' } }) Selon mes essais j'ai toujours des messages d'erreurs [02.03.2021] [06:31:47] [ERROR] [SCENE99]: (load):3: ')' expected near 'Trigger' [02.03.2021] [06:46:11] [ERROR] [SCENE99]: (load):3: ')' expected near '"&method="' [02.03.2021] [06:47:13] [ERROR] [SCENE99]: (load):3: ')' expected near '"Trigger"' J'ai compris que le problème c'est la requête HTTPS en elle même car elle contient des " un peu partout. Elle n'est pas prise en compte dans son intégralité et du coup le reste de la requête génère des erreurs. Pourriez vous m'aider SVP ? 
  2. jucom

    gestion simple thermostat

    Bonjour, quelqu'un a t'il un retour d’expérience sur le thermostat proposé dans la HC3 ? Je l'ai testé avec une sonde DHT22 sur smart Implant et un double switch. Le but étant de gérer la température d'un aquarium (inertie importante) avec comme consigne 28°. La valeur de température remonte bien et le switch fonctionne. Pourtant le thermostat n'actionne pas automatiquement le switch. Ex : le thermostat est réglé sur 27, la sonde remonte 27.5, le switch est OFF quand la température va tomber à 26°, le switch ne s'active pas. A l'inverse si j'active a ce moment le switch, quand la température va dépasser la consigne, le switch ne va pas réagir ! En revanche si je change manuellement la consigne sur le thermostat, le swicth va bien s'activer ou s’éteindre mais restera dans cet état. J'ai supprimé et refait, Idem. Dans climat, j'ai testé une zone avec la programmation qui va bien mais c'est pareil. J'ai fini par faire 2 règles simples en modes bloc et ca fonctionne sauf que ce n'est pas pratique pour changer la température. Quelqu'un a t'il des infos sur ce thermostat de la HC3 ? Merci,
  3. jucom

    Alarme AJAX

    Slt à tous, je ne sais pas si vu avez vu cette info ; Je n'ai pas trouvé + de données sur le sujet. Peut être déjà des dev en cours pour Fibaro ?
  4. jucom

    Quick App - Synology Surveillance Station

    Slt, en faisant des modif sur le synology, j'ai mis en défaut la quick app sans le vouloir. Du coup à force d'essayer de se connecter, la HC3 s'est retrouvée blacklistée comme c'est le cas a chaque fois qu'il y a une indisponibilité pendant un laps de temps. Afin de corriger ce problème j'ai apporté 1 modifications dans le Synology et ma box a repris normalement la discutions. J'ai déclaré l'IP de ma HC3 comme étant fiable. le résultat : [25.10.2021] [17:46:45] [ERROR] [QA_SURVSTATION_455]: QuickApp:getSID() : Error #407 Max Tries (if auto blocking is set to true). [25.10.2021] [17:47:45] [TRACE] [QA_SURVSTATION_455]: Request new SID [25.10.2021] [17:47:45] [ERROR] [QA_SURVSTATION_455]: QuickApp:getSID() : Error #407 Max Tries (if auto blocking is set to true). [25.10.2021] [17:48:45] [TRACE] [QA_SURVSTATION_455]: Request new SID [25.10.2021] [17:48:46] [DEBUG] [QA_SURVSTATION_455]: Ready [25.10.2021] [17:48:46] [DEBUG] [QA_SURVSTATION_455]: Found 4 cameras Je précise que je suis toujours avec le code modifié pour la version=6 -- Generate new SID -- function QuickApp:getSID(callback) if debug then self:debug(tools:args("QuickApp:getSID")) end self:trace("Request new SID") self:getAPI("/webapi/"..self.pathAuth.."?api=SYNO.API.Auth&method=Login&version=6&account="..self.User.."&passwd="..self.Password.."&session=SurveillanceStation&format=sid", { success = function(response) if debug then self:debug("QuickApp:getSID() : success") A suivre..
  5. jucom

    Quick App - Synology Surveillance Station

    J'ai check les log coté Synology. Les crash semblent correspondre au moment ou les quotas d'enregistrements sont atteints. A ce moment le syno fait une purge des vieux fichiers. Je pense qu'il est indispo pendant ce laps de temps pour répondre correctement aux demandes envoyées par la HC3. Les demandes s'enchainent et la HC3 se retrouve d'abord en insuffisant privilège puis black listée par le syno. (c'est l'état dans lequel ca se termine cote HC3) Apres un reboot ca passe de nouveau. Le screenshot "normal" quand les demandes arrivent normalement (il y en a bcp) Le screenshot "crash" quand les demande n'arrivent plus (juste apres la purge des vieux fichiers vidéos hors quotta) Le screenshot "roboot ok" quand ca repart apres le reboot Il faut que j'arrive a check les log des 2 cotés quand ça va se produire de nouveau
  6. jucom

    Quick App - Synology Surveillance Station

    Ok, j'ai ajouté les notif sur les cameras en cas d'indisponibilité.
  7. jucom

    Quick App - Synology Surveillance Station

    Je vais essayer de check tous les matins et soirs.
  8. jucom

    Quick App - Synology Surveillance Station

    Oui c'est exactement ça. Je voudrai pouvoir sortir des log mais comme l'historique est limité, je n'ai pas le moment où se produit l'événement qui pose problème. Quand je check soit ça fonctionne, soit ça tourne en erreur depuis trop longtemps.
  9. jucom

    Quick App - Synology Surveillance Station

    Bonsoir, y a t'il une façon de recup plusieurs jours de log ? Actuellement je les consulte depuis la console. Merci,
  10. jucom

    Quick App - Synology Surveillance Station

    hello, si j'ai bien suivi et selon les info que j'ai récupéré lors de la conf avec une précédente box ; Pour que la box puisse se log sur le syno, il faut d'abord qu'elle demande et obtienne un SID. Une fois obtenu, elle peut s'identifier. Effectivement quand on reboot le syno, le sid change donc il faut que la box le demande à nouveau pour pouvoir s'identifier. Je vois dans les log que le SID est bien redemandé par la box mais elle n'arrive plus à se connecter pour une insuffisance de privilèges. En changeant le fameux "version=x", sur le moment ca ne fonctionne pas car à force d'essayer le syno la blacklist. A ce moment, quand je reboot le syno la liaison Box / Syno reprend. Je ne sais pas si mon analyse sera utile mais je me demande si il n'y a pas une autre ligne dans le code ou "version=x" serait différent ce qui expliquerai qu'a un certain moment on se retrouve de nouveau avec un insuffisant privilège. La je suis de nouveau en "version=6" sur la section ci-dessous et ça tient depuis hier. -- Generate new SID -- function QuickApp:getSID(callback) if debug then self:debug(tools:args("QuickApp:getSID")) end self:trace("Request new SID") self:getAPI("/webapi/"..self.pathAuth.."?api=SYNO.API.Auth&method=login&version=6&account="..self.User.."&passwd="..self.Password.."&session=SurveillanceStation&format=sid", {
  11. jucom

    Quick App - Synology Surveillance Station

    Hello, manifestement le changement de méthode fonctionne sur le moment mais n'est pas persistant. J'ai testé plusieurs version=6 puis 7 etc.. Au bout d'un certain temps on toujours le meme message d'erreur. 06.10.2021] [13:21:31] [ERROR] [QA_SURVSTATION_455]: QuickApp:getCameras() : Error #105 Insufficient user privilege Il y a quelque chose qui varie avec le temps. -- -- Generate new SID -- function QuickApp:getSID(callback) if debug then self:debug(tools:args("QuickApp:getSID")) end self:trace("Request new SID") self:getAPI("/webapi/"..self.pathAuth.."?api=SYNO.API.Auth&method=login&version=6&account="..self.User.."&passwd="..self.Password.."&session=SurveillanceStation&format=sid", {
  12. jucom

    Quick App - Synology Surveillance Station

    Content d'avoir pu aider.
  13. jucom

    Quick App - Synology Surveillance Station

    Version 6 et reboot ton syno car logiquement au bout d'un nbr de tentatives il Blacklist temporairement.
  14. jucom

    Quick App - Synology Surveillance Station

    et merci beaucoup pour l'info, ne n'aurai pas trouvé ! :-)
  15. jucom

    Quick App - Synology Surveillance Station

    Bonsoir, je viens de pousser le quick app en faisant la modif version 7 ca n'a pas fonctionné pour moi. en revanche avec version 6 ca passe. A suivre.. -- -- Generate new SID -- function QuickApp:getSID(callback) if debug then self:debug(tools:args("QuickApp:getSID")) end self:trace("Request new SID") self:getAPI("/webapi/"..self.pathAuth.."?api=SYNO.API.Auth&method=login&version=6&account="..self.User.."&passwd="..self.Password.."&session=SurveillanceStation&format=sid", { ...
  16. je pense qu'il faut simplement que tu remplaces tes caractères spéciaux par un code hexa dans ta requête http http://192.168.XX.XX/XXXXX/fibaro/sql.php?value= le ? et le = sont à remplacer. correspondances ici https://www.nicolas-hoffmann.net/utilitaires/codes-hexas-ascii-unicode-utf8-caracteres-usuels.php J'ai eu le même problème. Ma requête passait très bien ds un navigateur et sur mon ancienne box. J'ai cherché pendant 3 semaines.
  17. Hello, pour ma part, j'en ai 1 sur 2 qui se sont Maj. Pourtant tous en 5.1 au départ. Le 2 eme passe en échec de maj systématiquement. Quelqu'un a déjà eu ce problème ?
  18. jucom

    réglage jardin

    Hello, si vous avancez sur le sujet ca m'intéresse. Comme vous je suis bloqué avec le panneau d'arrosage HC3 qui est inutilisable. J'ai parcouru tout le forum en vain. Merci,
  19. Merci, je vais regarder ca dès que possible.
  20. Hello, sur HC3 je n'ai pas la possibilité de considérer le IN1 ou IN2 comme des interrupteurs. J'arrive à les faire varier malgré tout de 0 à 10 mais le temps de réaction est très long malgré les réglages de sensibilité à 0.5V (j'ai testé 2v aussi). La seule solution que j'ai trouvé est d'interroger toutes les 5s mais je ne pense pas que ca soit idéal. Les paramètres commencent à 24., il n' y a rien avant. C'est pareil chez vous ?
  21. jucom

    Help - requete HTTPS vers synology

    Oui j'avais commencé a regarder, c'est juste que pour moi c'est une nouvelle fonction à apprendre et je ne sais pas comment l'utiliser. Du coup j'ai fait au plus simple d'abord mais plus long du coup .. Merci encore !
  22. jucom

    Help - requete HTTPS vers synology

    J'ai trouvé !! Laser tu m'a mis sur la voie avec les ". J'ai creusé pour tomber sur ce site faisant référence à Encodage-pourcent https://developer.mozilla.org/fr/docs/Glossary/percent-encoding L'HC3 avec net.HTTPClient() semble ne pas aimer du tout certain caractères spéciaux et je pense que les navigateurs modernes les interprètent tout seul. Apres vu mon niveau je me trompe peut être dans l'analyse. J'ai donc enlevé tous les ? les & et je les ai remplacés. ca donne ca https://ADRESSESYNOLOGY/webapi/entry.cgi%3Fapi=SYNO.SurveillanceStation.ExternalEvent%26method=Trigger%26version=1%26eventId=1%26eventName=This_is_external_event1%26account=LOGIN%26password=PASSWORD au lieu de ca https://ADRESSEDUSYNO/webapi/entry.cgi?api=SYNO.SurveillanceStation.ExternalEvent&method=Trigger&version=1&eventId=1&eventName=This_is_external_event1&account=LOGIN&password=PASSWORD Ca fonctionne enfin ! Un grand merci pour le temps passé !
  23. jucom

    Help - requete HTTPS vers synology

    Effectivement la commande dépouillée des " passe bien dans le navigateur https://ADRESSEDUSYNO/webapi/entry.cgi?api=SYNO.SurveillanceStation.ExternalEvent&method=Trigger&version=1&eventId=1&eventName=This_is_external_event1&account=LOGIN&password=PASSWORD Mais pas via la HC3 qui renvoie toujours [07.03.2021] [18:38:28] [DEBUG] [SCENE99]: OK, réponse : {"error":{"code":101},"success":false} J'ai testé avec ' juste avant et après le requête HTTPS et " aussi mais le résultat est le même. La requête https initial est générée tel quel par surveillance station avec tous ces ". Je l'utilisais dans EEDOMUS et je la teste dans un navigateur.
  24. jucom

    gestion simple thermostat

    Je n'avais pas fait attention non plus et c'est justement ce que j'ai testé et ca ne fonctionne pas. Il y a un thermostat lié à une sonde de Tempé et un actionneur ON/OFF
  25. jucom

    gestion simple thermostat

    très belle bête l'IPX800 !! Mon bac est un 450L et il y a en plus 120L de filtration à décantation (en dessous dans la meuble). Une petite photo en pièce jointe .. Secure SRT 32x, c'est pas mal je ne vois pas de déport de sonde possible pour aller dans l'eau ??
×