Aller au contenu

jucom

Membres confirmés
  • Compteur de contenus

    27
  • Inscription

  • Dernière visite

Réputation sur la communauté

4 Neutral

À propos de jucom

  • Rang
    Nouveau

Profile Information

  • Sexe :
    Homme
  • Ville :
    aubignan
  • Intéret :
    Simplifier la maison
  • Box
    Home Center 2
  • Version
    béta

Visiteurs récents du profil

252 visualisations du profil
  1. Merci, je vais regarder ca dès que possible.
  2. Hello, sur HC3 je n'ai pas la possibilité de considérer le IN1 ou IN2 comme des interrupteurs. J'arrive à les faire varier malgré tout de 0 à 10 mais le temps de réaction est très long malgré les réglages de sensibilité à 0.5V (j'ai testé 2v aussi). La seule solution que j'ai trouvé est d'interroger toutes les 5s mais je ne pense pas que ca soit idéal. Les paramètres commencent à 24., il n' y a rien avant. C'est pareil chez vous ?
  3. jucom

    Help - requete HTTPS vers synology

    Oui j'avais commencé a regarder, c'est juste que pour moi c'est une nouvelle fonction à apprendre et je ne sais pas comment l'utiliser. Du coup j'ai fait au plus simple d'abord mais plus long du coup .. Merci encore !
  4. jucom

    Help - requete HTTPS vers synology

    J'ai trouvé !! Laser tu m'a mis sur la voie avec les ". J'ai creusé pour tomber sur ce site faisant référence à Encodage-pourcent https://developer.mozilla.org/fr/docs/Glossary/percent-encoding L'HC3 avec net.HTTPClient() semble ne pas aimer du tout certain caractères spéciaux et je pense que les navigateurs modernes les interprètent tout seul. Apres vu mon niveau je me trompe peut être dans l'analyse. J'ai donc enlevé tous les ? les & et je les ai remplacés. ca donne ca https://ADRESSESYNOLOGY/webapi/entry.cgi%3Fapi=SYNO.SurveillanceStation.ExternalEvent%26method=Trigger%26version=1%26eventId=1%26eventName=This_is_external_event1%26account=LOGIN%26password=PASSWORD au lieu de ca https://ADRESSEDUSYNO/webapi/entry.cgi?api=SYNO.SurveillanceStation.ExternalEvent&method=Trigger&version=1&eventId=1&eventName=This_is_external_event1&account=LOGIN&password=PASSWORD Ca fonctionne enfin ! Un grand merci pour le temps passé !
  5. jucom

    Help - requete HTTPS vers synology

    Effectivement la commande dépouillée des " passe bien dans le navigateur https://ADRESSEDUSYNO/webapi/entry.cgi?api=SYNO.SurveillanceStation.ExternalEvent&method=Trigger&version=1&eventId=1&eventName=This_is_external_event1&account=LOGIN&password=PASSWORD Mais pas via la HC3 qui renvoie toujours [07.03.2021] [18:38:28] [DEBUG] [SCENE99]: OK, réponse : {"error":{"code":101},"success":false} J'ai testé avec ' juste avant et après le requête HTTPS et " aussi mais le résultat est le même. La requête https initial est générée tel quel par surveillance station avec tous ces ". Je l'utilisais dans EEDOMUS et je la teste dans un navigateur.
  6. jucom

    gestion simple thermostat

    Je n'avais pas fait attention non plus et c'est justement ce que j'ai testé et ca ne fonctionne pas. Il y a un thermostat lié à une sonde de Tempé et un actionneur ON/OFF
  7. jucom

    gestion simple thermostat

    très belle bête l'IPX800 !! Mon bac est un 450L et il y a en plus 120L de filtration à décantation (en dessous dans la meuble). Une petite photo en pièce jointe .. Secure SRT 32x, c'est pas mal je ne vois pas de déport de sonde possible pour aller dans l'eau ??
  8. jucom

    Help - requete HTTPS vers synology

    Bon j'ai bien avancé grâce a tes conseil Lazer et aux échanges que j'ai pu lire sur le forum local http = net.HTTPClient() http:request('https://AdresseSynology/webapi/entry.cgi?api=SYNO.SurveillanceStation.ExternalEvent&method="Trigger"&version=1&eventId=1&eventName="This_is_external_event1"&account="LOGIN"&password="PASSWORD"', { success = function(response) if response.status == 200 then print('OK, réponse : '.. response.data) else print("Erreur : status=" .. tostring(response.status)) end end, error = function(err) print("Erreur : " .. err) end, options = { method = 'GET' } J'ai remplacé fibaro:debug() par print() et ca fonctionne enfin... presque :-) La commande est bien envoyée, mais la HC3 a pour réponse du Synology ; [06.03.2021] [23:53:17] [DEBUG] [SCENE99]: OK, réponse : {"error":{"code":101},"success":false} Cela correspond à un paramètre invalide ce que je ne comprends pas puisque la même commande HTTPS fonctionne quand elle est utilisée seule dans un navigateur. J'ai testé en méthode 'GET' et 'PUT' c'est pareil. Je continu mes recherches...
  9. jucom

    gestion simple thermostat

    Oui c'est pas faux d'ailleurs c'est limite dangereux. J'ai un chauffage de secours en cas de disfonctionnement mais comme tu le dis, si ca plante et que ca chauffe en continus, pour moi en 1H j'ai tout perdu. L'intérêt primordial de la gestion via la box qui est la sensibilité. Je peux enclencher à 27.9° et couper à 28.1 ce qui me permet d'avoir une variation vraiment très faible ce que je recherche. C'est vrai que si demain je peux trouver un thermostat aussi sensible qui prend une consigne via la box .. "J'achète !"
  10. jucom

    gestion simple thermostat

    ok je comprends mieux ! Merci beaucoup pour ces explications. C'est dommage quand mode bloc on ne permette pas comparer la valeur d'un périphérique a un la valeur d'un autre. Ca donnerai accès à plein de possibilités pour des gens comme moi qui ont 0 connaissance avec le code LUA (les autres codes aussi d'ailleurs ;-) )
  11. jucom

    gestion simple thermostat

    Bonjour, quelqu'un a t'il un retour d’expérience sur le thermostat proposé dans la HC3 ? Je l'ai testé avec une sonde DHT22 sur smart Implant et un double switch. Le but étant de gérer la température d'un aquarium (inertie importante) avec comme consigne 28°. La valeur de température remonte bien et le switch fonctionne. Pourtant le thermostat n'actionne pas automatiquement le switch. Ex : le thermostat est réglé sur 27, la sonde remonte 27.5, le switch est OFF quand la température va tomber à 26°, le switch ne s'active pas. A l'inverse si j'active a ce moment le switch, quand la température va dépasser la consigne, le switch ne va pas réagir ! En revanche si je change manuellement la consigne sur le thermostat, le swicth va bien s'activer ou s’éteindre mais restera dans cet état. J'ai supprimé et refait, Idem. Dans climat, j'ai testé une zone avec la programmation qui va bien mais c'est pareil. J'ai fini par faire 2 règles simples en modes bloc et ca fonctionne sauf que ce n'est pas pratique pour changer la température. Quelqu'un a t'il des infos sur ce thermostat de la HC3 ? Merci,
  12. jucom

    Help - requete HTTPS vers synology

    J'ai lu que pcall permettait de détecter plus facilement ou se trouvent les erreurs. le truc c'est que je ne sais pas comment l’implémenter.
  13. jucom

    Tout nouveau, tout neuf !

    Apres avoir mis de coté la HC2 faute de temps, de budget et de périphériques que j'avais déja qui n'étaient pas compatibles, j'ai fini par la revendre et rester temps bien que mal sur l'EEDOMUS. J'ai ensuite revu ma copie en me séparant ou en remplaçant ces modules pour repartir de 0 avec la HC3. Cette fois tous mes modules sont enfin compatibles. J'ai principalement dans la gamme Fibaro détecteurs d'ouvertures modules de volets roulants doubles swtich doubles swtich libres de potentiel Smart implants Hors Fibaro Détecteurs PIR PSP05-D Detecteurs PIR Steinel Mon but étant d'agir dans un premier temps sur la sécurité avec les détections PIR qui actionnent les camera du synology les volets roulants l'éclairage exterieur un module digicode avec badges rfid sur Smart implant l'aquarium, température + éclairage l'arrosage automatique du jardin les notifications et les remontés d'informations qui vont bien Il n'y a plus qu'a, l'adaptation n'est pas évidente mais je devrai y arriver.
  14. jucom

    Help - requete HTTPS vers synology

    j'ai essayé les 3 possibilités en prenant en compte les explications.avec cette version je vois qu'il prend bien la totalité de ma requête local http = net.HTTPClient() http:request('https://IPSYNOLOGY/webapi/entry.cgi?api=SYNO.SurveillanceStation.ExternalEvent&method="Trigger"&version=1&eventId=1&eventName="This_is_external_event1"&account="LOGIN"&password="PASSWORD"', { success = function(response) if response.status == 200 then fibaro:debug('OK, réponse : '.. response.data) else fibaro:debug("Erreur : status=" .. tostring(response.status)) end end, error = function(err) fibaro:debug("Erreur : " .. err) end, options = { method = 'PUT' } }) j'ai une erreur à la fin mais sans precision [02.03.2021] [18:51:33] [ERROR] [SCENE99]: avec les Slashs j'ai ca [02.03.2021] [18:18:00] [ERROR] [SCENE99]: (load):3: unexpected symbol near '<\239>' les .. il veut pas [02.03.2021] [18:23:40] [ERROR] [SCENE99]: (load):2: unfinished string near ''https://ADRESSEipSYNOLOGY/webapi/entry.cgi?api=SYNO.SurveillanceStation.ExternalEvent&method="..Trigger.."&version=1&eventId=1&eventName="..This_is_external_event1.."&account="..LOGIN.."&password="..PASSWORD, {'
  15. jucom

    Help - requete HTTPS vers synology

    Ok, j'ai compris la notion de chaine, quote et antislashs. Je test ca ! Merci Bcp,
×