Aller au contenu
971jmd

net.HTTPClient()

Recommended Posts

Salut a tous

 

je souhaite savoir si sous 4.510 pourquoi le code suivant ne fonctionne plus 

 

http = net.HTTPClient()
http:request("CODE_HTTP", {options = {
method = 'GET'
},
success = function(response) fibaro:debug("OK") end,
error = function(err) fibaro:debug("Error: " ..err) end
})

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Manque un peu d'infos non ? Rassure moi, ce n'est pas ton code tel quel ? Sinon avec "CODE_HTTP" comme cela ca a déjà fonctionné ;-)

C'est ton code dans quel but ?

 

Je viens d'aller voir, suis en 4.510, par exemple le WATCHDOG de @Lazer fait du net.HTTPClient) et pas de soucis.

Partager ce message


Lien à poster
Partager sur d’autres sites

salut Pepite

oui effectivement j'ai pas précisé 

 

l'adresse suivante mes a jours une base SQL  :http://127.0.0.1:8080/fibaro/index3.php?nomdevice=lampe

ça fonctionne tres bien 

 

mai avec fibaro non:

   local http = net.HTTPClient()
http:request("http://127.0.0.1:8080/fibaro/index3.php?nomdevice=lampe", {options = {

method = 'GET'
},
success = function(response) fibaro:debug("OK") end,
error = function(err) fibaro:debug("Error: " ..err) end
})
[DEBUG] 08:17:48: Error: Connection refused
[DEBUG] 08:22:01: Error: Connection refused

 

pour info j'utilise WAMPSERVEUR

 

je pense que c le 127.0.0.1 que ne gère pas fibaro 

 


 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, 971jmd a dit :

http://127.0.0.1:8080

je vias certainement dire ne grosse c..mais pour moi en l'ecrivant comme ceci tu lui demande d'aller sur son propre loopback.

 

Si sur WAMPserver, ton PC a bien une addresse IP non.

 

Essaie avec http://IPLANDUPC:8080/....

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai tester avec :  

local http = net.HTTPClient()
http:request("192.168.0.44:8081/fibaro/index3.php?nomdevice=coco", {options = {

.

.

 

[DEBUG] 11:25:09: OK

 

mai rien ne bouge dans ma base SQL:15:

 

j'ai tester depuis mon iphone en local l'adresse 192.168.0.44:8081/fibaro/index3.php?nomdevice=coco

et rien 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai trouver le problème, le WAP n'étais pas ouvert au réseaux local  

 

j'ai modifier le fichier, httpd.conf  de WAP...

 

    Order Deny,Allow
     Allow from all
     Allow from 127.0.0.1
     Allow from  192.168.0.44
     Allow from ::1
     Allow from localhost
</Directory>

Partager ce message


Lien à poster
Partager sur d’autres sites

Voila, parfait ;-)

 

Well done ;-)

Partager ce message


Lien à poster
Partager sur d’autres sites

×