Aller au contenu
Twentycents

Comment ne pas oublier de déclencher l'alarme ?

Recommended Posts

Hello,

j'ai une petite question... vu que la géolocalisation ne fonctionne pas a pas à merveille. (sujet à creuser)

 

comment activer l'alarme le plus intelligemment possible (ma femme et mon fils par exemple ne vont pas avoir ce réflexe)

 

une idée ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Attention je précise quand même que je parle d'alarme c'est plutôt des capteurs de présence (armer ou désarmer)

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 35 minutes, Twentycents a dit :

une idée ?

Utilise le push interactif. si l'alarme n'est pas activée, tu envoies unnpush qui pose une question qui en fonction de la réponse te  mettra l 'alarme ;-)

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui mais là il faut commencer par écrire un algo pour que la domotique détecte l'absence, et décide par conséquent d'avertir l'utilisateur via le push.

 

Pour cela, il faut combiner plusieurs sources :

- plus aucun mouvement sur les détecteurs depuis X minutes (pour que ça soit fiable, il faut des détecteurs dans un maximum de pièce)

- les appareils mobiles ne sont plus sur le réseau Wi-Fi (détection de présence via Freebox, Unifi, MAC Address, il y a plusieurs tutos sur le forum)

- idem que ci-dessus, mais via Bluetooth

- avec une mesure de consommation sur la TV et l'écran du PC, si tous les écrans sont éteints

- après on peut imaginer regarder l'activité des lumières.... si plus aucune lumière n'est allumée/éteinte depuis 1h, c'est peut être que les habitants sont partis

 

etc.... mais dans tous les cas, évite l'activation automatique de l'alarme, ça évite qu'elle se mette à hurler lorsque tu te relèves du trône si tu as eu le malheur d'y aller avec une BD :D

 

  • Like 1
  • Haha 1
  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Mais LOOOOL

je suis en réunion et j’ai rigolé comme un bouffon lol

 

Le truc de la freebox me plait bien j’ai une question qui va te paraître debile mais j’ai acheté des télécommande Zwave les trucs hyper design. Est-ce que je peux faire un scénario dessus du genre... si tu vois plus la télécommande alors active l’alarme ?

Partager ce message


Lien à poster
Partager sur d’autres sites

:D

 

Les télécommandes, lesquelles ?

La dernière Keyfob de Fibaro ne se réveille pas (pour économiser les piles) => donc impossible de savoir si elle passe en noeud mort, donc impossible de savoir si elle est encore dans les parages ou non.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 8 minutes, Twentycents a dit :

ça va être compliqué alors

non ;-)

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, Twentycents a dit :

Hello,

j'ai une petite question... vu que la géolocalisation ne fonctionne pas a pas à merveille. (sujet à creuser)

 

comment activer l'alarme le plus intelligemment possible (ma femme et mon fils par exemple ne vont pas avoir ce réflexe)

 

une idée ?

 

Il y a 2 heures, Twentycents a dit :

Mince

 

 ça va être compliqué alors lol

une paire de claque en cas d'oubli.

Ils vont vite avoir le réflèxe ...

  • Haha 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, jojo a dit :

 

une paire de claque en cas d'oubli.

Ils vont vite avoir le réflèxe ...

j'voue..... j'aurais du y penser avant :)

Partager ce message


Lien à poster
Partager sur d’autres sites

effectivement la paire de calque pas mal hahahaha !!

la domotique c'est top mais ça déresponsabilise tout le monde je trouve.

 

Personnellement j'ai un voyant discret dehors à la sortie de la maison et j'ai pris l'habitude ''reflexe de pablov" lol pas de lumière = pas d'alarme !

 

 

Modifié par fan-de-securité

Partager ce message


Lien à poster
Partager sur d’autres sites

ce voyant doit rester discret, car il ne faut pas informer les visiteurs non invités qu'il n'y a personne ...

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Moi j'utilise la non détection du tél de ma femme et de moi. Si aucun des 2 n'est là, interactiv push sur le téléphone demandant si c'est normal que l'alarme est éteinte et avec un oui on la met en route automatiquement. Cela demande du coup en même temps si on veut lancer le nettoyage, ce qui envoi le roomba :) En place depuis des lustres, jamais le moindre souci, sauf que le VD unifi plantait. Mais ça c'est ok maintenant, cela fonctionne désormais à 100% avec le watchdog (Avant non car je n'avais pas la bonne version dui watchdog). Donc pour moi, c'est fiable. De toute façon cela n'arme pas en auto, mais pose la question.

Partager ce message


Lien à poster
Partager sur d’autres sites

@Nico c'est exactement ce que je veux faire avec la detection de la freebox et ça fait 2 jours que je suis dessus et ça marche pas 

j'ai l'impression que ma scene ne détecte pas les iphones :(

tu penses pouvoir m'aider un peu ou m'orienter ?

je partage mon code ? 

si ça remarche faudra que je refasse un tuto parce là...snif

Partager ce message


Lien à poster
Partager sur d’autres sites

Regarde le VD de Sebcbien, il est dans sa signature, il fonctionne en interrogeant la table ARP.

Par contre IPhone… Là je ne sais pas trop, je sais qu'à un moment plusieurs avaient des soucis car l'IPhone coupait son wifi en partie.

Partager ce message


Lien à poster
Partager sur d’autres sites

T'as une astuce pour débuggé un script genre voir chacune des actions qu'il effectu ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 12 minutes, Nico a dit :

Regarde le VD de Sebcbien, il est dans sa signature, il fonctionne en interrogeant la table ARP.

Par contre IPhone… Là je ne sais pas trop, je sais qu'à un moment plusieurs avaient des soucis car l'IPhone coupait son wifi en partie.

--[[
%% autostart
%% properties
%% globals
Twentycents
iPhone
--]]

function Check()

	local delay = 60*1000

	local timestamp = os.time()
	local Twentycents = tonumber(fibaro:getGlobalValue("Twentycents"))
	local iPhone  = tonumber(fibaro:getGlobalValue("iPhone"))
	local Presence = fibaro:getGlobalValue("Presence")

	if Twentycents < timestamp - delay and iPhone < timestamp - delay then
		if Presence == "1" then
			fibaro:debug(os.date('%d/%m/%Y').." : Absence détectée")
			fibaro:setGlobal("Presence", "0")
		end
	else
		if Presence == "0" then
			fibaro:debug(os.date('%d/%m/%Y').." : Présence détectée")
			fibaro:setGlobal("Presence", "1")
		end
	end

end

local trigger = fibaro:getSourceTrigger()

if trigger["type"] == "autostart" then
	fibaro:debug(os.date('%d/%m/%Y').." : Autostart infinite loop...")
	while true do
		Check()
		fibaro:sleep(60*1000) -- 1 minute
	end
elseif trigger["type"] == "global" then
	fibaro:debug("Global variable change : "..trigger['name'])
	Check()
elseif trigger["type"] == "other" then
	fibaro:debug(os.date('%d/%m/%Y').." : Started manually")
	Check()
elseif trigger["type"] == "property" then
	fibaro:debug(os.date('%d/%m/%Y').." : Property changed : ".. trigger['deviceID'].." => "..trigger['propertyName'])
else
	fibaro:debug(os.date('%d/%m/%Y').." : Unknown trigger : "..trigger["type"])
end

voilà le résultat que j'ai

 

[DEBUG] 10:59:39: 27/10/2018 : Autostart infinite loop...
[DEBUG] 11:02:13: 27/10/2018 : Started manually
[DEBUG] 11:02:27: 27/10/2018 : Started manually
[DEBUG] 11:04:47: 27/10/2018 : Started manually

Partager ce message


Lien à poster
Partager sur d’autres sites

Je crois que ça fonctionne et je crois aussi savoir pourquoi ça bug aussi....

 

[DEBUG] 15:58:23: 27/10/2018 : Autostart infinite loop...  ------------------ Wifi activé sur mon tel (donc variable Presence = 1)
[DEBUG] 15:58:58: Global variable change : Twentycents------------- Wifi toujours activé (donc variable Presence = 1)
[DEBUG] 16:00:10: Global variable change : Twentycents -------------------- Wifi toujours activé (donc variable Presence = 1) et là je passe en 4G.... et donc la Variable Presence =0 
[DEBUG] 16:01:23: 27/10/2018 : Absence détectée ---- BINGO ça fonctionne....allez je repasse en WIFI
[DEBUG] 16:02:34: Global variable change : Twentycents ---  Bingo again ! 
[DEBUG] 16:02:34: 27/10/2018 : Présence détectée et me revoilà :) 

 

Maintenant pourquoi ça bugait !!!!???

bah Facile ! ....

 

il suffit d'aller dans le menu des variables :  comme ce ci

 

image.thumb.png.ad77f096106d9dcd8df176731027b0a6.png

 

et cliquer tu la petite disquette (oh oui j'aime les disquettes) et ça change des trucs... du genre des trucs quand même importants ( en ROUGE )

 

image.thumb.png.969d13e748db6919fab40e8a27ba1d8d.png

 

et donc là que se passe-t-il ?

mon téléphone est connecté en wifi et je reçois une alerte qui dit que je suis absent... mais bien sur mon gars....

 

mais pourquoi ? que vient-il de se passer......... quel suspens :)

 

bah allez je retourne dans mon VD Freebox et donc un petit run sur le debug...

 

 

[DEBUG] 16:13:13: error_code: invalid_session
[DEBUG] 16:13:13: Benchmark [Main process]: elapsed time: 1.995 cpu secs
[DEBUG] 16:13:13: Benchmark [Total loop process]: elapsed time: 1.995 cpu secs
[DEBUG] 16:13:13: Total memory in use by Lua: 358.66 Kbytes
[DEBUG] 16:13:14: 3.1 - Explicitly request a challenge.
[DEBUG] 16:13:14: Challenge is OmIx5lw92hD4gKo1bjEiye6H78q1H3vn
[DEBUG] 16:13:15: Status: 403
[DEBUG] 16:13:15: Opening Session failled, because Erreur d'authentification de l'application error code: invalid_token
[DEBUG] 16:13:16: uid: a067bcf42b9d034eb5af735cb55b83d5
[DEBUG] 16:16:24: Opening Session failled, because Erreur d'authentification de l'application error code: invalid_token
[DEBUG] 16:16:25: uid: a067bcf42b9d034eb5af735cb55b83d5
[DEBUG] 16:16:25: success: false
[DEBUG] 16:16:25: msg: Vous devez vous connecter pour accéder à cette fonction
[DEBUG] 16:16:25: result.password_salt: aR9vxdkdVQI+MqrZPjTx1tQrYEoBKzKD
[DEBUG] 16:16:25: result.challenge: 5p9VRRRs6Zpo4E+RGQ4wEzq90v4nbm3u
[DEBUG] 16:16:25: error_code: invalid_session

 

et bla bla bla et bla bla bla

En gros, ça marche NICKEL mais ne retourne jamais dans tes variables loooooooool :)

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est un bug connu, il faut faut JAMAIS cliquer sur la disquette dans la panneau de variable (car toutes les variables complexes qui contient des tableaux (avec des accolades, crochets, etc)) sont perdues (NaN).

 

Il faut utiliser le panneau de variable seulement pour créer des variables, et les supprimer, mais jamais pour les modifier.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ahhhh ouais ok lol

merci ! J’avais lu en rouge ne pas cliquer sur la disquette mais je pensais pas après coup lol

j’ai galèré sa mère ah ah

Partager ce message


Lien à poster
Partager sur d’autres sites

si mes souvenirs sont bons, il s'agit d'un VD développé par @Lazer.

Il y a donc un autre principe TRES important qu'il faut savoir avec les solutions proposées par @Lazer : elles fonctionnent au car de poil.

Donc si on n'y arrive pas, c'est qu'on a pas bien lu les explications, qui sont en général TRES claires (même pour moi)

Partager ce message


Lien à poster
Partager sur d’autres sites

pas de fayoooooo qui tienne, c'est la vérité

Partager ce message


Lien à poster
Partager sur d’autres sites

@Twentycents tu débutes, je pense aussi que tu te lances dans des choses trop compliquées pour commencer.

 

Commence par des scénarios simples de lumière, chauffage, etc.


Utilise GEA, qui ne nécessite aucune compétence LUA.


Ensuite dans quelques semaines (mois ?) quand tu seras plus à l'aise et expérimenté, tu pourras attaquer les sujets plus complexes, qui nécessitent de faire un peu de LUA et de faire interagir plusieurs VD et Scènes ensembles.

 

Comment on dit déjà ? "mettre la charrue avant les bœufs"

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

×