Aller au contenu
Lazer

HC3 & HC3L - 5.070.42 - Stable - 18/03/2021

Recommended Posts

semble OK chez moi aussi.

6 min pour faire la mise à jour...

taille des backups sans historiques : 3.4 Mo

Partager ce message


Lien à poster
Partager sur d’autres sites

Mise à jour OK. Pas de soucis constatés.

Partager ce message


Lien à poster
Partager sur d’autres sites

Mise à jour effectuée : tout fonctionne après un redémarrage de la box.

Mais il y a toujours time image.png.18cea42b9f54df87e9dac10716512697.png 

et également des tooltips qui apparaissent au survol différents liens image.png.2d8256993b2f398d88d914477d114b99.png

qui ne veulent pas dire grand chose.

 

Est ce que c'est pareil chez vous ?

 

Bon dimanche à vous...

Partager ce message


Lien à poster
Partager sur d’autres sites

faire un refresh du navigateur (F5) et/ou vide le cache devrait résoudre ton soucis d'affichage.

Partager ce message


Lien à poster
Partager sur d’autres sites

CTRL+F5 plutôt, le F5 n'est pas suffisant.

 

Règle de base après une mise à jour :D

 

 

Mais du coup, je n'avais pas fait attention, mais le bug "il y a {{time}}" a enfin disparu, à la place il n'y a ... Plus rien :blink:

image.png.fc37790eb907484efeb8628428200abc.png

 

En fait ça ressemble à une erreur de traduction : en anglais le "ago" se met bien après la durée, mais en français le "il y a" doit venir devant.

Courage Fibaro, dans 2 ou 3 firmwares vous arriverez enfin à faire un string.format() correct :13:

  • Like 3

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est parce que la traduction est assurée par Yoda

Envoyé de mon RMX1993 en utilisant Tapatalk

  • Thanks 1
  • Haha 3

Partager ce message


Lien à poster
Partager sur d’autres sites

Aie quel boulet

 

Merci beaucoup pour ce Ctrl+F5 de Mes DONNEES Personnelles.

 

Bon dimanche à vous

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut les gars. Vous saviez que le moteur zwave allait être réécrit ? Parait en Q2/Q3.

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Aux dernières rumeurs, c'était prévu pour la prochaine version.

Vu qu'ils ont mis 5 mois à sortir cette version stable.... donc Q2/Q3 est réaliste, mais de quelle année ? Espérons 2021 !

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai lu je sais plus où que fibaro disait d'attendre si on voulait acheter une HC3 que le nouveau moteur soit sorti. J'espère que ça veut pas dire qu'ils sont inquiets sur la migration :(

Partager ce message


Lien à poster
Partager sur d’autres sites

Fibaro qui dit d'attendre ? Pas sûr de la pertinence commerciale.

J'ai jamais vu ça en tout cas.

 

En revanche tu as raison, ça promet encore un grand stress cette migration.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

 

Ils vont sortir une HC4 prématurément pour que cela fonctionne ... :)

 

Voilà ... :D

  • Haha 2

Partager ce message


Lien à poster
Partager sur d’autres sites

Drôle de comportement de mon HC3 hier, elle fonctionnait très bien (réactive et tout), mais le graph CPU montre une charge à 27% pendant plusieurs heures :

 

image.png.f912cfa76cd1374428b7d5f809b870e6.png

 

 

Ça correspond à 1/4 de le capacité CPU, et sachant qu'il y a 4 cœurs dans le processeur, je vais donc voir le détail par cœur, et c'est bien 1 seul cœur saturé à 100%, mais à tour de rôle :

 

image.png.68056b24b9c974e2df1092c91b4a2923.png

 

 

Au final c'est un reboot qui a solutionné le problème.

 

Donc c'était certainement un processus au niveau de l'OS (Linux) qui était parti dans une boucle infinie, mais lequel ?

A priori tous mes QuickApps fonctionnaient bien, et mes quelques 9 modules 2-Wave avaient l'air de communiquer correctement.

 

Étrange....

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui c'est évidement curieux ça m'est arrivé sur les essais de test du net.HTTPClient()

Ou sur des tests avec de settimeout qui ne termine pas ou mal lorsqu'ils sont en cours et que je modifie le lua ( avant la fin du timer j'ai un doute )

 

Ton graphique me conduit à deux questions

Comment obtient on le Graphique avec les coeurs séparés ( Version spéciale que tu a  fait pour étudier le pb ? )

Et sur mes  graphiques ALL et 24h00  pourquoi un maxi a 24,5 % ( c'est une vielle valeur haute qui traine ? dans la BD ? ) 

 

 

 

845989068_Capturedecran2021-04-07a14_50_49.thumb.png.75469b6e898fe8397db430208d88666e.png674586160_Capturedecran2021-04-07a14_59_38.thumb.png.6a6972e52098df359e358fba1adb4822.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Ce qui est curieux c'est que ça s'est produit à un moment où je n'utilisais pas la box, c'est à dire que je n'étais pas connecté dessus, en train de développer, etc.

 

Et j'ai bien regardé les logs de mes QuickApps, ils avaient l'air de tous fonctionner correctement.

 

 

Les informations d'utilisation de chaque cœur sont déjà mémorisées dans la base de données par DomoCharts.

Ce qui est nouveau, c'est le graphique personnalisé pour l'afficher. Mais c'est un truc bricolé à l'arrache, je ne sais pas si c'est vraiment partageable, je pense qu'il sera préférable d'afficher ça proprement dans Grafana... quand je me remettrai dessus (donc pas tout de suite)

 

Le calcul du maxi peut effectivement être plus ancien, le graphique n'affiche que 7 jours par défaut, mais les données sont conservées un peu plus longtemps. Tout cela est paramétrable dans config.inc.php.

  • Thanks 1

Partager ce message


Lien à poster
Partager sur d’autres sites

ça ressemble au freeze dont on parle depuis plusieurs semaines non ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Ben je sais pas, j'ai pas eu de freeze moi, comme dit, un coeur a été saturé pendant plusieurs heures mais la box fonctionnait normalement.

  • Confused 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@ Lazer Je pense aussi avoir eu comme toi 

 

Vers 23 je suis sorti, les lumières ne s'allume pas, l'ouverture de portail n'est pas signalé ... 

Les voyants sur la hc2 étaient normaux. Mais aucune réactions aux commande zwave.

J'ai lancé un reboot qui m'a semblé trop long. Clignotement de la diode la plus a gauche. Par les boutons arrière j'ai déclenché une restauration ( la dernière sauvegarde avait à peine 3 heures.)

Je n'ai pas eut sur le coup le reflexe d'aller voir les graphes CPU.

Mais j'ai pensé tout tout à l'heure dallez voir Domocharts

400117211_Capturedecran2021-04-16a16_06_39.png.0cfeba1c635c7b7ec92bbf8993f5b0b5.png

 

Ca pourrait bien ressembler à un blocage d'un coeur ...

Dans cet espace, la box n'avait pas grand chose à traiter mais ...

 

Pour la RAM il y a un gros pic à ce moment là 

 

 

440645845_Capturedecran2021-04-16a16_22_24.thumb.png.8d3b479bed18394983b1d59f27e37345.png

 

 

On peut observer aussi une perte de RAM Depuis hier 18:50 ( Restart des services après backup)

comme je m'envoi un mail toutes les heures, je constate que le cache reste à 30% et le dispo passe de 24 à 19 donc l'utilisé croit régulièrement

On observe après des paliers stables une augmentation à vers 4H00 et vers 13H00 je ne trouve pas de truc particulier dans Histo et Trace

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Cela ressemble effectivement à un cœur saturé, mais dans mon cas, la box fonctionnait parfaitement.

 

Lors du prochain plantage (j'espère pas, mais bon...) il serait intéressant de relever le résultat de :

/api/service/servicesStatus

Exemple sur un système sain, tous les services sont Ok / true :

{
	"HCServer": {
		"running": true,
		"status": "Ok",
		"devicesStatus": {
			"disconnected": 0,
			"directRoute": 5,
			"indirectRoute": 2,
			"unknownRoute": 1,
			"batteryEmpty": 0,
			"batteryLow": 1,
			"batteryMedium": 0,
			"batteryHigh": 1
		}
	},
	"Zwave": {
		"running": true,
		"status": "Ok"
	},
	"FibaroServices": {
		"running": true,
		"status": "Ok"
	},
	"RemoteAccess": {
		"running": true,
		"status": "Ok"
	}
}

Je n'ai pas eu de plantage de mon HC3, donc je peux pas encore développer de watchdog, mais c'est la technique que j'utilise sur HC2 pour la redémarrer en cas de crash (ce watchdog tourne sur le NAS)

 

 

 

L'augmentation de la mémoire Cache au moment du backup c'est normal, c'est le fichier backup qui est mis en mémoire cache et conservé tant qu'il y a de la place. C'est le principe même du cache, un OS (quel qu’il soit, Linux, Windows, etc.... va toujours chercher à remplir la mémoire au maximum avec du cache... .c'est la façon de le montrer qui diffère)

Pour rappel le fichier backup c'est un dump de la DB, des icônes, etc... le tout zippé dans un fichier chiffré.

 

C'est bien pour cette raison que la vraie mémoire libre (au sens : disponible pour les applications), c'est la somme de Free + Cache.

 

Le Buffer lui est toujours à peu près constant (et à une valeur très faible)

 

On voit bien la génération du fichier backup sur mon graph, le 10 avril à 3h :

image.thumb.png.373f43b34a0bab6d34ef77aecec3dd9a.png

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Quelqu'un à t'il déjà pu deziper le tar download issu de  : (IP My BOX)/api/service/logsDump   ??

Modifié par henri-allauch

Partager ce message


Lien à poster
Partager sur d’autres sites

Il est chiffré pour des raisons de sécurité (comme les backups)

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

×