Aller au contenu

Recommended Posts

Je vous ai proposé il y a peu un monitoring de votre Synology depuis la HC2 (http://www.domotique-fibaro.fr/index.php/topic/5682-synology-monitoring/)

 

Je vous propose maintenant le contraire : monitorer votre HC2 depuis votre Synology.

L'idée vient du fait que mon HC2 fonctionnait très bien, mais qu'il y avait un problème au câble réseau ...

 

Pour le ping, un tout grand merci à  Lazer, sans qui je n'y serais jamais arrivé.

Pour la notification si la box est en erreur 503, merci à  CaptainIgloo et samhuin pour cette partie de script.

 

Pour la notification par mail depuis le synology, voici où je me suis inspiré : http://forum.synology.com/enu/viewtopic.php?f=32&t=79334

 

Fonctionnalités

 

  • Ping de la box HC2/L depuis le Synology
  • Vérification si pas de code erreur 503
  • Si erreur notification dans le Syno et envoie d'un mail

 

Le script :

IP=192.168.xxx.xxx
TO="adresse.mail@a.notifier"
HOST=$(/bin/hostname)
/bin/ping -c 1 -w 10 ${IP}
if [ $? -ne 0 ]
then
SUBJECT="HC2/L Ping error"
BODY="La box HC2/L (${IP}) ne ping plus (test toutes les minutes).\n\nSynology DiskStation\n\nFrom ${HOST}"
HEADERS="From: ${TO}"
NOTIF="${SUBJECT} - ${IP}"
/usr/bin/php -r "mail(\"${TO}\", \"${SUBJECT}\", \"${BODY}\", \"${HEADERS}\");"
/usr/syno/bin/synodsmnotify "@administrators" "System Event" "${NOTIF}"
fi

URL="http://$IP/api/loginStatus"
coderetour=`curl -I $URL 2>/dev/null | head -n 1 | cut -d' ' -f2`
if [ "$coderetour" == "503" ]
then
echo "Code retour 503"
SUBJECT="HC2/L 503 error"
BODY="La box HC2/L (${IP}) retourne un code erreur 503. Evaluer si un redémarrage de la box est nécessaire.\n\nSynology DiskStation\n\nFrom ${HOST}"
HEADERS="From: ${TO}"
NOTIF="${SUBJECT} - ${IP}"
/usr/bin/php -r "mail(\"${TO}\", \"${SUBJECT}\", \"${BODY}\", \"${HEADERS}\");"
/usr/syno/bin/synodsmnotify "@administrators" "System Event" "${NOTIF}"
# curl http://$IPHC/services/finishUpgradeAfterError.php
else
echo "Le code retour est " $coderetour
fi

Configuration du Synology :

Si ce n'est pas fait, il faut configurer le Syno pour qu'il puisse envoyer des mails :

Panneau de configuration -> Notifications

post-1320-0-41502500-1442945590_thumb.jpg

 

Panneau de configuration -> Planificateur de tâches

Créer -> Script défini par l'utilisateur

post-1320-0-71029300-1442520252_thumb.png

 

Dans le champ "Script défini par l'utilisateur", coller le script ci-dessus (en mettant l'IP de la box et votre adresse mail dans les champ IP et TO

 Le champ "Utilisateur" doit être root (sinon le ping retourne une erreur, même si ping ok)

post-1320-0-09140400-1442520268_thumb.png

 

Dans l'onglet" Programmer", planifier la fréquence d'exécution du script

post-1320-0-49031700-1442520285_thumb.png

 Préciser l'heure de dernière exécution à  23:59, car par défaut c'est 00:59.

Pour vérifier que tout fonctionne bien, mettez une adresse IP non existante.

 

Bonus :

Dans le même ordre d'idée, j'ai fait un petit scrip "Keep Alive", pour vérifier une fois par jour que les mails, etc s'envoient correctement depuis mon Syno. Comme l'IP que je renseigne est celle du Syno, s'il m'envoie un mail comme quoi le Syno ne ping plus, c'est qui il a un autre problème.

IP=192.168.xxx.xxx
TO="adresse.mail@a.notifier"
HOST=$(/bin/hostname)
/bin/ping -c 1 -w 1 ${IP}
if [ $? -ne 0 ]
then
	SUBJECT="Keep alive error from  ${HOST}"
	BODY="${IP} ne ping plus"
	HEADERS="From: ${TO}"
	/usr/bin/php -r "mail(\"${TO}\", \"${SUBJECT}\", \"${BODY}\", \"${HEADERS}\");"
	/usr/syno/bin/synodsmnotify "@administrators" "System Event" "${BODY}"
else
	SUBJECT="Keep alive from  ${HOST} ok"
	BODY="${IP} ping ok"
	HEADERS="From: ${TO}"
	/usr/bin/php -r "mail(\"${TO}\", \"${SUBJECT}\", \"${BODY}\", \"${HEADERS}\");"
	/usr/syno/bin/synodsmnotify "@administrators" "System Event" "${BODY}"
fi

  • Upvote 4

Partager ce message


Lien à poster
Partager sur d’autres sites

Super boulot @jojo,

 

Bon j'ai pas de syno mais super boulot tout de même !! merciiii

Partager ce message


Lien à poster
Partager sur d’autres sites

ce script doit pouvoir fonctionner depuis n'importe quelle plateforme Linux, donc depuis un raspery, ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

J'ai appliqué exactement la procédure décrite, et je n'ai aucun résultat

Même en changeant l'adresse IP je n'ai pas de réception de mail, ni events dans les logs systemes de mon syno

Je ne vois pas comment investiguer??

Un peu d'aide?

merci

Partager ce message


Lien à poster
Partager sur d’autres sites

est-ce que ton Syno t'envoie déjàdes mails (pour backup, etc) ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai modifié le premier topic pour expliquer la configuration du Syno pour qu'il sache envoyer des mails

Partager ce message


Lien à poster
Partager sur d’autres sites

est-ce que ton Syno t'envoie déjàdes mails (pour backup, etc) ?

oui oui

le syno m'envoie déjàdes mails

j'ai même refait un test d'envoi de mail via la fonction 'test'

donc je ne comprends pas.

Envoyé de mon A0001 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

et avec le script que j'ai mis dans le "bonus", ça ne fonctionne pas non plus ?

Pour tester, tu peux essayer en sélectionnant le script et faire exécuter (il lui faudra peut-être 10-20 sec)

Car en effet c'est très bizarre que tu as ni mail, ni notif, c'est comme si le script ne s'exécutait pas

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut

Alors je ne sais pas l'expliquer, mais maintenant cela fonctionne.

Lorsque je modifie l'@ip et que je mets une IP erronée je reçois maintenant un mail, cool.

 

Je pense qu'il a fallut un certain temps au Syno pour qu'il prenne en compte les scripts.

 

Encore une fois merci pour ces scripts.

Partager ce message


Lien à poster
Partager sur d’autres sites

c'est pour cela que j'ai également programmé un script keep alive tous les jours à00h00, pour vérifier que mon syno sait bien envoyer des mails.

Partager ce message


Lien à poster
Partager sur d’autres sites

merci jojo pour ce tuto quand je fait un debogue j'ai une erreur je comprend pas pourquoi c'est juste l'IP de la box qu'il faut mettre ?

[ERROR] 22:30:34: line 2: malformed number near '192.168.xxx.xxx'

Partager ce message


Lien à poster
Partager sur d’autres sites

oui, mais làtu me montre un debug LUA / de ta HC2.

Ce script n'est PAS àinstaller sur la HC2, mais sur ton Synology

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour tous,

J'ai ajouté (en fait, c'est captainIgloo qui l'a modifié, je ne suis que son secrétaire :P ) dans le script une détection si erreur 503. Voir 1er topic

Partager ce message


Lien à poster
Partager sur d’autres sites

:2: je l'a mis sur les deux , je le retire de la HC2 ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Aujourd'hui un petit message de mon Synology pour me dire un 503 de mon HC2 dommage que sa reboot pas tout seul sa serai le top

Partager ce message


Lien à poster
Partager sur d’autres sites

cool, donc tu avais bien un 503, qui a été vu ?

Super, car je n'avais pas pu tester le script en situation réelle.

 

Dans le mail que tu as reçu, as-tu le bon lien pour faire le reboot ?

 

J'ai VOLONTAIREMENT supprimé la possibilité de faire un reboot automatique, car imagine que tu es en plein processus d'upgrade, ou de backup, ou de restore, ... (des situations où une erreur 503 n'est pas une vrai erreur => redémarrage => catastrophe.

Partager ce message


Lien à poster
Partager sur d’autres sites

Non il y avait pas de lien pour le reboot

La box HC2/L (192.168.xxx.xxx) ne ping plus (test toutes les minutes).

Synology DiskStation

From DiskStation

Partager ce message


Lien à poster
Partager sur d’autres sites

très bisarre !

car ce mail, c'est si le câble de la HC2, ou ... est mort.

mais si erreur 503, le ping fonctionne, et tu as un autre mail.

 

As-tu essayé de te connecter sur la box après le mail ? Que s'affichait-il ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je venais juste de rentré chez moi ,impossible de se connecter j'ai donc dû appuyer sur le bouton de la Box pour le rebooter

Partager ce message


Lien à poster
Partager sur d’autres sites

donc, c'était une erreur de ping, pas de 503, car sinon tu pourrais te connecter àl'interface, et elle t'afficherait un grand 503 au lieu de te demander tes credentials

Partager ce message


Lien à poster
Partager sur d’autres sites

J'étais avec un tel Samsung j'avais pas de mac sous la main

Partager ce message


Lien à poster
Partager sur d’autres sites

Script installé tout fonctionne (sauf 503 pas pu testé)

merci jojo

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai modifié le post 1 pour inclure les modifications du script proposées par samhuin pour détecter l'erreur 503

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai copié le script à  suivre voir si c'est mieux  :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Euh en place pour moi, par contre je ne pige pas, il m'envoi le mail toutes les minutes, il n'est pas censé envoyer que quand il y a une coupure ?

 

Car là  ça pourrie un peu la boite mail :)

 

EDIT : Lol, je me suis trompé de script, j'ai mis le keep alive :) :)

Partager ce message


Lien à poster
Partager sur d’autres sites

×