Aller au contenu
Lazer

Sauvegarde HC3 automatique sur NAS Synology

Recommended Posts

Bonsoir,

 

Superbe travail et surtout très bonne idée mais j'ai une question '' Est ce que cela jouerait sur un NAS Qnap ? '' ou il faudrait faire un nouveau script complet ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est un script Shell, donc il peut s'exécuter sur n'importe quel UNIX/Linux.

Mais par contre, il faudra l'adapter, en particulier toutes les instructions spécifiques aux Synology (notification et email), je n'ai absolument aucune idée de leur équivalent sur QNAP.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 02/08/2020 à 18:10, Lazer a dit :

Mais oui, il faut demander au support.

Réponse du support : faire une tentative de réparation(option Repair du mode recovery)

 

selon la doc : 

Repairing system

This feature allows you to restore the operating system to the latest version or version from a file without deleting any user data. Only the system will be refreshed.
Depending on how you have entered the Recovery Mode, different system will be available for repairing: inactive when entered via configuration interface or active when entered using  button. Switch system to repair the other one.

  1. Enter the Recovery Mode.
  2. Click Repair System A/B.
  3. Choose if you want to restore Latest version or use Local file.
  4. Confirm.

Je me demande si c'est une bonne idée... :unsure:

Modifié par jjacques68

Partager ce message


Lien à poster
Partager sur d’autres sites

@Lazer D'accord merci pour l'info et à l'occasion je vais essayé et tiendrais au courant ici mon résultat :D

Partager ce message


Lien à poster
Partager sur d’autres sites

hmmm mon histoire se complique dangereusement...

 

visiblement si on veut utiliser les fichier de backup sauvegarder en local, l'extention ne doit pas être .fbi mais .7z !

 

alors suffit-il de le compresser avec 7-Zip ? - pas trouver de réponses null part...

 

Pour le moment je suis dans une grosse galère avec leur connerie de "repair". Box plantée...

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est embêtant.... je n'ai jamais testé la restauration... c'est pas bien...

Faut que je fasse le test à l'occasion

Partager ce message


Lien à poster
Partager sur d’autres sites

tu as vu les messages que tu as déplacé, le compressé en .7z semble fonctionné malgré l'erreur d'image corrompue...

c'est vraiment louche ce truc...

Partager ce message


Lien à poster
Partager sur d’autres sites

hello

 

j'ai une petite question.....  script installé sur NAS, connecter vers HC3 ok, mais ensuite je reçois le message suivante : impossible de lire la sauvegarde globale 'BACKUP'... code de retour HTTP 404

mais sur la HC3 j'ai bien une variable globale qui s'appelle BACKUP...  

 

donc je ne vois pas d'ou vient le problème.....  une idée ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu es bien certain de l'orthographe du nom de ta variable globale ?

Il fait la différence entre les majuscules et les minuscules, il faut que le nom soit rigoureusement identique.

Tu peux tester la réponse de l'API directement comme ceci :

 

http://<IP>/api/globalVariables/BACKUP

 

Partager ce message


Lien à poster
Partager sur d’autres sites

ah ben non, en fait c'était une erreur dans l'adresse IP :-) 

mea culpa

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @Lazer, je relance le sujet... J'ai (maintenant) (aussi) un script qui s'occupe de la backup automatique de la HC3 (dans le Cloud), mais après overture d'un ticket chez Fibaro, ils me confirment que, lorsque le quota de 50MB est dépassé, il n'y a pas de "nettoyage" automatique des anciennes backups... 

 

Du coup je me demande si ton script gère cette problématique, ou si tu fais autrement (en local ? Mais le principe doit être le même ?). 

 

Merci pour tes lumières :) 

Partager ce message


Lien à poster
Partager sur d’autres sites

(Je déplace ton message qui était posté sur un mauvais topic)

 

Mon script ne gère pas la purge automatique des anciens backups, car je stocke en local et n'ai pas de problème de place.

Mais c'est quelque chose qu'il faudrait que j'ajoute dans le futur, ça permettrait comme toi de faire des backups automatisés dans le cloud. Sans cela, comme tu l'as constaté on arrive vite à saturation de l'espace disponible.

 

Un jour peut être....

Partager ce message


Lien à poster
Partager sur d’autres sites

Depuis la dernière mise à jour, j'ai la taille des backup qui augmentent de jour en jour.

Maintenant je suis à 18 Mo.

Et ce matin visiblement, la backup auto n'a pas fonctionné :

Citation

Cher utilisateur,

Le planificateur de tâches à terminé une tâche planifiée.

Tâche : Backup HC3
Heure de début : Sun, 25 Oct 2020 02:00:03 GMT
Heure d’arrêt : Sun, 25 Oct 2020 02:10:25 GMT
État actuel : 11 (Interrompu)
Sortie standard/erreur :

Backup Fibaro Home Center : Sunday 25/10/2020 02:00:03
Vérification de la valeur de la variable globale 'Backup_Auto'...
Variable globale 'Backup_Auto' = '1' identique à '1' => Sauvegarde
Sauvegarde...
..................................................................................................................................................................................................................................................................................................................................................................................................................................................
Erreur : services Fibaro non redémarrés après le timeout de 600 secondes
Reboot forcé du Home Center...
Erreur : impossible de forcer le reboot de la box Fibaro : code de retour HTTP 500

 

ça veut dire qu'il a mis plus de 10 minutes à faire le backup ?? c'est insensé non ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Effectivement... Mais au final elle a redémarré toute seule ? Le backup a quand même été fait ?

Si ce n'est que ça, il faudra augmenter le timeout.

Partager ce message


Lien à poster
Partager sur d’autres sites

alors le backup s'est fait. je le vois dans la page backup.

mais le téléchargement ne s'est pas fait.

Et visiblement elle a rebooté.

 

hmmm, il me semble déjà avoir augmenté le timeout... 10 min c'est long !!

Partager ce message


Lien à poster
Partager sur d’autres sites

en effet, super long

tu peux faire un backup manuellement pour chronométrer.... soit c'est vraiment long, soit y'a un autre souci

Partager ce message


Lien à poster
Partager sur d’autres sites

alors je mets un tout petit peu moins de 10 minutes pour faire un backup.

Je pense être borderline avec le timeout actuel de 600 secondes.

 

Je le monte à 15 min, mais ce n'est que partie remise...

 

Faudrait trouver pourquoi la taille prend en moyenne 1 Mo par jour...

Peut-être trouver le moyen de purger qqch ?? :15:

Partager ce message


Lien à poster
Partager sur d’autres sites

×