Aller au contenu

Peter

Membres confirmés
  • Compteur de contenus

    586
  • Inscription

  • Dernière visite

Réputation sur la communauté

66 Excellent

À propos de Peter

  • Rang
    Membre accro
  • Date de naissance 08/12/1971

Profile Information

  • Sexe :
    Homme
  • Ville :
    La rochelle
  • Box
    Home Center 2
  • Version
    4.540

Visiteurs récents du profil

1 800 visualisations du profil
  1. Peter

    Esp-easy

    trop fort cela fonctionne encore un grand merci a toi il faut vraiment que je mi mette au Lua être bloqué comme cela C'est chiant en tout cas voici le debug une fois la modification faite [DEBUG] 14:41:48: { "TaskValues": [ {"ValueNumber":1, "Name":"Temperature", "NrDecimals":2, "Value":22.00 }, {"ValueNumber":2, "Name":"Humidity", "NrDecimals":2, "Value":68.00 }], "TTL":2000, "DataAcquisition": [ {"Controller":1, "IDX":1, "Enabled":"true" }, {"Controller":2, "IDX":0, "Enabled":"false" }, {"Controller":3, "IDX":0, "Enabled":"false" }], "TaskInterval":2, "Type":"Environment - DHT11/12/22 SONOFF2301/7021", "TaskName":"temp-Humidite", "TaskEnabled":"true", "TaskNumber":1 } [DEBUG] 14:41:48: {"Value":22,"NrDecimals":2,"Name":"Temperature","ValueNumber":1} [DEBUG] 14:41:48: {"Value":68,"NrDecimals":2,"Name":"Humidity","ValueNumber":2} [DEBUG] 14:41:48: temp=22, hum=68
  2. Peter

    Esp-easy

    @Barelle merci pour ton aide mais il y a une erreur le debug donne cela [DEBUG] 14:16:23: { "TaskValues": [ {"ValueNumber":1, "Name":"Temperature", "NrDecimals":2, "Value":21.00 }, {"ValueNumber":2, "Name":"Humidity", "NrDecimals":2, "Value":65.00 }], "TTL":2000, "DataAcquisition": [ {"Controller":1, "IDX":1, "Enabled":"true" }, {"Controller":2, "IDX":0, "Enabled":"false" }, {"Controller":3, "IDX":0, "Enabled":"false" }], "TaskInterval":2, "Type":"Environment - DHT11/12/22 SONOFF2301/7021", "TaskName":"temp-Humidite", "TaskEnabled":"true", "TaskNumber":1 } [DEBUG] 14:16:23: error
  3. Peter

    Esp-easy

    Hello @Barelle je viens de tester sans la table et j'ai une erreur mais comme je suis null voir plus que null en Lua je comprend pas je te met le degub si tu peux m'aider a comprendre [DEBUG] 12:34:51: { "TaskValues": [ {"ValueNumber":1, "Name":"Temperature", "NrDecimals":2, "Value":24.00 }, {"ValueNumber":2, "Name":"Humidity", "NrDecimals":2, "Value":58.00 }], "TTL":2000, "DataAcquisition": [ {"Controller":1, "IDX":1, "Enabled":"true" }, {"Controller":2, "IDX":0, "Enabled":"false" }, {"Controller":3, "IDX":0, "Enabled":"false" }], "TaskInterval":2, "Type":"Environment - DHT11/12/22 SONOFF2301/7021", "TaskName":"temp-Humidite", "TaskEnabled":"true", "TaskNumber":1 } [DEBUG] 12:34:51: 200 [ERROR] 12:34:51: line 25: attempt to index global 'jsonTable' (a userdata value)
  4. Peter

    Esp-easy

    Bonsoir a tous Merci encore a @barelle pour sont code mais il y a un souci les valeur ne se mette pas a jour la valeur reste toujours a celle de la table json jsonTable = '{ "TaskValues": [ {"ValueNumber":1, "Name":"Temperature", "NrDecimals":2, "Value":27.00 }, {"ValueNumber":2, "Name":"Humidity", "NrDecimals":2, "Value":64.00 }], "TTL":2000, "DataAcquisition": [ {"Controller":1, "IDX":1, "Enabled":"true" }, {"Controller":2, "IDX":0, "Enabled":"false" }, {"Controller":3, "IDX":0, "Enabled":"false" }], "TaskInterval":2, "Type":"Environment - DHT11/12/22 SONOFF2301/7021", "TaskName":"temp-Humidite", "TaskEnabled":"true", "TaskNumber":1 }' et la deuxieme partie du code de @Barelle me sort une erreure voici le code que j'utilise local thisdevice = fibaro:getSelfId() local taskId = "1" local conn = Net.FHttp(fibaro:getValue(thisdevice, 'IPAddress'), fibaro:getValue(thisdevice, 'TCPPort')) -- connection espeasy/port response, status, errorCode = conn:GET('/json?tasknr=' .. taskId) fibaro:debug(response) fibaro:sleep(1) if errorCode == 0 then fibaro:debug(status) jsonTable = json.encode(jsonTable); --encodage de la table json espeasy jsonTable = '{ "TaskValues": [ {"ValueNumber":1, "Name":"Temperature", "NrDecimals":2, "Value":22.00 }, {"ValueNumber":2, "Name":"Humidity", "NrDecimals":2, "Value":59.00 }], "TTL":2000, "DataAcquisition": [ {"Controller":1, "IDX":1, "Enabled":"true" }, {"Controller":2, "IDX":0, "Enabled":"false" }, {"Controller":3, "IDX":0, "Enabled":"false" }], "TaskInterval":2, "Type":"Environment - DHT11/12/22 SONOFF2301/7021", "TaskName":"temp-Humidite", "TaskEnabled":"true", "TaskNumber":1 }' jsonTable = json.decode(jsonTable); -- decodage de la table json espeasy local temp = jsonTable.TaskValues[1].Value; -- enregistrment dans variable temp local hum = jsonTable.TaskValues[2].Value; -- enregistrment dans variable hum fibaro:debug("temp="..temp..", hum="..hum); fibaro:call(thisdevice, "setProperty", "ui.Label1.value", temp .."°") -- affichage du resultat dans le label 1 fibaro:call(thisdevice, "setProperty", "ui.Label2.value", hum .."%") -- affichage du resultat dans le label 2 else fibaro:debug("error") fibaro:call(thisdevice, "setProperty", "ui.Label1.value", "error") fibaro:call(thisdevice, "setProperty", "ui.Label2.value", "error") end local value = fibaro:getValue(389, "ui.Label1.value") local value = fibaro:getValue(389, "ui.Label2.value") fibaro:log(value) fibaro:call(fibaro:getSelfId(), "setProperty", "logTemp", "TxtRed" ) portant dans le debug les valeur sont bonne dans le json.decode mais fausse dans les variables voir debug dessous [DEBUG] 23:14:20: { "TaskValues": [ {"ValueNumber":1, "Name":"Temperature", "NrDecimals":2, "Value":20.00 }, {"ValueNumber":2, "Name":"Humidity", "NrDecimals":2, "Value":59.00 }], "TTL":2000, "DataAcquisition": [ {"Controller":1, "IDX":1, "Enabled":"true" }, {"Controller":2, "IDX":0, "Enabled":"false" }, {"Controller":3, "IDX":0, "Enabled":"false" }], "TaskInterval":2, "Type":"Environment - DHT11/12/22 SONOFF2301/7021", "TaskName":"temp-Humidite", "TaskEnabled":"true", "TaskNumber":1 } [DEBUG] 23:14:20: 200 [DEBUG] 23:14:20: temp=22, hum=59 si des expert pouvais me dire ou je me suis tromper merci a tous d'avance
  5. Peter

    Esp-easy

    merci a toi j'ai enfin pu mettre cette espeasy et sont dht11 en situation encore un grand merci
  6. Peter

    Esp-easy

    Bonjour et merci @Barelle sa fonctionne parfaitement j'aurais pas trouver es-que je peut te demandé sais tu comment mettre le symbole % et ° dans une etiquette de module virtuel en tout cas un grand merci a toi
  7. Peter

    Esp-easy

    Bonjour a tous Je me casse les dents depuis 3jours sur se code local thisdevice = fibaro:getSelfId() local taskId = "1" local conn = Net.FHttp(fibaro:getValue(thisdevice, 'IPAddress'), fibaro:getValue(thisdevice, 'TCPPort')) response, status, errorCode = conn:GET('/json?tasknr=' .. taskId) fibaro:debug(response) fibaro:sleep(1) if errorCode == 0 then fibaro:debug(status) jsonTable = json.decode(response); local temp = jsonTable.Temperature; local hum = jsonTable.Humidity; fibaro:call(thisdevice, "setProperty", "ui.Label1.value", temp) fibaro:call(thisdevice, "setProperty", "ui.Label2.value", hum) else fibaro:debug("error") fibaro:call(thisdevice, "setProperty", "ui.Label1.value", "error") fibaro:call(thisdevice, "setProperty", "ui.Label2.value", "error") end car je voudrais récupérer les infos de temperature et d'humidité d'une sonde DHT11 connecter sur un espeasy (Wemos D1) je n'arrive pas a récupérer les infos du json voici ce que j'ai dans le debug du VD [DEBUG] 15:04:37: { "TaskValues": [ {"ValueNumber":1, "Name":"Temperature", "NrDecimals":2, "Value":27.00 }, {"ValueNumber":2, "Name":"Humidity", "NrDecimals":2, "Value":64.00 }], "TTL":2000, "DataAcquisition": [ {"Controller":1, "IDX":1, "Enabled":"true" }, {"Controller":2, "IDX":0, "Enabled":"false" }, {"Controller":3, "IDX":0, "Enabled":"false" }], "TaskInterval":2, "Type":"Environment - DHT11/12/22 SONOFF2301/7021", "TaskName":"temp-Humidite", "TaskEnabled":"true", "TaskNumber":1 } si les pros du LUA pouvais me dire ou cela coince D'avance merci a tous
  8. Peter

    Script intervalle de temps

    Bonsoir regarde ce que j'ai fait pour ma fille et qui fonctionne depuis plusieurs années
  9. Peter

    Imprimeur needed :)

    @Lazer me dit pas que tu peux pas trouver un simplify 3d Hacker perso je teste aussi le prusaslicer et il est vraiment pas mal mais je galère un peu pour les réglages de mes machines pour le moment tester sur la tevo Tornado et l'AnetA8 vraiment sympa
  10. Peter

    Imprimeur needed :)

    @Lazer tu ne verras pas trop la différence entre 0.2 et 0.15 et tu doit être très large sur les 10% de Geetech j'aurais été mon gentil mais pour le filament bois j'adore la texture sur les pièces imprimées et en plus plus léger c'est vraiment sympa la ma tevo tornado imprime un Groot de 20CM de hauteur plus de 29H d'impression et en bois Bon teste pour le PETG tu trouvera le bon réglage sans souci perso j'ai créer plusieurs profile en fonction du PETG que j'utilise aussi bien sur cura que sous S3D la je teste le Prusa slicer sur mac il a vraiment l'air pas mal du tout
  11. Peter

    Imprimeur needed :)

    @Lazer pour le filament bois j'ai eu aucun souci avec sur 2 delta une anet a8 et une tevo tornado avec buse de 0,4mm Mais pour le PETG sur toute ses machines j'ai été obliger de couper le ventilateur de refroidissement soit complètement soit jusqu'à une hauteur de couche définit Suivant la pièces ( support ou pas porte à faux ect ) C'est la seul méthode que j'ai trouver qui fonctionne Sur plusieurs forum il expliqué que le petg refroidir trop vite et que les couches ne fusionné pas correctement Je te dit juste ce que j'ai expérimenter et qui fonctionne chez moi sur différente machine Après il faut que tu fasse des testes sans ventilateur (refroidissement pièces et pas corp de chauffe) par palier et tu verra à quelle puissance de refroidissement Ton PETG se comportera bien. Bon teste
  12. Peter

    Imprimeur needed :)

    @Lazer pour le PETG évite le refroidissement de la pièces ou vraiment a une vitesse très faible tester sur 4 machines et il s'imprime mieux sans refroidissement de couche
  13. Peter

    Bricolette chez BenjyNet

    @domo il y a cult''s , happy 3d, filiale de boulanger pour les pièces électroménager et plein d'autres
  14. Peter

    Bricolette chez BenjyNet

    @Lazer de rien Pour les buses je suis à plus de 1200 impressions en huit mois en pla/abs et je viens juste d'en remplacer une Par contre si vous passer de la fibre de carbone ou du nylon / polycarbonate la buse s'use beaucoup plus rapidement Sur une delta j'ai remplacé plusieurs fois la buse mais elle passe que des fils exotiques Amusez vous bien avec vos imprimantes
  15. Peter

    Bricolette chez BenjyNet

    @lazer quand ton fil est trop humide tu entend ta buse qui crépite ou claque et tu as plein de micro bulle sur l'impression Mais t'inquiet sa fait huit moi que j'ai du pla de la fibre de carbone et du nylon dans le garage et je ne les protèges pas plus que cela Et pour le moment aucun souci
×