Aller au contenu
Domodial

Google Home lié à Fibaro ID

Recommended Posts

Bonjour,

 

Je crée ce topic unique pour Google Home et Fibaro ID.

J'entends par là, la reconnaissance native de la box Fibaro, lié à l'application Home de Google, afin de ne pas mélanger les sujets avec le topic Google et IFTTT.

--------------------

 

Import des modules :

 

Je remarque que c'est aléatoire.

  • La page d'authentification Fibaro peut arriver tout de suite comme pas du tout avec une erreur.
  • L'import des modules dans Home peuvent se passer sans encombre comme terminer avec une erreur.
  • La modification du nom des modules ou l'ajout/suppression d'un module dans Fibaro doit passer obligatoirement par une rupture de la liaison Home/Fibaro afin de lier à nouveau le compte pour répercussion des changements apportés.

 

Je viens de faire la mise à jour de la HC2 et de lier Fibaro avec mes GH.

Si globalement ça fonctionne bien en donnant des ordres direct sur les noms des modules et des pièces, je note que Fibaro (ou Google) :

 

  • Ne remonte pas les scènes
  • Je viens de faire une scène bloc.

Je confirme d'après ce que je remarque, Fibaro et GH ne reconnait pas les scènes.

 

Egalement j'ai des modules qui n'apparaissent pas séparément en temps que tel, et donc je vois 1 groupe d'éclairage (sous Home) qui comprends 5 modules.

Il y a donc une notion de groupe, avec le temps je trouve que c'est pas mal.

Mais en sélectionnant sous Home (sur la partie haute de l'icon) le groupe en question, une fenêtre s'ouvre pour faire apparaître tous les modules du groupe.

A ce stade souvent Home dit que la connexion n'a pas pu être établi.

En fermant et re-ouvrant cette fenêtre nous voyons apparaître à la place du mot "connexion" l'intitulé "5 appareils".

 

Utilisation du groupe :

 

Supposons que nous avons "Led plafond" dans le salon, "Led plafond" dans la chambre, et "Led plafond" dans le séjour, avec plusieurs autres éclairages, nous aurons 3 groupes.

 

Pour faire la distinction entre "Led plafond" et "Led plafond" et "Led plafond" il faut ajouter dans la diction de l'ordre à donner, le nom de la pièce.

Exemple Dit google allume les led plafond du salon

Si je veux allumer tout l'éclairage du salon, alors il n'y a qu'à dire : Dit Google allume le salon

 

Jusque là c'est bien mais déconcertant sur le coup.

 

En ce qui concerne les routines entre Home et Fibaro :

 

Ca ne se passe pas très bien et même pas bien du tout.

J'ai des comportements étranges, soit GH ne reconnait pas la commande alors que la routine est bonne (à mes yeux), soit il allume une lampe de chevet (par exemple) alors que j'ai demandé d'allumer un éclairage qui n'a rien à voir et qui est dans une autre pièce (en plus !!) mais pourtant bien configuré comme appartement à la pièce que je veux.

 

Ce point est le plus gros point noir pour moi (en dehors des scènes non reconnues)

 

MAJ : 

Les routines fonctionnent finalement, il faut vraiment faire attention aux accents et aux libellés des modules.

 

Je dit : allume le néon (qui est au salon)

L'assistant Google Doit : allume le néon du salon (pour établir que c'est le néon du salon et pas le néon du garage) / éteint la lumière blanche du salon / met de la lounge sur spotify !

Si je fait dans la config "neon" à la place de "néon" ou "néons" ça ne fonctionne pas !

Egalement LUMIERE provoquera une réaction de GH qui va épeler la commande.

Avec Lumière ça fonctionnera.

 

Note : dans cet exemple j'ai voulu essayer une séquence qui dans le sens ou la lumière blanche était allumé, je voulais qu'elle s'éteigne lors de l'allumage du néon (qui en fait un mix de multiples led combiné dans des meubles mais avec un néon bleu derrière un radiateur et donc plus facile par habitude à retenir pour la famille) et en bypassant le fait de dire toujours "Salon" à la fin. C'est un peut le roles des routines (enfin pour moi).

 

Les routines V2 sont vraiment sympas car nous pouvons chainer contrairement à avant.

 

Reconnaissance normal :

 

Exemple marrant :( Dit Google, Allume les lumières blanches >> Réponse : Je change la couleur en blanc de la lampe de chevet.

Rappelons que "Lampe de chevet" ne s'appelle pas "Lumière blanche" mais "Lampe de chevet" (en plus j'en attends une deuxième ça va être comique)...

 

Continuons Dit Google, Allume les lumières blanches du salon >> ça fonctionne parfaitement

 

En gros, si l'on indique pas le nom de la pièce, ça devient un foutoir sans nom !! GH fait n'importe quoi (ou plutot la combinaison Fibaro + GH)

 

Modifié par Domodial
  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Même les scènes fait en mode briques ne remonte pas ? Je ne sais plus du coup, dans c'est que dans Alexa ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne sais pas nico je n'ai aucune scène en mode brique, c'est tellement chiant à faire :lol: 

 

Je sais qu'avec Alexa il faut en passer par là. Je vais essayer. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de faire une scène bloc.

Je confirme d'après ce que je remarque, Fibaro et GH ne comprends pas les scènes.

Partager ce message


Lien à poster
Partager sur d’autres sites

Routines OK (Maj dans le topic)

En fait Home est sensible aux accents (de ce que je comprends).

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Jusqu'à hier, tout fonctionnait très bien pour les actionneurs, avec accent ou pas, pas de soucis. Mais je n'utilise pas les routines...

Par contre, depuis aujourd'hui plus rien ne fonctionne... j'ai réessayé de réassocier mon compte, mais j'ai une erreur...

Je ne sais pas si c'est lié à la màj 4.530 de hier...

Je réessayerai plus tard.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, je viens de constater que IFTTT ne voit plus non plus les scènes et devices de la HC2... Donc c'est un problème Fibaro... :-(

  • Thanks 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Chez moi également. Je pense que c'est le même soucis chez Fibaro qui m’empêche de lier mon système avec Google Assistant...

Partager ce message


Lien à poster
Partager sur d’autres sites

Par contre j'arrive toujours a lier ou délier Home. Au passage de la version 4.530 j'avais pleins de messages d'erreur avec la liaison mais j'ai l'impression que le cloud Fibaro n'avait pas fini de connaître la nouvelle version de ma box. Depuis je n'ai plus d'erreurs en import mais je n'ai jamais vue une seule lueur de scènes lol

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, easyjava a dit :

Chez moi également. Je pense que c'est le même soucis chez Fibaro qui m’empêche de lier mon système avec Google Assistant... 

Alors ça, j'ai eu ce problème, et si tu es en 4.520, il traine un méchant bug dedans, j'ai résolu en faisant un Backup puis un reboot de la box.

Ensuite l'ajout du compte a fonctionné.

Partager ce message


Lien à poster
Partager sur d’autres sites

j’a réessayé hier, et j’ai pu relier mon compte sans problème... tout refonctionne normalement chez moi 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ikilou, moi pareil, la première fois j'ai du laisser passer une nuit, et le lendemain tout était ok.

Partager ce message


Lien à poster
Partager sur d’autres sites

Quelqu'un pourrait me dire, a quel endroit apparait les scènes importé dans Google Home ?

J'ai fait une scène à nouveau et j'ai relié mon compte mais je ne vois toujours rien apparaître.

 

Est-ce que c'est planqué dans GH ou est-ce que ça apparait dans la liste ou la pièce ou est rangé ma scène ?

 

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

seulement les devices viennent dans GH... pas les scènes...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous,

 

est at ce que avez des problèmes de latences pour que la Google home émette une action ?

 

je lui dit par exemple :

ok Google allume le salon 

 

met je dois attendre 5 sec a 10sec pour qu’elle allume la lumière.

avant c’était quasi instantané... une idée d’ou Pourrais venir mon problème ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

en fait, c’est les lumières et les actionneurs comme les wall plug. Pas les stores, pas de plugin, pas de VD, scène...

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, ArTi69 a dit :

Bonjour à tous,

 

est at ce que avez des problèmes de latences pour que la Google home émette une action ?

 

je lui dit par exemple :

ok Google allume le salon 

 

met je dois attendre 5 sec a 10sec pour qu’elle allume la lumière.

avant c’était quasi instantané... une idée d’ou Pourrais venir mon problème ?

 

Pas de soucis chez moi, j’en même mis un dans ma voiture, qui est connecté sur une clé USB wifi/4G, et c’est très rapide malgré le fait que c’est une liaison lente...

Modifié par ikillou

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, ikillou a dit :

seulement les devices viennent dans GH... pas les scènes...

Mais du coup, si je remonte plus haut vous parlez des scènes, mais alors elle sont prisent en considération mais pas visible dans GH c'est ça ?

Punaise je ne pige plus rien.

 

Quelqu'un peut m'expliquer  ??? Les scènes c'est ou qu'elles sont lol

Modifié par Domodial

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de rencontrer un truc que je n'avais pas vu.

Ma routine est bonne mais google me dit : Je ne sais pas qu'elle appareil led allumer.

 

Ce n'est même pas une erreur de routine, il y a quelque chose qui ne va pas mais je ne sais pas quoi, car au bout d'un certain temps elle comprends (lag ???) tout a fait la commande mais une fois sur 15.

En lui répétant au bout d'un moment sans changer la routine elle allumes les bonnes leds. C'est super aléatoire, c'est du grand n'importe quoi qui fait chercher dans tout les sens et j'ai l'impression que quelque chose ne se passe pas bien entre les serveurs GH et Fibaro.

 

C'est épuisant.

Partager ce message


Lien à poster
Partager sur d’autres sites

En fait, les scènes, je les utilise en passant par IFTTT... Là, oui, tu peux définir des Applets qui réagissent depuis GH (le IF) et pour le THEN c'est démarre une scène Fibaro.

 

Donc, par exemple, si je dis : OK Google, mets l'alarme. Il démarre une scène sur la HC2 pour armer les sensors.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

En effet les scènes IFTTT fonctionnent directement via IFTTT mais je pensais qu'elles étaient vues par Google directement. Pour Alexa la scène est bien vue mais Alexa ne comprends pas la commande lol. Misère se misere.

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est quand même laborieux la reconnaissance avec GH et les routines etc...

Je vais repasser sur le script à Steven, je n'avais aucun loupé.

Partager ce message


Lien à poster
Partager sur d’autres sites

×