Aller au contenu
Yohan

Fibaro Fgs-211 / Fgs-212 "relay Switch 1X3Kw"

Recommended Posts

Il faut inclure le module en étant àportée radio de la box, car le routage n'est pas actif au moment de l'inclusion.

Au besoin, rapproche ton module pour l'inclusion, puis déplace-le ensuite àsa position définitive.

Partager ce message


Lien à poster
Partager sur d’autres sites

Lazer met le doigt sur un point important, car d'après ce que je viens de lire sur un autre post, tu as une box récente et un ou deux modules... Pas simple d'avoir un bon maillage si ton switch est éloigné de la box, il te faut un module qui fasse fonction de répartiteur

Partager ce message


Lien à poster
Partager sur d’autres sites

Autre chose, il m'est arrivé, même en étant àproximité immédiate de la box, de ne pas arriver àinclure le module en cliquant 3 fois sur le bouton dédié.

Une autre solution est de mettre le box en mode inclusion, puis durant les 30s qui suivent, brancher électriquement le module. En effet, lors de l'alimentation électrique, les modules Fibaro se mettent en inclusion automatique.

Partager ce message


Lien à poster
Partager sur d’autres sites

@Nvince76

@Lazer

 

Bonsoir j'ai essayé de le mettre a proximité de la box mois de 1m mais cela ne fonctionne pas.

J'ai aussi essayé en appuyant plus de 3 fois sur le bouton B.

Partager ce message


Lien à poster
Partager sur d’autres sites

Moi, j’appuie pas 3 fois, mais 10-15 fois rapidement et sur un FGK (Détecteur à  d'ouverture à  pile), il faut maintenir l'arrière + cliquer comme un malade sur le bouton.

 

Sinon, c'est vrai que pour les module alimenté, j'ai jamais eu de soucis.

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu fais bien supprimer un module (plus les 3 appuis sur B) avant de l'ajouter?

Partager ce message


Lien à poster
Partager sur d’autres sites

 @Lazer, (à  propos du chauffe-eau)

 

 Comme je n'avais pas de nouvelles du connecteur avec les fils rouges et bleus pour relier mon FGS aux résistances, j'ai soudé des cosses en forme d'oeillet sur un fil bleu souple de 2,5mm2.

FGS-211 Chauffe-eau

 Une que j'ai assemblé à  celle que j'ai démonté de la résistance avec un boulon à˜5mm puis bien isolé. Et l'autre que j'ai recâblé sur la résistance. De cette façon, le fil d'origine n'est pas coupé. Par contre, j'ai alimenté le FGS avec une ligne 220V extérieure au chauffe-eau autrement, il aurait été éteint tout le temps entre 6h et 22h (donc pas de retour). J'avais aussi besoin d'améliorer le maillage dans ce coin.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Excellent Did !!!

En plus tu conserves la garantie avec ce montage. BIen vu ;)

 

Si je comprends bien, tu ne coupes pas la (les) phases, mais le neutre, car un seul fil suffit.

Et le FGS sert à  piloter un relai, et c'est ce dernier qui coupe le neutre.

 

Tu m'étonnes que le Z-Wave ça ne doit pas bien passer derrière un ballon d'eau-chaude !

 

Etape suivante : domotiser la sonde de température, c'est à  dire la mesurer la thermorésistance, afin de pouvoir intégralement reprogrammer le chauffe eau, et balancer la télécommande fournie avec.

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui garantie, tu as bien deviné ;) J'ai édité mon message du dessus.

c'est encore le syndrome de la touche Tab, j'ai du mal avec le clavier de mon nouveau portable.

Partager ce message


Lien à poster
Partager sur d’autres sites

ok et pour faire plus simple (moins passionnant je vous l'accorde...)

simplement mettre le controller sur l'arrive electrique, ça vous semble correct ?

Peso vu que j'ai payé mon ballon 600€ chez casto, je suis pas sur qu'il ai une sonde qui doit être tout le temps branchée.. (j'ai quand même une pile de 9V et une sonde titane)

qu'en pensez vous ?

merci :)

Partager ce message


Lien à poster
Partager sur d’autres sites

 @Lazer,

Le fil neutre est plus simple à  couper car le câblage est prévu pour être alimenté en triphasé (en remplaçant la carte et rebranchant le connecteur).

J'ai un peu rusé avec l'utilisation du FGS, comme c'était un module qui déconnait, le relais Finder possède un contact inverseur 16A et j'ai branché le contact repos pour que le chauffe-eau soit alimenté au repos.

FGS Chauffe-eau

 J'ai inversé les icônes On et Off, je ne manoeuvre pas le module physique mais un module virtuel où j'ai inséré la température de l'eau chaude et la puissance consommée (venant d'une tore du HEM3)

Module virtuel Chauffe-eau

 Le main loop m'affiche l'icône (Arrêt ou Marche), la conso et la température de l'eau chaude mais je suis un boulet sur Lua, cela fonctionne mais si vous avez un code plus simple ou mieux formulé, ça m'intéresse.

--[[
%% properties
%% globals
--]]

local id_module_virtuel = fibaro:getSelfId()
     
local allumer = tonumber(fibaro:getValue(31, "value")) == 0
local eteindre = tonumber(fibaro:getValue(31, "value")) == 1
     
local icon = fibaro:getValue(31, "currentIcon")
if (allumer) then
icon = 1079
elseif (eteindre) then
icon = 1080
end
fibaro:call(171, "setProperty", "currentIcon", icon)

local temp = fibaro:getValue(46, "value")
fibaro:call(171, "setProperty", "ui.Label1.value",temp.. " W")
local temp = fibaro:getValue(213, "value")
fibaro:call(171, "setProperty", "ui.Label2.value",temp.. " °C")
fibaro:log(fibaro:getValue(213, "value").." °C - "..fibaro:getValue(46, "value").." W" )
fibaro:sleep(4000);
  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Comment récupères-tu la température de l'eau chaude ?

 

@ploznher, relis bien mon message du 02 octobre 2014 - 23:43 en première page, pour bien comprendre le mécanisme de la batterie.

Partager ce message


Lien à poster
Partager sur d’autres sites

 C'est une sonde étanche sur un  FGBS. Elle est simplement fixée avec un serflex sur le tuyau d'eau chaude en sortie et isolée thermiquement.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah ok je pensais faire ça aussi, et puis avec de la pâte thermique pour améliorer le contact.

Mais je pense qu'il y a un petit delta par rapport à  la température interne réelle.

 

C'est pour ça qu'il serait intéressant d'arriver à  choper l'info depuis la thermistance directement, puisque c'est elle qui pilote le thermostat du ballon, pour la sécurité.

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

 C'est vrai que la température monte un peu quand on tire de l'eau chaude.

Partager ce message


Lien à poster
Partager sur d’autres sites

 Un petit retour sur le maillage Zwave, j'avais installé il y a quelques semaines un FGBS-001 (pour l'utilisation d'un contact et une sonde de température DS18B20) alimenté en 12V pour étendre la couverture vers un FGFS-101 mais il passait en noeud mort aléatoirement. Depuis l'ajout du FGS-211 dans mon chauffe-eau (à  proximité), ce FGFS-101 m'affiche maintenant un beau vert et ne passe plus en noeud mort.

L'extension de la couverture Zwave serait donc plus efficace avec les modules 220V?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai aussi remarqué que le FGBS Universel a une porté moins importante que les modules alimentés en 230V.

Partager ce message


Lien à poster
Partager sur d’autres sites

 Salut Lazer.

Que penses-tu de ma mainloop du MV chauffe-eau?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne suis pas expert en LUA, mais je verrais bien les optimisations suivantes afin de mieux utiliser les variables et limiter les appels aux fonctions getValue(), consommatrices de temps :

--[[
%% properties
%% globals
--]]

local id_module_virtuel = fibaro:getSelfId()
    
local allumer = tonumber(fibaro:getValue(31, "value")) == 0
local eteindre = tonumber(fibaro:getValue(31, "value")) == 1
    
if (allumer) then
 icon = 1079
elseif (eteindre) then
 icon = 1080
else
 icon = fibaro:getValue(31, "currentIcon")
end
fibaro:call(id_module_virtuel, "setProperty", "currentIcon", icon)

local conso = fibaro:getValue(46, "value")
fibaro:call(id_module_virtuel, "setProperty", "ui.Label1.value",conso.. " W")
local temp = fibaro:getValue(213, "value")
fibaro:call(id_module_virtuel, "setProperty", "ui.Label2.value",temp.. " °C")
fibaro:log(temp.." °C - "..conso.." W" )
fibaro:sleep(4000);

Partager ce message


Lien à poster
Partager sur d’autres sites

Question ... s'il est pas allumé .. c'est qu'il est éteint .. ou il peut prendre une autre valeur ?

local allumer = tonumber(fibaro:getValue(31, "value")) == 0

icon = 1080
if (allumer) then
 icon = 1079
end
fibaro:call(id_module_virtuel, "setProperty", "currentIcon", icon)

On gagne encore une variable (eteindre) qui ne sert à  rien.

 

Edit : l'entête

--[[
%% properties
%% globals
--]] 

C'est pas très utile dans un main loop :)

 

Edit 2 : @Lazer, bien vu pour la réutilisation de temp et conso.

Partager ce message


Lien à poster
Partager sur d’autres sites

 Merci Lazer et Steven pour vos suggestions très pertinentes.

Mais après la simplification des états de Steven, l'icône ne changent plus et les valeurs en vert sous le module dans l'interface HC2 ne s'affichent plus.

Partager ce message


Lien à poster
Partager sur d’autres sites

Pardon Steven, j'ai remis

local id_module_virtuel = fibaro:getSelfId()

que j'avais viré avec le copier-coller

Partager ce message


Lien à poster
Partager sur d’autres sites

Je savais bien ... vu la perfection de Lazer et la mienne, cela n'était pas possible de faire une erreur. donc par définition, seul toi est à  mettre en cause.

 

Heiiinnnn, quoiii, comment cela la grosse tête ... pfffftttt ... même pas vrai.

 

:98:  et Lazer    :99:

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

 Non, non restez, encore une question sans jeu de mots:

Puis-je baisser mon sleep dans le mainloop? Enfin le réduire.

Partager ce message


Lien à poster
Partager sur d’autres sites

×