Welcome to Domotique-fibaro

 

Inscrivez-vous maintenant pour accéder à toutes nos fonctionnalités. Une fois inscrit et connecté, vous serez en mesure de contribuer à ce site en soumettant votre propre contenu ou en répondant au contenu existant. Vous serez en mesure de personnaliser votre profil, de recevoir des points de réputation comme une récompense pour la soumission de contenu, tout en communiquant avec d'autres membres via votre boîte de réception privée, et bien plus encore! Ce message sera supprimé une fois que vous vous êtes connecté.

 

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

372 messages dans ce sujet

Bonjour Jonny ;)

 

Ce n'est pas forcement simple à  mettre en place avec le Toolkit mais l'idée me plait bien :60: , je suis aussi actuellement sur un autre projet qui pourrait me servir de "socle".

 

Juste une question tu utilises OSX ou Windows ?

 

 

Hi Jonny, great idea but this is not easy to implement in the "Toolkit". I currently work on a side project that could serve as base :15:

Just a question: Your system is OSX or Windows ?

0

Partager ce message


Lien à poster
Partager sur d’autres sites

J'utilise les 2 mais le toolkit est installé sur ma machine Windows.

 

 

I use both but toolkit are installed on my windows machine

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Très bien, cela ne sera surement pas fait rapidement mais je vais essayer le plus vite possible.

ps: si je dois installer un service, c'est un problème pour toi ?

 

Fine! I couldn'y do it fast but i'll try asap.

if i should install a service, this is a problem for you?

Stay tuned ;)

3

Partager ce message


Lien à poster
Partager sur d’autres sites

pas du tout un problème

Not àproblem at all

0

Partager ce message


Lien à poster
Partager sur d’autres sites

KriKroff, petite question sur une évolution : Serait il possible de pouvoir réimporter la configuration d'un module (Non virtuel, un vrai) depuis le toolkit ? Je m'explique. Sur des modules du type FGMS, remettre tous les paramètres est long et fastidieux. Du coup cela permettrait après désinclusion/inclusion de recharger les paramètres, de les cloner d'un àl'autre, etc ? Tu penses que c'est jouable ?

1

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui je pense que c'est jouable Nico et je trouve d'ailleurs que c'est une très très bonne idée, merci :60:

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Arghhhhhhhhhhhhh !!!! Et dire que cela me trotte dans la tête depuis que j'ai ces FGMS qui me font chi**, avec leur 35 paramètres à  tout le temps refaire. Si tu y arrives, ce serait, excellent !! Pareil pour mes VR, je pourrai tout cloner facile du coup quand je modifie un truc.

 

Merci Krikroff !!!

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Krikroff,

 

Pour ma migration à  la future V4, je me prépare comme je peut pour tout rationaliser, concentrer afin que je puisse réinstaller from scratch si ça se passe mal.

Question, avec le toolkit, j'arrive à  exporter le code des VD et scènes, c'est super, mais j'aimerais aussi pouvoir exporter le reste que tu présente dans l'interface:

- Variables globales et leur contenu

- association des pièces, niveaux, icônes

- configuration des modules comme suggéré ici plus haut

- etc

enfin, bref, toute la config serait bien ;-)

Merci !

0

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ajoute ta demande dans ma roadmap mais je peux pas promettre de sortir cela avant la V4 il y a déjàbeaucoup àfaire pour rendre le toolkit compatible avec la V4, les changements sont très nombreux

Envoyé de mon iPhone àl'aide de Tapatalk

1

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Tout le monde !

J'ai trouvé un workaround très simple:

Il suffit dans l'appli toolkit, de sélectionner toutes les cellules d'une section (le petit rectangle tout en haut à  gauche, à  côté de ID#) et de copier (CTRL+C) 

Ensuite il suffit de les coller dans un fichier excel.

La seule chose qui ne passe pas, ce sont les variable (contenues dans une list box)... Une suggestion Krikroff ?

0

Partager ce message


Lien à poster
Partager sur d’autres sites

@JC,

Je viens d'installer la dernière version V1.0.2.1 Rc2, mais cela crash systématiquement :

 

   à  HC2Toolkit.MainWindow..ctor()
   à  HC2Toolkit.App.ApplicationStart(Object sender, StartupEventArgs e)
   à  HC2Toolkit.App.OnStartup(StartupEventArgs e)
   à  System.Windows.Application.<.ctor>b__1(Object unused)
   à  System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   à  MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)
0

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok la suppression par désinstallation ne supprime pas tout.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui j'avais le même souci, il faut tout supprimer et réinstaller du départ.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

JC, dans ta todo list, pourrais tu rajouter une option pour sauvegarder l'ensemble des icônes présents  ?

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Ils sont déjàtous sauvegardes et disponibles dans le cache applicatif , il me semble avoir donné le lien dans le changelog, sinon dis moi . Une option directement dans le menu serait une bonne chose

Envoyé de mon iPhone àl'aide de Tapatalk

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, je pensais plus àune fonction supplémentaire dans un menu déroulant genre "save all icons"

2

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de m’apercevoir que le niveau des piles d'un ST814 n'est pas affiché, or dans les "API raw data" on trouve   "batteryLevel": "60",

Donc, à  l'occasion, si c'était un effet de vot'bon cÅ“ur !!!

 

Merci.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

@ KriKroff,

J'ai comme qui dirai un plantage !

 

post-937-0-94172800-1418746877_thumb.jpg

0

Partager ce message


Lien à poster
Partager sur d’autres sites

- Suite à  quoi ?

- Sur quelle version du HC2 ?

- Sur C: ou dans ton dossier d'installation tu devrais trouver un fichier toolkit-craschdump-xxxxx.txt, si tu peux me l'envoyer par MP.

 

JC

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Comme tu as pu le constater, je bosse sur le RGBW de Fibaro.

Ton appli ce lance bien, je navigue dans les différents onglets. Cependant lorsque je navigue dans l'onglet "Devices" en descendant avec le scroll j'ai ce plantage.

 

Version HC2: 3.590

Bizarrement pas de craschdump.

 

Bruno

 

post-937-0-14730200-1418749837_thumb.jpg

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Hum... Et si tu reproduis le problème et que tu fais voir les détails sur la fenêtre d'erreur, ca dit quoi ?

Envoyé de mon iPhone àl'aide de Tapatalk

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bien avec un peu de recherche j'ai ça:

Je suis en ce moment entrain de taquiner les modules RGBW et mon btn Tactile RGBW.

Lorsque je met le mode 0-10v je me retrouve avec des sensors Other.

Lorsque je repasse ce mode en RGBW les sensors sont supprimer, mais ton toolkit me les trouvent et plante dessus !!!

Maintenant si je repasse en 0-10v afin de bien rendre les sensors présents, ceux-ci ont changé ID !!! donc ça plante quand même.

Bref, pas grave, j’espère que la V4 résoudra ce problème.

Ceci dis regarde ce point si tu as la V4 en route...

 

 

Pour info:

 

Nom d’événement de problème: CLR20r3
  Signature du problème 01: hc2toolkit.exe
  Signature du problème 02: 1.0.2.1
  Signature du problème 03: 53e024b5
  Signature du problème 04: mscorlib
  Signature du problème 05: 4.0.30319.17379
  Signature du problème 06: 4f27368c
  Signature du problème 07: 42df
  Signature du problème 08: 13c
  Signature du problème 09: System.UnauthorizedAccess
  Version du système: 6.1.7600.2.0.0.256.1
  Identificateur de paramètres régionaux: 1036
  Information supplémentaire n° 1: ca67
  Information supplémentaire n° 2: ca67234244b6040900d39053461f3b7d
  Information supplémentaire n° 3: 19a1
  Information supplémentaire n° 4: 19a17f9cab4624323063ba21309a893c
 
Lire notre déclaration de confidentialité en ligne :
 
Si la déclaration de confidentialité en ligne n’est pas disponible, lisez la version hors connexion :
  C:\Windows\system32\fr-FR\erofflps.txt
0

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok merci je n'avais jamais testé le RGBW en mode sensors je vais essayer de reproduire le problème.

JC

Envoyé de mon iPhone àl'aide de Tapatalk

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Krikroff,

 

sans vouloir abuser :15: , dans ta todo list, pourrais tu rajouter 2 possibilités ?

 

- pouvoir changer la police de l'éditeur de code LUA

- indenter automatiquement le code

 

merci

0

Partager ce message


Lien à poster
Partager sur d’autres sites

@Fred, Ok je note et je rajoute ça dans ma toto list :) .

 

@Turlututu74, j' ai migré la sortie crashdump dans les documents de l’utilisateur afin d'éviter des plantages relatifs aux droits sur le système de fichier.

 

Sinon, je finalise actuellement le support de la V4 et ce n'est pas simple car au niveau de l' API Fibaro a initié des changements et a arrêté en cours de route visiblement :huh:, des trucs exotiques aussi :rolleyes:

0

Partager ce message


Lien à poster
Partager sur d’autres sites