Aller au contenu
pepite

Prévision Météo

Recommended Posts

De rien ;-) c'est le code brut sur cette v1 la.

Je suis en train de revoir le tout en ce moment ^^

Envoyé depuis la Station Spatiale Internationale

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour le VD, ça fonctionne bien !

 

Après se pose la question de previsions ... sont elle fiables ? mais c'est un autre debat !

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

 

Fonctionne parfaitement pour moi. seul regret, Fibaro ne laisse pas faire d'import massif d'icones...

 

Merci aux dev.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Perso à un souci avec ce VD,?

il indique -273°C sur toutes les prévision?

Partager ce message


Lien à poster
Partager sur d’autres sites

Fonctionne toujours aussi bien. Vu les problemes de Weather sur la nouvelle version HC2. Je vais l'utiliser pour mes variables temperatures exterieur ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

 

on rajoute le VD et c'est finit ? ou on doit faire des trucs encore :p

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Faut rajouter les icones ;-)

Sinon, tu peux aller voir le VD/scene récent de Dragoniacs, WeatherBit

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@pepite

 

Encore une mauvaise nouvelle sur la meteo. Apres les plugins officiels qui ne fonctionnent plus.

 

Sur ton plugin meteo, je pense que maintenant il demande une clef token sur www.prevision-meteo.ch

 

Ca fonctionne plus depuis le 23/08.

 

Tu en penses quoi ?

Partager ce message


Lien à poster
Partager sur d’autres sites

ça ne fonctionne plus chez moi non plus depuis le 23/08

Quand j’essaie d'afficher le json sur le debug de la box.

J’obtiens ceci:image.png.eb6b5f626d8289f36b35c1573fe2d371.png

 

Partager ce message


Lien à poster
Partager sur d’autres sites

En fait, c’est la méthode d’acces au site qui ne fonctionne pas. J’ai essayé via un navigateur via https et j’arrive à obtenir le fichier.

mais je ne sais pas comment faire du https avec la HC2.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Pour faire du https, faut passer par une scene, pas de https avec un VD.

 

Comme ceci par exemple :

--[[
%% properties
%% events
%% globals
--]]

local id_vd = xxx

local http = net.HTTPClient()
http:request("https://www.data.gouv.fr/fr/datasets/r/000ae493-9fa8-4088-9f53-76d375204036", {  
    success = function(response)
      if response.status == 200 then
        if response.data and response.data ~= "" then
          fibaro:setGlobal("VacancesScolaire", response.data)
          fibaro:call(id_vd, "pressButton", "1")
          fibaro:debug("Success")
        else
          fibaro:debug("Error : empty response data")
        end
      else
        fibaro:debug("Erreur : status=" .. tostring(response.status) .." Message : " .. tostring(response.data))
      end
    end,
    error = function(err)
      fibaro:debug("Erreur : " .. err)
    end,
    options = {
      method = 'GET',
      timeout = 3000,
      headers = {['content-type']='application/json'},
      checkCertificate = false,
    }
})

Partager ce message


Lien à poster
Partager sur d’autres sites

Mais honnetement, jeter un oeil ici ;-)

 

 

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ce tuto météo, 

Je l'ai suivi et en 30 minutes tout est configuré et fonctionne bien ! 

Partager ce message


Lien à poster
Partager sur d’autres sites

Le plugin Weatherbit fonctionne bien aussi de mon coté. Par contre il n'y a pas d'icones meteo en fonction du temps sur celui-ci. C'est dommage ... Il faudrait essayer de les intégrer.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le plugin Weatherbit fonctionne bien aussi de mon coté. Par contre il n'y a pas d'icones meteo en fonction du temps sur celui-ci. C'est dommage ... Il faudrait essayer de les intégrer.
C'est une idée, je vais regarder comment faire ça

Envoyé de mon SM-A530F en utilisant Tapatalk

  • Like 2

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de publier une V3.0 avec les icônes :60:

Par contre, les icônes ne s'affichants toujorus pas sur l'appli FIBARO, j'ai du ajouter un slider de choix en bas du VD :huh:

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

×