Welcome to Domotique-fibaro

 

Inscrivez-vous maintenant pour accéder à toutes nos fonctionnalités. Une fois inscrit et connecté, vous serez en mesure de contribuer à ce site en soumettant votre propre contenu ou en répondant au contenu existant. Vous serez en mesure de personnaliser votre profil, de recevoir des points de réputation comme une récompense pour la soumission de contenu, tout en communiquant avec d'autres membres via votre boîte de réception privée, et bien plus encore! Ce message sera supprimé une fois que vous vous êtes connecté.

 

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Berale24

HC2 & HCL - Version 4.110 - Stable - 04/01/2017

410 messages dans ce sujet
Il y a 23 heures, Nico a dit :

Oui, supprimes ton modules et refais le à 0.

 

Hello,

 

Alors, ce soir j'ai sortit l'armada :D

Une ralonge 220v et RJ45

 

De une, j'ai pu supprimer mes modules, mais ils étaient toujours présent dans mon panneau.

J'ai cliqué sur la X et ils sont partit.

Puis je les aient inclus à nouveau, mes 2 RGBW refonctionnent et mon script avec (en changeant les ID)

 

Mais j'ai toujours ma m... dans le center panel.

 

Donc ça tourne depuis 9 mois et impossible de virer ça.

Du coup, je ne peux faire la mise à jour des FW de ces modules.

 

Finalement la couleur est revenu chez moi, mais pas ma merdasse de départ.

 

Idem pour l'oeil de sauron, lui je n'y touche pas encore, après 3 mois il n'a plus de pile (enfin je crois).

 

Grrrrr

1

Partager ce message


Lien à poster
Partager sur d’autres sites

afac

0

Partager ce message


Lien à poster
Partager sur d’autres sites

afac

0

Partager ce message


Lien à poster
Partager sur d’autres sites

je ne trouve pas pour l'appli mobile, peut être pcq je n'ai pas renommé mon comte admin ?

On peut donner une adresse email bidon  pour l'admin ? style admin@moi.be ? quelle est l'implication, la hc2 envoie des emails de vérification, changement de mot de passe etc ?

0

Partager ce message


Lien à poster
Partager sur d’autres sites

oui ça renvoie une code de confirmation sur le mail, à rentrer dans le wizard pour finaliser.

3

Partager ce message


Lien à poster
Partager sur d’autres sites

 Ah, merci @biboun pour cette réponse.

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Ouais et moi ça met le brin dans mes commandes curl de FHEM :( et comme je suis une pipe la dedans, je sais pas comment modifier l'expression pour que ça passe :)

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Et ces commandes font quoi, mise à jour de quoi ? Potentiellement selon ce qu'elles font, un compte non admin suffit.

0

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 08/01/2017 à 15:39, Sakkhho a dit :

je viens de m'apercevoir que dans cette version (ou peut être avant) toute sauvegarde s'accompagne d'un checksum de la clé

Je confirme mais en plus :

Capture d’écran 2017-01-12 à 17.42.24.pngLa date Status du serveur dans Information générales ( .serverStatus de strings/info ) que je pensait être le temps écoulé  depuis le dernier reboot est réinitialisé à 0

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Le serverStatus est réinitialisé à chaque redémarrage des services Fibaro, donc cela signifie qu'ils redémarrent les services à chaque backup.

1

Partager ce message


Lien à poster
Partager sur d’autres sites

Il semblerai, si quelqu'un peut confirmer  

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Mais c'est toujours le cas non ? Car après un backup, dans la partie haute on voit bien Moteur Zwave lancé etc.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui mais avant ça n'influençait pas le serverStatus 

0

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 11/01/2017 à 16:55, Nico a dit :

Seb, tu es sur du profil de Mme ?

Tu as tente de réinstaller l'app, moi j'avais eu à le faire en 4.100 de mémoire.

finalement ça a fonctionné :)

Merci !

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Well done @sebcbien.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Ahh nickel Seb !

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Seb c'est bien :60:

 

J'ai honte :94:

2

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah voilà, mon test est fini :

 

j'ai donc fait un backup en 4.110 pour voir, et je confirme tout ce qui a été dit :

- redémarrage de tous les services Fibaro (alors qu'avant, ils n'étaient pas tout redémarrés) => Donc maintenant le serverStatus repasse à 0

- recalcul du checksum

2

Partager ce message


Lien à poster
Partager sur d’autres sites

Veuillez noter: depuis 4.110, la commande /service/startUpgrade.php et /services/startBetaUpgrade.php a été supprimée.

Il faut utiliser le postman avec la commande POST (http: //HC-IP/services/system/update.php) pour forcer l'installation du microprogramme sur la version existante :18:

4

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci Tinman.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Attention Backup entraîne maintenant redémarrage de tous les services Fibaro ( confirmé par @Lazer )

Donc les scènes auto start redémarrent 

J'ai constaté danc ce cas qu'il me manquait  un sendmail et je pense aussi les notifications que j'envoi en début de scène.

J'ai pensé que si on attend pas un peu, les services ne sont pas encore tous initialisés et donc pas de send mail ..

J'ai ajouté une attente d'une minute avant, et là ça a fonctionné.

 

    -- Charger l'heure courante et celle du démarage de la box
    local horaire = os.date ("Le %d/%m/%Y à %H:%M:%S")	
    local hc2 = api.get('/settings/info')    
    --Voir si serverStatus redémarré depuis moins de 15 minutes
    if os.time() - hc2.serverStatus <= 15 * 60 then 
	fibaro:setGlobal('G_Starting', "ON")  -- c'est un reboot ou Backup
    	fibaro:sleep( 60 *1000 ) --pour temporiser demurrage sce pour mail
        fibaro:call(Id_Admin, "sendEmail", "Etat HC2" ,  "Hc2 StartServeur (Boot ou Backup) -> G_Starting ON " ..horaire)	
    else

 

 

Modifié par henri-allauch
0

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, tinman a dit :

//HC-IP/services/system/update.php

Thanks a lot, very useful information, exit startupgrade ;-)

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon j'ai cliqué sur la maj et sans réfléchir, j'ai suivi le wizard avec log en adrese mail ....

Et et , bien sur puisque je n'ai pas lu tous les post ect ect.... et donc tous les appels http down (et j'en utilise bcp ! )

Du coup, backup et suprise, je reste en 4.11 mais je peux fermer le wizard et ne pas finir donc mes appels ok!

je vais relire le fil pour voir si une solution à été apportée à cela !

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tes appels n'ont pas besoin des droits d'admin, tu peux simplement recréer un user nommé "admin" avec les droits d'accès aux modules/scences/VD nécessaires.

A priori les appels d'API qui nécessitent les droits d'admin sont assez limités, ceux qui ont le problème compléteront, je crois qu'il s'agit de mettre à jour des valeurs dans des fake devices.. ( et il y a une méthode de contournement)

 

Je ne sais pas si vous avez reçu le mail, mais de toute façon Fibaro va "imposer" cette méthode sous peu:  http://mail.exciting-news.pl/p/sgnzb5tuue/jfb17wyk5b/

0

Partager ce message


Lien à poster
Partager sur d’autres sites