Aller au contenu
Berale24

HC2 & HCL - Version 4.110 - Stable - 04/01/2017

Recommended Posts

Je suis toujours avec admin. Le wizard apparaît à la connection et après on est tranquille donc oui@nico n'a aucune excuse pour ne pas faire la mise à jour

Envoyé de mon SM-G901F en utilisant Tapatalk

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

je confirme que fermer le wizard revient à chaque Login si on le ferme.

pour le niveau de batterie, j'espérais que la correction du bug 00002195 présente dans le changelog pouvait avoir de l'intérêt...

Envoyé de mon SM-G930F en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

moi je veux renommer le compte admin, mais pas en adresse email.... saurez-vous deviner à quel compte je pense ?

 

 

Révélation

root

 

Partager ce message


Lien à poster
Partager sur d’autres sites

tout est possible

 

ce serait même assez facile si tu es déjà root, mais avec le vrai compte système Linux, pas avec le compte "web"

Sans ça, l'assistant va te jeter, car il force le choix d'une adresse email

Partager ce message


Lien à poster
Partager sur d’autres sites

Je vous prie de passer votre root monsieur@lazer lol il est préférable de ne pas avoir accès au root on a déjà assez de soucis avec le lua et des scripts mal codé.




Envoyé de mon SM-G901F en utilisant Tapatalk

  • Upvote 2

Partager ce message


Lien à poster
Partager sur d’autres sites

Fibaro aime bien les lancements de nouveaux firmwares STABLES le jour de l'ouverture du CES à Las Vegas, souvenez-vous de la première v4 STABLE il y a 2 ans.... c'était mémorable... d'instabilité :2:

 

 

  • Upvote 6

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Après une après-midi, la box semble tenir, cependant j'ai remarqué, lorsqu'on a par exemple deux modules liés (pour commander des lampes)

Dans mon cas, si j'active une, cela allume la seconde

Jusqu'à présent au travers de l'interface, le second module s'activé

Avec le dernier Frimware, le module s'allume mais dans l'interface Web cela ne se rafraichis pas.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Pascal, si tu relis bien tu verras que j'ai déjà migré hier soir, mais je ferme le Wizard à chaque fois pour l'instant :)

Sinon Henry, moi je n'écris pas dans les fake, je ne fait que les commandes par l'API, ce sont des capteurs d'ouvertures en fait mes fakes (J'ai pas de température ou autre par exemple). Et cela fonctionne parfaitement avec un compte autre qu'admin...

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 56 minutes, Lazer a dit :

tout est possible

 

ce serait même assez facile si tu es déjà root, mais avec le vrai compte système Linux, pas avec le compte "web"

Sans ça, l'assistant va te jeter, car il force le choix d'une adresse email

Ha ok. Je ne suis pas root, donc non pour moi.

Dommage, ça ne m'enchante pas trop de remplacer mon login par un e-mail. Mais c'est comme ça, il y a pire :2:

Partager ce message


Lien à poster
Partager sur d’autres sites

Tiens, il me propose pas ma station netatmo comme station pour la météo à la place de YR, c'est parce que j'ai pas fais le Wizard encore ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Ça paraît quand même stable cette version.
Est ce que les bugs de la 4.100 sont disparus ?
De mémoire qq bugs Avec GEA et autres. (une solution avait été donné par qq un non ? mais je retrouve plus ...)

Pourquoi vous voulez pas mettre le mail comme compte ?
Pour les requêtes ext ?

 

ce que ces requêtes fonctionnent toujours en 4.1x :

local HC2 = Net.FHttp('127.0.0.1', 11111)

car j'ai bien envie de passé sur cette version; donc faut que je me prepare à debugger ce qui est connu...

Modifié par Sakkhho

Partager ce message


Lien à poster
Partager sur d’autres sites

Moi tout fonctionne sans soucis.

Partager ce message


Lien à poster
Partager sur d’autres sites

Nico : tout s'explique naturellement, si je fais une lecture, cela fonctionne avec un compte autre que admin (comme toi). Donc admin est nécessaire pour une écriture dans le fake Device ( ce qui parait Normal )

Sakkhho : Changer le user admin ça impose de modifier les applis qui accèdent à la HC2 et les requêtes externes qui accède à l'API. 

Pour ceux qui ne font que de la lecture ou des commandes (ex: Nico ) passer par un compte autre que admin est une excellente idée ( D'ailleurs c'est plus propre ) 

Pour ceux comme moi qui écrivent dans un (fake) device les essais démontrent q'il faut être admin

On avait un doute sur le passage de l'@ dans le user en fonction de la méthode utilisée pour accéder à l'API. 

Lazer nous a donné un exemple avec CURL qui fonctionne (il y a quelques temps sur le fil 4.101 je crois). 

Moi, en python j’ai pu passer un @ dans le pwd, comme je ne suis pas encore en 4.110 j’ai pas essayé dans le user mais ça devrai passer aussi.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je confirme que je n'ai jamais réussi à faire une écriture via l'API avec un compte standard. Il faut le compte admin.
Ce qui est dommage, car le mot de passe admin se balade dans l'IPX800 et FHEM.

 

Les comptes standards peuvent aussi être utilisés pour cliquer sur le boutons d'un VD ou exécuter une scène (ce que fait l'appli mobile)

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Moi je dois pas avoir Beaucoup de requête de ce type a part l écriture de la valeur de La conso d'eau issue du site de Veolia.

Mais je retrouve pas le post d une solution a un bug apporter en 4.10x.
Je suis sur qu il y avait qq chose à modifier. Quelqu un se souvient ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Hum, moi je n'ai rien modifié, les bugs de la première beta sont corrigés.

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

je suis certain qu'un membre avait proposé quelque chose mais impossible de remettre la main dessus

je vais fouiller

Modifié par Sakkhho

Partager ce message


Lien à poster
Partager sur d’autres sites

trouvé

 

ca, mais plus d'actualité je pense :

 

 

et ca :

toujours vrai pour les backup je suppose ?

 

quels sont les autres changements dans l'api depuis qq versions ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour ne pas que mon compte admin se ballade à droite et à gauche, je met à jour les labels d'un VD avec les informations que j'ai besoin (du style : ID, property, value) avec un utilisateur standard, puis un trigger va déclencher un scénario qui va mettre à jour un fake device.

Le mot de passe admin ne transite donc jamais. Tous les modifications d'état de mes modules sont centralisées sur la HC2, aucune application externe n'a le droit de modifier l'état d'un de mes modules, uniquement l'écriture de labels ou l'appui sur un bouton.

  • Upvote 3

Partager ce message


Lien à poster
Partager sur d’autres sites

Hey les gars, juste pour savoir... est-ce que vous savez s'il est possible de donner une unité à une valeur (exemple le plugin netatmo qui nous renvoie le niveau de CO2 genre 1200..; ça aurait été sympa de pouvoir lui coller ppm à la suite sur l'affichage).

Partager ce message


Lien à poster
Partager sur d’autres sites

@Steven, oui c'est vrai tu m'avais donne le code pour l'IPX d'ailleurs lol Faut que je mette en place @Nico, comment tu fais alors ? Explique nous

Partager ce message


Lien à poster
Partager sur d’autres sites

bon moi comme je fais de la domotique de papa j'ai pas beaucoup de cas ou le compte admin ce balade ... lol

 

Partager ce message


Lien à poster
Partager sur d’autres sites

×